Location Services Not Turning On - Pinephone

So, I open the settings application and toggle the Location Services selection to on. I then try to use the location in gnome-maps and I am confronted with a message that says that location services are turned off and I need to turn it on, despite it already being on, as seen here:


Note, the output of sudo mmcli -m any --location-status is:

  --------------------------------
  Location |         capabilities: 3gpp-lac-ci, gps-raw, gps-nmea, gps-unmanaged, agps-msa, 
           |                       agps-msb
           |              signals: yes
  --------------------------------
  GPS      |         refresh rate: 0 seconds
           | supported assistance: xtra
           |   assistance servers: http://xtrapath1.izatcloud.net/xtra3gr.bin
           |                       http://xtrapath2.izatcloud.net/xtra3gr.bin
           |                       http://xtrapath3.izatcloud.net/xtra3gr.bin

I am not sure what is going on here. It seems that GPS is working, but I have no location on any apps. I have tried using location services with Postmarket OS on this very phone and it works without a hitch.

1 Like

I had the same problem despite being on unstable with the latest updates. I had kept on updating a dev image from a couple of months ago. Reflashing the latest dev image solved the problem, GPS now works with Gnome Maps at least (I haven’t tried other applications with location services). I guess it’s a good idea to reflash from time to time instead of just updating.

3 Likes

Thanks for the advice and thanks for letting me know it’s not just me. I really don’t want to have to reflash the phone. I will if there’s absolutely no way around it, I will, but I’d rather find a solution that is a little less drastic. Any idea regarding what logs might be useful here, perhaps?

2 Likes

@djg_s39c Hi there! I am running factory installed Manjaro phosh, too. Have you been able to solve missing GPS functionality without reflashing the Manjaro image? I have tried some ‘mmcli’ commands in order to enable severeal GPS features, especially

sudo mmcli -m any --location-enable-gps-nmea
sudo mmcli -m any --location-get

Unfortunately ‘nmea’ auto-disables within few seconds. ‘–location-get’ will give some GPS output only if it is started fast enough.

1 Like

Hello @mentelhelf

Unfortunately I have nothing to update with on this issue. If it helps, here are some links which may be of use but, yeah, I think this is just one of those problems that may go unsolved until some smart cookie throws a tantrum and writes their own damn software for this. Note: I’ve heard others using the pinephone state that they have cracked this nut, but, I’ve tried all the OS’s they mentioned and I can’t get GPS reporting from anything other than cell towers, so, I’m skeptical.

Serial port terminal > Cannot open /dev/ttyS0: Permission denied - Ask Ubuntu
Proof of concept AGPS data loading for PinePhone · GitHub
mmcli man page - ModemManager - General Commands | ManKier
Unsatisfactory GPS reception on PinePhone?
[SOLVED] can’t open device “/dev/ttyUSB0”: Perm. denied (Linux permissions) - Using Arduino / Installation & Troubleshooting - Arduino Forum

1 Like

I also have very similar stance on this matter.
Haven’t found the solution but digging around to find the solution. Hopefully one day we will figure this out and will be useful for others as well.