Localization Libreoffice

first of all: I recently switched from Ubuntu to Manjaro. I installed the German localisation of Libreoffice 7 (Still) and was surprised that Libreoffice now appears in German, but no hyphenation, thesaurus or spelling was installed.
As I said, I come from Ubuntu, where all the necessary packages are automatically installed in the currently set system language without me having to install the individual sub-packages. Am I doing something wrong during the installation?
If not, I would like to know whether the installer (in this case Pamac) could be enabled to install all the necessary language files as happens with Ubuntu.


You need mythes-de and hunspell-de for thesaurus and spelling.
For hyphenation you need to Choose Format - Styles and Formatting, and then click the Paragraph Styles icon. Right-click the paragraph style that you want to hyphenate , and then choose Modify. Click the Text Flow tab. In the hyphenation area, select the Automatically check box.

Thank you for the quick reply. By the way, for hyphenation, the package “hyphen-de” still needs to be installed.

But is it intended (maybe later) that these packages will be installed automatically if the default language in the system differs from English?

If not: perhaps you could include this request as a suggestion for an improvement of the package manager (or maybe this can be included in the language module)?

I don’t think that can be done trough PKGBUILD. Also optional dependencies need a different handling for such scenarios. Let me ping @Manjaro-Team and see if they kan find a better way to deal with this.

In Manjaro Settings Manager you will find an option for installing language packages.

Libreoffice installation requires the user to install the necessary language packs as there is no way of knowing which language packs are preferred.

The language settings is often set to a mix of languages.

Because Manjaro does not guess what the user wants it is a user task to install the desired locale packages.

For example, I have installed hyphen-de manually. It should then be displayed in the Manjaro Settings Manager as an installed language package.
But as you can see in the screenshot, it is not displayed there. Even before I installed the package manually, I was not offered any language packages for installation.

I have now installed Thunderbird as a test. But I don’t get any packages to choose from via the Manjaro Settings Manager. Is there something wrong with the Manjaro Settings Manager?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.