Locale settings problem!

I have a big problem and i think it’s a KDE sys error.
When i coose sr_RS@latin from Locale settings, i have got Serbian Cyrilic locale whatever i do but i don’t wont Cyrilic.
I have try to edit /etc/locale.gen and locale.conf but wthout any success. Whhatever i do i have got an Serbian Cyrilic.
Is there a way to get Serbian Latin format on a Latin letter?

TNX for all

Have you tried using the Manjaro Settings Manager GUI tool for Locale ?

manjaro-settings-manager -m msm_locale

Tried just now and all is the same because msm_locale is a gui part from Locale/Settings :frowning:

If you click on Add in Locale GUI

and choose Language - Srpski

and Territory - Србија

The Locale will show the Serbian Cyrillic Locale - sr_RS
but you should be able to click on it and change it to Serbian Latin - sr_RS@Latin


Yes. You’re righ 100% but in theoretic when i chose as You described and after reboot there are Cyrilic Locale settings only. I don’t know but system turns Latin to Cyrilic and thats it on all KDE distros (not only Manjaro)!!!

Locale - My system is still using wrong language | ArchWiki
KDE Plasma also allows to change the UI’s language through the system settings. If the desktop environment is still using the default language after the modification, deleting the file at ~/.config/plasma-localerc (previously: ~/.config/plasma-locale-settings.sh) should resolve the issue.

There is definitely something strange with the KDE system as the base !!!
At the moment, I have changed the entire sys language to Serbian Latin, and after restarting the computer, my system is Serbian Cyrillic. As if Serbian Latin does not exist in the KDE system at all !!!

While I don’t know the serbian language and I don’t know how this is supposed to work in KDE
I still have an idea:
from a terminal (or any other editor that let’s you edit as root)
open and edit


sudo nano /etc/locale.gen

make sure that all the locales starting with sr_ are uncommented
and then run
sudo locale-gen

to generate the selected locales - maybe they wheren’t even available to choose from because of this?

I know that both sr_RS UTF-8 and sr_RS@latin UTF-8 give me cyrillic characters
while sr_ME UTF-8 gives me latin characters
but that is the extent of my knowledge.

After the generation of all these locales, you should then also be able to select them in KDE.

I will try it latter and give a report here.
Tnx for advice.

All my effort (and forum members effort) dropped to a water.
Here it is las settings mentioned by @Nachlese and bump :frowning: . I am dissapointed to KDE :frowning:

Whatever i choose, always setted as Cyrillic letter :frowning: (i am loosing my hair)

after editing /etc/locale.gen
and running
sudo locale-gen

locale -a
shows me those 3 serbian locales as available:

locale -a

What does it show for you?


among them?

I don’t see them in your list.
These are the ones which give you serbian language in latin characters.
(they should …)

They have to be, after you edited
and running
sudo locale-gen

I always found it a bit confusing but there are the KDE Settings
and then there are the Manjaro System Settings.

Applications → Settings → Manjaro Settings Manager

Go there, select the locale, one or all of them,
then go to where you tried to set them now
and tell KDE to use them.

But I have to say that I was unable to convince my (test) system to actually show me serbian in latin, even when using this locale.
It is set to use this locale for the system language.
The result after reboot is.
cyrillic messages
but still my default language (de)
It is strange and confusing …

:sob: :sob: :sob:
I did everything that was suggested to me, but it’s always the same.
After each restart, Locales turns to Cyrillic, whatever I do and whatever I choose
It’s the same on KUbuntu raised in Oracles VB vm, so I think it’s KDE SYSTEM ERROR and I don’t know who to contact :frowning:

The best I could achive (in Xfce) was some messages and some other things like time and date and “wlan connection established” in latin but still all folder names and most of the menu in cyrillic.
It is strange.
Maybe it is not fully translated?
But that is hard to believe.

I tried to set the language in the login-screen, because Xfce doesn’t have the language setting option - and discovered another strange thing:
the settings I chose where only fully applied the second time I logged in.
On first login the changed setting was ignored/not applied.

When i change Locale settings, LogOn screen/letters changes only on reboot. Not to LogOut/LogIn…
Manjaro Gnome and other Gnomastic distros working like a charm for Locale settings :frowning:

I also tried setting the system locale with localectl set
but in Xfce - like for you in KDE - it worked only partially.

locale -a

locale -a

localectl status
sudo localectl set-locale sr_ME.utf8

no matter which locale I chose - it wouldn’t work to show serbian in latin characters
I have no idea why it seems to work in Gnome.
There must be a difference - but I don’t know about it.