Liveusb - No Display Output


I am trying to install Manjaro on an old Lenovo G505s that currently runs Mint on it.

CPU: AMD A8-4500M with Radeon HD Graphics
GPU 1: AMD ATI Radeon HD 8570A/8570M
GPU 2: AMD ATI Radeon HD 7640G
Memory: 7158MiB

Unfortunately I only see the word ‘GRUB’ for about half a second on the screen when the laptop boots from the liveusb. It seems that the live system gets loaded (fan activity, cpu noise) but the screen remains blank.

I tried using 2 different usb sticks, 2 different flashing tools (Etcher and Mintstick), 4 different isos (latest 3 XFCE LTS isos, i.e.: Kernel 54 and 510 + XFCE 513) and all usb ports available.

I can load the latest EndeavourOS liveusb with no issues on this machine.

Do you have any clue about why is this happening? Thank for reading these lines and your support. Sincerely yours,

Hello @link314 :wink:

So there is no Grub Boot Menu?

My thought about it. Manjaro may have a problem with that ATI Dual Graphics Crossfire technology.
I would turn it off in the bios and try to start the stick once again.

Hello megavolt, there is no grub boot menu. I just see the word ‘GRUB’ on the top left corner of the screen and afterwards a blank screen

Hello Manfrago, thank you for answering. I did try to set the variable ‘Graphic Device’ to ‘UMA’ and as it displayed the blank screen, i changed it to ‘Compatible’ in the BIOS setup. It did not work though.

I believe there is then a problem with screen resolution and the grub theme maybe?

What is the native resolution of the screen?

With Lenovo, the UMA mode only uses the integrated graphics. For the time being, I would leave it like that for the installation. It’s not the solution, but it’s a good base.

The machine is running Mint with a screen resolution of 1366x768 @ 60Hz

I know when dual booting mint grub can’t boot manjaro but manjaro can boot mint. I’m guessing it maybe connected to that

But the situation is:

I only see the word ‘GRUB’ for about half a second on the screen when the laptop boots from the


1 Like

Here you can read that the installation was possible at least under manjaro 18 KDE and Cinnamon. That gives to me the crazy idea to test the community edition Cinnamon with your stick …

Hi Manfrago, Cinnamon would be too heavy for this machine. I installed other arch based distro with ease. Thank you for your help though.

Out of personal interest only: Have you ever tried whether cinnamon starts on your laptop?

Hi Manfrago, I did not try to boot the Cinnamon version. I tried to create a new partition table in the USB stick using Gparted (gpt instead of msdos) with no positive result