Live USB Won't Load After Grub Menu

Recent downloads yesterday of gnome or xfce live and installed onto USB on Dell XPS-13 9380 boot into Grub menu. Manjaro then fails with a terminal prompt and error “run/miso/sfs/livefs wrong fs type, bad superblock on /dev/loop0, etc.” Three or 4 months ago an older version of Manjaro Gnome live on USB booted normally and installed onto an available partition. Also, yesterday an Ubuntu live USB booted normally and installed Ubuntu on an available partition. I have tried various USB memory sticks and always same result. Any help would be appreciated.

Following is the Grub edit menu from the Manjaro Live USB:

secure boot disabled in bios;
fast boot disabled in bios - you may not have this option;
fast startup disabled in windows, if you are dual booting;
RAID disabled, and AHCI enabled - if you are using windows and you are on RAID, dont switch to AHCI, otherwise you will not be able to boot into windows…
use Ventoy to flash iso…

The above mentioned and double check your image. Just tried the newest version of the gnome version to recreate your problem and it didn’t boot: the image was corrupted while copying on my ventoy drive and I compared the checksum only after trying to boot. Tried it again (md5 checksum matched this time) and it booted flawlessly. So, my advice would be to check the checksum of your image and the image on your stick.