Live installer won't recognize internal HD on HP 2000 laptop

Laptop is HP 2000 core I3 processor, 8gbRAM 1Tb int HD. Windows removed and Pop OS installed w/o difficulty. I want to install Manjaro, instead of PopOS, but Manjaro will not recognize the HD. Yes, secure boot is off, there are no other bios settings that can be changed, no Ubuntu won’t load either ( yes I know that PopOS is Ubuntu, but the darn computer does’t seem to know that.) I have formatted the drive and it still won’t recognize Manjaro. PopOS will load, as will Fedora, neither of which is the distro I want on the laptop. I would really like to install Manjaro. I have checksummed the iso, downloaded it again and checked it again, no luck. anybody have any suggestions on how to get Manjaro to recognize the internal HD? Thanks in advance.

Welcome here at the Manjaro forum, @Okamikur,

Have you tried to create a new GPT partition table on that disk?
Have you tried to change the SATA controller mode from RAID to AHCI?
Check if you have any TPM settings in your firmware and disable them.

One or two things to note - AHCI and LVM.

I don’t now the current status of Calamares and LVM but at least Fedora uses LVM as default and this can be a little confusing when trying to replace it.