Little problem with qemu/virt manager


I have a minor problem when I’m launching qemu, everytime I boot my computer, I have to restart qemu with those following commands to connect virt-manager to default network and activate the socket :

sudo systemctl restart libvirtd      
sudo virsh net-start default

How can I fix this permanenently ?

Enabling service should solve problem:

sudo systemctl enable libvirtd

Do you use WiFi as a base for your default libvirtd network? How did you configure your default libvirtd network?

OK, I still have to enable the network :

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/", line 65, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/", line 101, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/object/", line 57, in newfn
    ret = fn(self, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/object/", line 1329, in startup
  File "/usr/lib/python3.9/site-packages/", line 1353, in create
    raise libvirtError('virDomainCreate() failed')
libvirt.libvirtError: Requested operation is not valid: network 'default' is not active

I’m on LAN, no particular configuration, just installed from pacman

for the network:

virsh net-autostart default

to disable

virsh net-autostart --disable default

Thanks it worked perfectly !

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.