Little help with MS Teams

Hello all

I am am having “slight” problem with Microsoft Teams.
So my kids school was inviting me to MS teams group, where I can see some picks, get some updates of the schools projects, etc.
So I got teams from snap (seemed to be the latest version compared to flathub), made an account, and everything seems to work.
However, when I click the link from the email, the teams client “launches” but nothing happens. No groups added, no nothing (I have also experienced this with links for meetings).

Am I missing any configuration?
I am fully aware that this is not MS help forum, but maybe someone here has had similar experience and can point me in the right direction.

I am actually struggling to word this properly into my duckduck (google if duckduck doesn’t find anything) search, so bear with me.

inxi -Fazy
~ >>> inxi -Fazy                                                                                             
System:
  Kernel: 5.9.3-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.9-x86_64 
  root=UUID=10a7e7a7-da03-41b9-b65c-942b75a7ad97 rw rootflags=subvol=@ quiet 
  udev.log_priority=3 
  Desktop: KDE Plasma 5.20.2 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-cx0xxx 
  v: Type1ProductConfigId serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 8478 v: 70.57 serial: <filter> UEFI: Insyde v: F.22 
  date: 04/21/2020 
Battery:
  ID-1: BAT1 charge: 33.4 Wh condition: 31.9/52.8 Wh (60%) volts: 12.8/11.6 
  model: Hewlett-Packard PABAS0241231 type: Li-ion serial: <filter> 
  status: Unknown 
CPU:
  Info: Quad Core model: Intel Core i5-8300H bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10) microcode: D6 
  L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 36812 
  Speed: 899 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 849 2: 858 3: 859 
  4: 890 5: 849 6: 873 7: 856 8: 854 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Hewlett-Packard 
  driver: nvidia v: 455.38 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:1c8d 
  Device-3: Cheng Uei Precision Industry (Foxlink) HP Wide Vision HD 
  Integrated Webcam 
  type: USB driver: uvcvideo bus ID: 1-5:5 chip ID: 05c8:03bc 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: modesetting 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") 
  diag: 394mm (15.5") 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.2.1 
  direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci 
  bus ID: 00:1f.3 chip ID: 8086:a348 
  Sound Server: ALSA v: k5.9.3-1-MANJARO 
Network:
  Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter 
  vendor: Hewlett-Packard driver: rtw_8822be v: N/A modules: rtw88_8822be 
  port: 4000 bus ID: 02:00.0 chip ID: 10ec:b822 
  IF: wlo1 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus ID: 05:00.0 
  chip ID: 10ec:8168 
  IF: eno1 state: down mac: <filter> 
Drives:
  Local Storage: total: 1.60 TiB used: 479.27 GiB (29.3%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLW256HEHP-000H1 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: CXB73H1Q scheme: GPT 
  ID-2: /dev/sda type: USB vendor: Western Digital model: WD My Passport 0740 
  size: 465.73 GiB block size: physical: 512 B logical: 512 B serial: <filter> 
  rev: 1007 scheme: GPT 
  ID-3: /dev/sdb type: USB vendor: Toshiba model: External USB 3.0 
  size: 931.51 GiB block size: physical: 512 B logical: 512 B serial: <filter> 
  rev: 5438 scheme: MBR 
Partition:
  ID-1: / raw size: 237.97 GiB size: 237.97 GiB (100.00%) 
  used: 70.09 GiB (29.5%) fs: btrfs dev: /dev/nvme0n1p2 
  ID-2: /home raw size: 237.97 GiB size: 237.97 GiB (100.00%) 
  used: 70.09 GiB (29.5%) fs: btrfs dev: /dev/nvme0n1p2 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 55.0 C mobo: 29.8 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 319 Uptime: 4h 32m Memory: 15.53 GiB used: 5.11 GiB (32.9%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 1345 
  pacman: 1333 lib: 374 flatpak: 4 snap: 8 Shell: Zsh v: 5.8 
  running in: konsole inxi: 3.1.08 

Found a second Flatpak which I installed and that works. So of the 3 packages I have tried the one marked Microsoft Teams (com.microsoft.Teams) 1.3.00.25560 is working for me.

Just for information, there is also a “teams” AUR package available.

https://aur.archlinux.org/packages/teams/

My pacman hasn’t shown me the AUR packages for teams, only Snap and Flatpak in the “Show all” section. Forgot to check AUR section.

Thank you for the reminder.

But don’t install blindly from AUR, check the info about a package on aur.archlinux.org

1 Like

Thanks man, I actually didn’t know about this page.

Hi, I m a newbie in manjaro and ı tried to download that package by using the following command : sudo pacman -U https://packages.microsoft.com/repos/ms-teams/pool/main/t/teams/teams_1.3.00.25560_amd64.deb but ı got the error: error: '/var/cache/pacman/pkg/teams_1.3.00.25560_amd64.deb': package missing required signature. Can u help me about it ? :slight_smile:

@garavel
It is not good to download anything from the web. I don’t know how to install from that package. Instead open Add/Remove software and find it there. You might need to go into settings and enable AUR.
To enable AUR open add/remove

Click the three lines to the right and select the second lowest option.
Screenshot_20201107_234214

Enable AUR
Screenshot_20201107_234239

That worked :slight_smile: Thank you!!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.