Linuxtrack installation won't build Wine-Bridge

Is anyone here using Linuxtrack? I’ve done everything I can think of to get the Wine-Bridge running and I have been unsuccessful to date.

App: GitHub - uglyDwarf/linuxtrack: Headtracking for Linux/Mac

I can compile it, I can get it working, head tracking is working awesome, but the portion to make it build the Wine-Bridge fails. I have tried everything to do with the configure command and failed to date.

I posted about the issue here, but think it will be a long time prior to getting an answer: Will not build Wine-Bridge · Issue #197 · uglyDwarf/linuxtrack · GitHub

Hoping someone has either A. Solved this problem, or B. Knows a lot more about compiling than I do and knows how to force it.

Are you building from the latest commit or the 0.99.19 tag from 2016? Providing that information would be very helpful in your upstream issue you created.

The Linuxtrack-master which is updated for QT5 and is version 0.99.20

There is no 0.99.20 tag.

This has nothing to do with Manjaro. Please edit your upstream issue to include information that will help the developers help you.

I did. Thanks for the tip. Uglydwarf has not been updating the tags. It is 0.99.20 if you build it from the master branch.

The one from 2016 requires QT4 which doesn’t exist anymore.

Also note I had to mod the ‘ltr_srv_master.cpp’ file and add the line ‘#include <pthread.h>’ to get it to compile properly. Adding this in here in the event someone else wants to attempt a build.

I am so close I can taste it, but I have spent 2 days trying to get this to work which is why I am asking for support.

Manjaro does not provide support for third-party applications we’eve never heard of.

Please focus on your upstream issue instead as that is the proper avenue of support.

1 Like

Closing it so fast makes no sense. It is the correct topic for that category. Let it open a bit longer.

@xman1 reading your post shows me that you know nothing about compiling software from source. For me it looks like a missing dependency issue. Did you check the soure ode for what the application needs? Maybe ask users from the AUR for more hints on how to compile it: AUR (en) - linuxtrack

Currently nsis does not build with latest scons so use scons 4.1.0 from which builds. Then linuxtrack will detect and also build the wine bridge.

@megavolt Agreed.

@xman1 I apologize for closing the thread.

Not a problem!

I have it built from source. Version 00.99.20 which uses QT5 over QT4. It is that it doesn’t find Wine for some reason. It is supposed to find the wine libraries with --with-wine-libs=-L, but in my case, it doesn’t work.

I notice on the ./configure command, if you type --help, it will tell you what options there are:

Optional Packages:
  --with-PACKAGE[=ARG]    use PACKAGE [ARG=yes]
  --without-PACKAGE       do not use PACKAGE (same as --with-PACKAGE=no)
  --with-pic[=PKGS]       try to use only PIC/non-PIC objects [default=use
  --with-gnu-ld           assume the C compiler uses GNU ld [default=no]
  --with-sysroot=DIR Search for dependent libraries within DIR
                        (or the compiler's sysroot if not specified).
  --with-xplane-sdk       specify path to XPlane SDK
  --with-wine-libs        specify Wine libraries to link aginst
  --with-wine64-libs      specify Wine64 libraries to link aginst
  --with-lib32-dir        specify 32bit library directory (usually needed only
                          on amd64 arch.)
  --with-opencv-libs      specify OpenCV libraries to link aginst
  --with-opencv-cflags    specify OpenCV includes

I am going to investigate what you posted about scons. I didn’t run into any errors compiling. Just that it doesn’t see wine. Maybe I am doing it wrong (most likely) but I am at least learning.

Still working on this… This post holds some clues… he pointed his at the bin file and not the library file? Hmmm…

Work has me tied up a lot so I have not had time to make much progress for a bit. Back now though. Will get back to testing soon. If I find a solution to this, I will share. I can’t be the only one that plays X-Plane or DCS or any of the other flight sims.