Linux won't boot (freezes on Lenovo logo screen)

Hi there,

So I followed some steps from Archwiki
to solve my issue with nvidia(couldnt wake up from sleep, black screen). After that when I rebooted, linux wouldnt load, i selected the kernel and it just stays on the lenovo screen and responds to nothing.

Here are the steps that i did:
From here (1.8,1.11)title/NVIDIA/Troubleshooting

I created blacklist.conf
And added

install amdgpu /usr/bin/false
install radeon /usr/bin/false

In /etc/modprobe.d/blacklist.conf

Then I also added `acpi_osi=! acpi_osi=Windows 2015 kernel parameter to boot loader configuration.

Then I also did the

Point 10 from NVIDIA/Tips_and_tricks#Preserve_video_memory_after_suspend

After that I restarted and it couldnt go forward from lenovo logo.

I have timeshift. Is there a way to boot or restore timeshift from grub cmd line? Or at least delete the changes I did. I tried the steps to boot, but there is not sda1 in dev directory(there is nothing), so it wasnt able to boot.

I also have dual boot linux+ windows


  Kernel: 6.5.9-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    Desktop: KDE Plasma v: 5.27.9 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82UX v: Lenovo Slim 7 16ARH7
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76530 WIN
    serial: <superuser required> UEFI: LENOVO v: KLCN19WW date: 06/08/2023
  ID-1: BAT0 charge: 52.4 Wh (78.7%) condition: 66.6/75.0 Wh (88.8%)
    volts: 15.8 min: 15.4 model: LENOVO AP16L5J status: not charging
  Info: 8-core model: AMD Ryzen 7 6800HS Creator Edition bits: 64 type: MT MCP
    arch: Zen 3+ rev: 1 cache: L1: 512 KiB L2: 4 MiB L3: 16 MiB
  Speed (MHz): avg: 778 high: 2068 min/max: 400/4785 cores: 1: 1467 2: 400
    3: 400 4: 400 5: 2068 6: 400 7: 400 8: 400 9: 400 10: 400 11: 1397 12: 1732
    13: 400 14: 400 15: 1396 16: 400 bogomips: 102267
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA GA107BM [GeForce RTX 3050 Mobile] vendor: Lenovo
    driver: nvidia v: 535.129.03 arch: Ampere bus-ID: 01:00.0
  Device-2: AMD Rembrandt [Radeon 680M] vendor: Lenovo driver: amdgpu
    v: kernel arch: RDNA-2 bus-ID: 05:00.0 temp: 39.0 C
  Device-3: IMC Networks [] driver: uvcvideo type: USB bus-ID: 5-1:2
  Display: wayland server: v: with: Xwayland v: 23.2.2
    compositor: kwin_wayland driver: X: loaded: amdgpu,nvidia
    unloaded: modesetting,nouveau dri: radeonsi gpu: nvidia,amdgpu resolution:
    1: 1920x1080 2: 1707x1067
  API: EGL v: 1.5 drivers: nvidia,radeonsi,swrast platforms:
    active: wayland,x11,surfaceless,device inactive: gbm,device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (rembrandt LLVM
    16.0.6 DRM 3.54 6.5.9-1-MANJARO)
  API: Vulkan v: 1.3.269 drivers: nvidia,radv surfaces: xcb,xlib,wayland
    devices: 2
  Device-1: AMD Rembrandt Radeon High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 05:00.1
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo
    driver: snd_pci_acp6x v: kernel bus-ID: 05:00.5
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 05:00.6
  API: ALSA v: k6.5.9-1-MANJARO status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 0.3.83 status: off
  Server-3: PulseAudio v: 16.1 status: active
  Device-1: Realtek vendor: Lenovo driver: rtw89_8852be v: kernel port: 2000
    bus-ID: 02:00.0
  IF: wlp2s0 state: down mac: <filter>
  Device-2: KYE Systems (Mouse Systems) GF3000F Ethernet Adapter
    driver: hid-generic,usbhid type: USB bus-ID: 3-1:2
  Device-1: Realtek [] driver: btusb v: 0.8 type: USB bus-ID: 3-3:3
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 931.51 GiB used: 100.81 GiB (10.8%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WD BLACK SN850X 1000GB
    size: 931.51 GiB temp: 36.9 C
  ID-1: / size: 577.2 GiB used: 100.75 GiB (17.5%) fs: ext4
    dev: /dev/nvme0n1p5
  ID-2: /boot/efi size: 256 MiB used: 67.5 MiB (26.4%) fs: vfat
    dev: /dev/nvme0n1p1
  Alert: No swap data was found.
  System Temperatures: cpu: 51.6 C mobo: N/A gpu: amdgpu temp: 43.0 C
  Fan Speeds (rpm): N/A
  Processes: 377 Uptime: 54m Memory: total: 16 GiB note: est.
  available: 13.34 GiB used: 5.11 GiB (38.3%) Init: systemd Compilers:
  gcc: 13.2.1 clang: 16.0.6 Packages: 1424 Shell: Zsh v: 5.9 inxi: 3.3.31

I know it is kind of dumb but anyway. I will be very grateful if someone could help:)

Welcome to the forum! :vulcan_salute:

Only if you are using btrfs, along with the btrfs-enabled version of GRUB.

However, you can use timeshift from the live USB. All you need to do is tell it where your root filesystem is and where your backups are. It’ll then restore the backup of your choosing and reboot the machine.

1 Like

Thank you for your reply, sorry I am a bit new to this all, shouldnt I mount the root partition by /dev/sdX from live USB to be able to then restore the snapshot? when I list the /dev directory in grub cmd line its empty:(

Also, do you know what went wrong? Is there something I did wrong in the steps?

To be honest, I don’t know. timeshift can and does automatically mount (and unmount) the pertinent volume with the backups, but I don’t know whether it does that with the root filesystem.

I suppose that simply telling it where the root filesystem is would possibly cause it to automatically mount that. But in the event of doubt, you can always just try it. It won’t do any harm.

This is perfectly normal, because /dev is a mountpoint for a special memory-based filesystem called devtmpfs, which is created and populated by the kernel at boot time, and then managed by udevd during runtime. So there is nothing there to restore. :wink:

This I cannot tell you, because I don’t have Nvidia graphics and I generally avoid topics regarding graphics drivers, exactly because it’s not my field of expertise. :wink:


Okay, thank you I’ll try:)

1 Like

Why would this be necessary?
Do you have multiple GPUs?

Even in the case of hybrid graphics mhwd profiles are provided.

Where did you get 2015? Is it accurate for your hardware?
Also, if you didnt run sudo update-grub afterwards it would have no impact.

Both of the above are pretty easy to remove.

Though you may need to chroot in.

As to

This has multiple parts and some portions do not describe concrete steps to take … so I’m not sure what exactly you did while following this portion of the guide.

1 Like

Hi, thanks for the reply. Yes I have hybrid graphics AMD and Nvidia.

The windows 2015 was accurate for my system I checked it with

strings /sys/firmware/acpi/tables/DSDT | grep -i 'windows ' | sort | tail -1

I run update-grub afterwards.

Here are the steps I did for point 10

sudo nano /etc/modprobe.d/nvidia-power-management.conf

Added this to the conf file

options nvidia NVreg_PreserveVideoMemoryAllocations=1 NVreg_TemporaryFilePath=/var/tmp-nvidia


sudo systemctl enable nvidia-suspend.service
sudo systemctl enable nvidia-hibernate.service

sudo systemctl enable nvidia-resume.service

Before suspending, wrote “suspend” to /proc/driver/nvidia/suspend :

echo "suspend" | sudo tee /proc/driver/nvidia/suspend

After waking up

echo "resume" | sudo tee /proc/driver/nvidia/suspend

Ill check the “How to” and give it a try thank you:)

I booted from live USB, did

manjaro-chroot -a

It mounted /dev/nvme0n1p5. Knowing that, I went back to grub cmd line, and was able to specify the root. Then I booted to my manjaro, deleted the changes I did and was able to boot normally. I still did not understand the cause but luckily nothing severe happened and I was able to recover.

Thank you all for the replies:) What is the best practice to prevent/easily solve these kind of problems? Is there a specific thing to do or it depends?

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.