Linux tools for RAM stress test

Some people warned me that the use of XMP is risky, because it can cause instability, corrupt data. Other people say I’ve got nothing to worry about.
I’ve enabled XMP and now I’m wondering if I need a RAM stress test.
My motherboard only has UEFI.
I find it very weird that there aren’t more tools for memory stress testing. Is it because the risk is very low?
Did you stress test your RAM and, if you did, which tool did you use?

Boot a live .iso and use the memtest boot option. There even is a free downloadable .iso of the (now commercial) memtest86

5 Likes

It’s also baked into Grub (at least for me it is)

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

:innocent:
P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

I’ll be sure to bear that in mind. Thank you for being cordial about it.

I’ll come back to write about how I carried out the test as soon as I do it.

EDIT I was unable to do anything. First I tried the GRUB, but I didn’t see the memtest listed. Then I booted a live Manjaro session, but I didn’t see the memtest there either.

1 Like

Try the UEFI version (sorry missed that in the solution and your question.

(Solution edited to include that crucial bit of information)

So the UEFI version is the bootable USB I used to install Manjaro? I couldn’t find memtest in the menu.

That’s because memtest86+ is not compatible with UEFI. You’ll want to install memtest86-efi.

See Stress testing - ArchWiki

For MBR yes, not UEFI.

No, however it is possible on specific combos of hardware that you can have issue with instability, for example a Ryzen 3600 on a B450M Gigabyte board, with the Corsair 3200 8GBx2 kit, with XMP it is unstable, you need to modify one value after you apply the XMP values, just raise the tRC from its default to just a little more. Some kits are not well tested on every hardware, or optimized for Intel CPU and have issues with AMD. But most of the time enabling XMP is just the best choice, free performance, optimal use of hardware, no issue.

I used Mprime tool to test the RAM, doing “large FFTs” tests for multiple loops (as many as possible but it takes time and you don’t want to use the computer during that time) and see if any error pops up, if it detects just one error in the calculation there is an issue, most likely with the RAM regarding the selected test.

Memtest may be the better tool, but for a quick check Mprime was fine for me.

1 Like

Thanks.

Are there any safety concerns regarding the use of memtest and Mprime? Some people are suspicious about memtest.

Btw, I have i5-11600K, Z590-A PRO and HyperX Fury.

Same people who told you XMP is risky? :stuck_out_tongue:

These tools should not be a safety concern. These kind of tools however will push the hardware, but the hardware is made for that so it should be fine.

1 Like

No, the one I edited into the original solution:

Take the UEFI one and “burn” it to its own USB stick and boot that!

(Sorry for being unclear)

:frowning:

I downloaded and extracted the memtest86 ISO for Linux.

I tried to make a bootable USB from terminal, but I couldn’t boot from it.

Then I made a bootable USB with ImageWriter. I changed the boot priority in BIOS, but it won’t boot.

I haven’t used dd in a long time and use balena etcher. Could you give that a go, please?

:crossed_fingers:

I stopped using Etcher because of privacy concerns.

I burned the memtest86 ISO, and then the Arch Linux ISO, to the USB stick in the terminal, following the instructions from the PassMark website. I also followed some general dd instructions from another site. I still couldn’t boot into memtest86, and when I booted Arch I didn’t see a memory test option.

The command from “another” site:

sudo dd if=/home/happy/Downloads/Arch\ Linux/archlinux-2021.08.01-x86_64.iso of=/dev/sda5 bs=1024k status=progress

Mem test has long been the go to for testing Ram stability and consistency.

If you have just enabled default XMP I would be pretty confident you are ok. If you manually played with timings and all that you might need to do some more testing.

After mem test you can use https://www.phoronix-test-suite.com/ to run some memory bench marks if you want. You can install it from the AUR Here

1 Like