Linux-latest and linux58 are in conflict

I am trying to do a regular update in Octopi but i get the message “transactionerror continue in terminal”

But in terminal i got this:

sudo /usr/lib/octopi/octphelper -ts
:: Synchronizing package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade…
:: Replace linux57 with community/linux-latest? [Y/n] Y
:: Replace linux58 with community/linux-latest? [Y/n] n
:: Replace linux58-acpi_call with community/linux-latest-acpi_call? [Y/n] n
:: Replace mhwd-nvidia-418xx with core/mhwd-nvidia? [Y/n]
:: Replace mhwd-nvidia-430xx with core/mhwd-nvidia? [Y/n]
:: Replace mhwd-nvidia-435xx with core/mhwd-nvidia? [Y/n]
:: Replace mhwd-nvidia-440xx with core/mhwd-nvidia? [Y/n]
:: Replace mhwd-nvidia-450xx with core/mhwd-nvidia? [Y/n]
:: Replace mhwd-nvidia-455xx with core/mhwd-nvidia? [Y/n]
warning: sndio: local (20180120-1) is newer than community (1.7.0-3)
resolving dependencies…
looking for conflicting packages…
:: linux-latest and linux58 are in conflict. Remove linux58? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: linux-latest and linux58 are in conflict
Press any key to continue…

Any idea have to solve this conflict?

Welcome @dafnie

Try to update again and say yes by entering y when asked to remove linux58. Linux 5.8 is EOL.

1 Like

I have not been asked to remove linux5.8, but i got this message when saying yes to replace linux5.8

error: failed to prepare transaction (could not satisfy dependencies)
:: removing linux58 breaks dependency ‘linux58’ required by linux58-nvidia-390xx
:: installing nvidia-390xx-utils (390.138-1) breaks dependency ‘nvidia-390xx-utils=390.132’ required by linux58-nvidia-390xx

Install kernel 5.10. Reboot.Then remove kernel 5.8, then please post

inxi -Fxxxza --no-host

In case you have only one graphic adapter you could then run

sudo mhwd -a pci nonfree 0300

Have tried Kernel 5.10 and it give me black screen.
Have tried kernel 5.4 but error is the same.

Running on Linux Not sure if it is stable

Sorry, you need advice from a Nvidia expert from the forum. :man_shrugging:

Somehow you need to get rid of

If nouveau driver would work for you this could be a step in between, if it would allow you to boot into kernel 5.10. If this works you could use my above command to install Nvidia drivers for kernel 5.10 then.

The good part: If you get this solved now, you will have peace on this front for a while as 5.10 will be a LTS kernel.

By the way, output of the inxi command would still be quiet helpful…

1 Like

Is nvidia 390 not still available with the 5.4lts kernel? I thought the team were keeping the one legacy driver

nvidia-390xx is available in 5.4 and 5.10 (and other kernels). You can always check this here:

Hmm, Now I have upgraded.
But after reboot i can not boot in to any linux (5.10, 5,9 or 5.4) in grub.
After grub booting the screen stays black. :weary:
What to do now?

After the recent update all nvidia drivers except 455xx and 390xx are dropped due nvidia’s policies. Because they are not compatible with the newest kernel.

If you really need the nvidia 340xx driver, you will have to use an LTS Kernel like 5.4 and package the driver yourself.

Otherwise i recommend to use the nouveau driver if possible.

Also try the 390xx driver. Maybe it supports your gpu.

mhwd -r video-nvidia
mhwd -i video-nvidia-390xx

To over come your actual problem is removing nvidia driver completely and also mhwd and reinstall it.

This quote is in german, but maybe you understand the commands:

Thanks, but have do i get a commandline when i can not boot?

If the display-manager just fails, then you should at least be able to switch to another TTY by typing CTRL + ALT + F3. Then login there and type the commands there.

If not possible, you will have to boot a manjaro install disk, chroot by typing: manjaro-chroot -a and solve the problem there.

Hmm, all ok until I reach “pamac install mhwd mhwd-db”
Error: can not do stat() on /var/lib/pacman/sync/*.files: no such file or catalog.
Nothing to do.
Transmission done.

ok… seems no database files are there?

try this:

sudo pamac upgrade --force-refresh --no-aur

and then install again.

Hmm, after this i got.
/ mhwd --auto pci nonfree 0300
Error: No config found for device: 0000:01:00.0

/ mhwd -i pci video-nvidia
Error: config nvidia-nvidia does not exist

can you return

sudo mhwd-kernel -li
sudo mhwd -li
sudo ls /etc/mkinitcpio.d/*.preset

additionally also this:

pamac search --no-aur --installed nvidia
ls /var/lib/mhwd/db/pci/graphic_drivers/
ls /var/lib/mhwd/local/pci/

But i believe no packaged driver is supported for your gpu right now. You will need to build the driver 340xx yourself or use the nouveau driver.

  1. Currently running 5.4.85-1-manjaro

  2. No installed pci config3
    No installed usb configs

  3. /etc/mkinitcpio.d/linux510.preset /etc/mkinitcpio.d/linux54.preset /etc/mkinitcpio.d/linux54-rt.preset /etc/mkinitcpio.d/linux59.preset

then try

report any errors

sudo mkinitcpio -P

if ok

sudo pacman -Syyu

Could your try first delete all nvidia driver related configs of xorg and boot with plain nouveau driver?

Search them in /etc/X11/xorg.conf.d and the file /etc/X11/xorg.conf.