Lightdm not running correctly

Hello my lightdm seems to be crashing everytime I start my Pc.
It hangs on boot either after “[OK] started CUPS Scheduler” or at some other point.
I remember the last change I made to my system that could affect something like this was activating Freesync and NoTear.
Also I am running Dual Boot with windows 10 (windows 10 is on another drive though it seems that the Bootloader might be on the same drive as manjaro)

Data I found out is below
If you need more data please ask.

[please be aware I am typing the errors per hand since I cannot acces the desktop and writing a forum post through console is not a thing I am capable of doing nor do I know how to get the copy and pasted stuff out of my pc onto another device]
After ctrl+alt+f3 ‘’‘journalctl --catalog --priority=3 --boot=0’’’ gives me

{date and stuff + name} systemd[1]: Failed to start Light Display Manager.
Subject: A start job for unit lightdm.service has failed
Defined-By: systemd
Support: {manjaro support site url}

A start job for unit lightdm.service has finished with a failure.

The job identifier is 946 and the job result is failed.
{date and stuff + name} systemd-udev[404]: could not read from '/sys/module/amd64_edac/initstate': No such device 

sudo lightdm --test-mode --debug
gives this output (cant copy and paste it from there sadly so here is a picture hope it works)

my inxi --admin --verbosity=7 --filter --width (though some data might be old since I am copying this from another older forum post of mine)

Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
   parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64
   root=UUID=0bc33de2-959d-433a-8788-244c33b2697f rw quiet apparmor=1
   security=apparmor udev.log_priority=3
 Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1
   vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
 Type: Desktop Mobo: ASUSTeK model: PRIME X570-P v: Rev X.0x
   serial: <superuser required> UEFI: American Megatrends v: 4021
   date: 08/09/2021
 Message: No system battery data found. Is one present?
 RAM: total: 15.54 GiB used: 2.21 GiB (14.2%)
 RAM Report:
   permissions: Unable to run dmidecode. Root privileges required.
 Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2
   family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
 Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
   L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
   L3: 32 MiB desc: 2x16 MiB
 Speed (MHz): avg: 2467 high: 3717 min/max: 2200/4208 boost: enabled
   scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2911 2: 2057
   3: 2054 4: 2199 5: 2200 6: 2199 7: 3613 8: 3717 9: 2057 10: 2202 11: 2199
   12: 2200 bogomips: 86440
 Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
   bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
   constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
   cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid
   f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibs
   irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe
   msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
   pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
   pfthreshold pge pni popcnt pse pse36 rdpid rdpru rdrand rdseed rdt_a
   rdtscp rep_good sep sev sev_es sha_ni skinit smap smca sme smep ssbd sse
   sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce
   topoext tsc tsc_scale umip v_spec_ctrl v_vmsave_vmload vgif vmcb_clean vme
   vmmcall wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
 Type: itlb_multihit status: Not affected
 Type: l1tf status: Not affected
 Type: mds status: Not affected
 Type: meltdown status: Not affected
 Type: spec_store_bypass
   mitigation: Speculative Store Bypass disabled via prctl and seccomp
 Type: spectre_v1
   mitigation: usercopy/swapgs barriers and __user pointer sanitization
 Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
   conditional, RSB filling
 Type: srbds status: Not affected
 Type: tsx_async_abort status: Not affected
 Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
   vendor: Sapphire Limited driver: amdgpu v: kernel bus-ID: 0a:00.0
   chip-ID: 1002:731f class-ID: 0300
 Display: x11 server: X.Org compositor: xfwm4 v: 4.16.1 driver:
   loaded: amdgpu display-ID: :0.0 screens: 1
 Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.7x15.0")
   s-diag: 777mm (30.6")
 Monitor-1: DisplayPort-0 res: 2560x1440 dpi: 109
   size: 597x336mm (23.5x13.2") diag: 685mm (27")
 OpenGL: renderer: AMD Radeon RX 5700 XT (NAVI10 DRM 3.41.0
   5.13.19-2-MANJARO LLVM 13.0.0)
   v: 4.6 Mesa 21.2.5 direct render: Yes
 Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel
   bus-ID: 0a:00.1 chip-ID: 1002:ab38 class-ID: 0403
 Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
   driver: snd_hda_intel v: kernel bus-ID: 0c:00.4 chip-ID: 1022:1487
   class-ID: 0403
 Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
 Sound Server-2: JACK v: 1.9.19 running: no
 Sound Server-3: PulseAudio v: 15.0 running: yes
 Sound Server-4: PipeWire v: 0.3.40 running: no
 Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
   vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel port: f000
   bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
 IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
 IP v4: <filter> type: dynamic noprefixroute scope: global
   broadcast: <filter>
 IP v6: <filter> type: dynamic noprefixroute scope: global
 IP v6: <filter> type: noprefixroute scope: link
 WAN IP: <filter>
 Message: No bluetooth data found.
 Message: No logical block device data found.
 Message: No RAID data found.
 Local Storage: total: 3.18 TiB used: 56.07 GiB (1.7%)
 SMART Message: Required tool smartctl not installed. Check --recommends
 ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 500GB
   size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
   lanes: 4 type: SSD serial: <filter> rev: 2B2QEXE7 temp: 30.9 C scheme: GPT
 ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
   model: WD20EZRZ-00Z5HB0 size: 1.82 TiB block-size: physical: 4096 B
   logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
   rev: 0A80 scheme: GPT
 ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 QVO 1TB
   size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
   type: SSD serial: <filter> rev: 2B6Q scheme: GPT
 Message: No optical or floppy data found.
 ID-1: / raw-size: 465.47 GiB size: 457.09 GiB (98.20%)
   used: 49.16 GiB (10.8%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
   label: N/A uuid: 0bc33de2-959d-433a-8788-244c33b2697f
 ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
   used: 25.5 MiB (8.5%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
   label: NO_LABEL uuid: 6D5F-3BC0
 ID-3: /mnt/Fast Library raw-size: 915.89 GiB size: 900.51 GiB (98.32%)
   used: 6.88 GiB (0.8%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17
   label: Fast Library uuid: 6a9f3a32-0b2d-47db-a750-49ff7315f9f0
 ID-4: /mnt/Slow Archive raw-size: 1.82 TiB size: 1.79 TiB (98.37%)
   used: 28 KiB (0.0%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: Slow Archive
   uuid: f3e28752-bf8b-44b3-9ec9-5befd5a00509
 Alert: No swap data was found.
 ID-1: /dev/sdb2 maj-min: 8:18 size: 15.62 GiB fs: swap label: N/A
   uuid: 9a48c4a1-7a4a-4f3a-82b0-888ec862a47d
 Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 6 rev: 2.0
   speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
 Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
   chip-ID: 1d6b:0003 class-ID: 0900
 Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 6 rev: 2.0
   speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
 Device-1: 3-3:2 info: tshort Dactyl-Manuform (5x6) type: Keyboard,HID
   driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
   power: 500mA chip-ID: 444d:3536 class-ID: 0300
 Device-2: 3-4:3 info: Logitech G502 Proteus Spectrum Optical Mouse
   type: Mouse,HID driver: hid-generic,usbhid interfaces: 2 rev: 2.0
   speed: 12 Mb/s power: 300mA chip-ID: 046d:c332 class-ID: 0300
   serial: <filter>
 Device-3: 3-6:4 info: ASUSTek AURA LED Controller type: HID
   driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 16mA
   chip-ID: 0b05:18f3 class-ID: 0300 serial: <filter>
 Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
   chip-ID: 1d6b:0003 class-ID: 0900
 Hub-5: 5-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
   speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
 Device-1: 5-2:2 info: Prusa Original Prusa i3 MK3
   type: Abstract (modem),CDC-Data driver: cdc_acm interfaces: 2 rev: 2.0
   speed: 12 Mb/s power: 100mA chip-ID: 2c99:0002 class-ID: 0a00
   serial: <filter>
 Hub-6: 6-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
   chip-ID: 1d6b:0003 class-ID: 0900
 System Temperatures: cpu: 37.2 C mobo: N/A gpu: amdgpu temp: 42.0 C
   mem: 40.0 C
 Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
 Processes: 298 Uptime: 27m wakeups: 0 Init: systemd v: 249 tool: systemctl
 Compilers: gcc: 11.1.0 Packages: 1263 pacman: 1254 lib: 394 flatpak: 5
 snap: 4 Shell: Bash v: 5.1.12 running-in: xfce4-terminal inxi: 3.3.11

5.13 is EOL. Switch to a supported kernel:

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu 
sudo mhwd-kernel -i linux515

Then reboot into 5.15. Press Esc during boot to get into grub menu > advanced options and boot with 5.15. Double check your running kernel is not 5.13 then remove it:

uname -r #to check kernel version
sudo mhwd-kernel -r linux513
1 Like

okay that was one of the old data I am currently running on kernel 5.16 had 5.15 before with same problem thought kernel update might fix it

What is the output of systemctl get-default?

Also share the contents of /etc/lightdm/lightdm.conf.

systemctl get default returns

Imma just write every line that is not uncommented


This is meant to be under the [Seat:*] section and not [LightDM] as it is given in the default lightdm configuration file. Maybe that’s why it says [LightDM] contains unknown option greeter-session on line 6th in the picture provided by you. Make this change and reboot.

same error in journalctl

here the new output oflightdm --test-mode --debug

cat /etc/lightdm/lightdm.conf | grep -v "#"

you did change that to read:






grep -v "#" /etc/lightdm/lightdm.conf

would get rid of the unnecessary “cat” and the pipe
in the previously given command
… it just “grep’s” the given file
for lines not starting with: #

Can you try commenting out logind-check-graphical=true under [LightDM] section?

thats how it is now

I tried didn’t change anything

I had some difficulty with editing.

Review again please.

yes I figured. One thing my keyboard doesnt have a | key so i just nano’d and checked everything that doesn’t have a # at the start of the line. The grep just makes those lines invisible right?

not quite :wink:
The grep (this one …) just lists the lines without a # in front of the line.
It just lists the lines which do not start with: # :wink:

it lists the lines which are actually capable of doing anything
which are not commented out …

Jeah I that’s what I wanted to say but my brain is not working anymore currently. Had a long day.
Thank you.

But just to be sure the not commented out lines match exactly your thing.
Ive tried adding the


though it doesn’t change anything

Can you try reverting back these changes?

I deleted the 20-amdgpu.conf and the 20-radeon.conf (dont remember the names exactly and now I seem to be able to boot thank you! @ishaanbhimwal

now I just have to figure out how to enable those things without killing lightdm in the process

systemctl stop lightdm.service

do your thing

systemctl start lightdm.service


… or just don’t care
do your edits
and then restart the service

systemctl restart lightdm.service

or reboot

Doing it the standard way by creating the config files seemed t work I guess the two seperate config files I had, due to me being stupid, maybe confused the system.