Lightdm failed to start

After updating manjaro I ran into the problem that Lightdm fails to start. I expected that to happen as I had the problem before but I fixed relatively easy by installing a new driver for my graphics card.

This time however this doesn’t work. I got a RTX 2060 so I tried to install the 460 driver with mhwd, but always got the error that its not available. With mhwd -la I can see that there is only the 390 driver + nvidia-prime available which seems wrong.
After looking into that it seems something changed in how nvidia drivers are installed in Manjaro, where only “video-nvidia” is needed/installed ,so older solutions I googled didn’t work.

My laptop uses a RTX 2060 and the kernel version is 5.12.8

I assume this issue is rather trivial to solve (as it was before), but I’m kinda out of options ^^

Hello @Messias :wink:

lspci -nnkkvt | grep -i nvidia


cat /var/lib/mhwd/ids/pci/nvidia.ids 

Check if the chipid is present at nivdia.ids.

If not, then you have to install the dkms and avoid mhwd for this card.

What exactly am I looking for ? For my GPU it says [10de:1f11] which I assume are the ids.

And what should be in the nvidia.ids ? Both those numbers ? Because only 1f11 is present.

I have asked, because you said this:

mhwd -la shows all possible configs, but mhwd -l shows all configs which match with your hardware. The check was just there to keep sure that the ID match, since your talk about mhwd -la and not mhwd -l.

So, did I understand correctly, that video-nvidia is not there when running mhwd -l ?

No, video-nvidia shows up when runnning mhwd -l