Lightdm failed, after nvidia update

Hi , I was trying to update my system and had the nvidia -440x and nvidia-450xx conflict. I tried removing nvidia-utils-440x and installing nvidia-utilis-450x ,then updating the driver.But through mhwd gui ,I couldn’t update the hybrid version of nvidia prime So after browsing through the forums i decided to try and install video-nvidia-450xx.
But after its installation I can’t open my lightdm window manager ,and only tty environment is accessible.

When i tried to remove video-nvidia-450xx to downgrade or use any open source driver.

I get the error

> Removing nvidia-450xx-utils breaks dependecy 'nvidia-450xx-utils=450.66' required by linux56-rt-nvidia-450xx

Further when i try to remove linux56-rt-nvidia-450xx , pacman says

Failure to intialize alpm library

And fails.

Can anyone suggest me what to do. I can’t follow any steps in other threads since I can remove the libraries. Sorry for bad formatting , am typing this in mobile

Downgrade your kernel to the LTS and then remove the driver. Unless all is fine after downgrading the kernel of course.

Thank you for your answer, I did a full update and forces installed the hybrid driver and it somehow worked. Thank you for your time

1 Like