Light Display Manager failed to start on boot

Not too sure what broke. It seems there used to be a bunch of forum posts about this issue on this forum, as per Google cache, but all those pages are now gone.

The logs don’t seem to make sense to me. Yesterday I did a packages update of about 336 things, maybe something broke.

Edit: manually launching lightdm also does not work

I have two monitors and I think the failure is somewhere here:

Launching process 1439: /use/bin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
XServer 0: Waiting for ready signal from X server :0
Seat seat0 changes active session to
Process 1439 exited with return value 1
XServer 0: X server stopped
Releasing VT 7
XServer 0: Removing X server authority /run/lighten/root/:0
Seat seat0: Display server stopped

I have a greeter, lightdm-gtk-greeter

Did pacman -S for lightdm and lightdm-gtk-greeter

I have user-session set to xfce and I have a xfce.desktop file in /usr/share/xsessions



lightdm --test-mode --debug
sudo systemctl --failed

If you just want to get into your desktop, get to a tty by pressing ctrl+alt+[f1 through f7] until one of them works. you should see a small text login prompt. login with your system username and password. You should be brought into your terminal. Run the command


startx starts the x server. This will not work if you are in the Wayland display server (you probably aren’t, all things considered).
I uninstalled LightDM because it breaks and just login in the tty and run startx. It just works.
This isn’t 100% necessary as it probably is possible to get LightDM working again, but this is what I would do

seems to be permissions on /var/lib/lightdm-data …
for need to quickly get into my system i just forced it with
‘sudo chown root:lightdm /var/lib/lightdm-data’
and then
‘sudo systemctl restart lightdm’
unsure of what they actually should be or what made it fail
but that made it work for now and when i get time i will research it further.
just posting a quick ugly way to get it running (lightdm that is)

This is working


sudo systemctl enable gdm.service --force



sudo systemctl enable sddm.service --force

sudo systemctl reboot

You can find your desktop in this link


You can install desktops

AND YOU Can find lightdm recommend display manager if you install any desktops
I hope this works forever :upside_down_face: