Libusb issue since last update with kernel 5.13

Can’t update Kernel (from 5.12 to 5.13) because I have an ignored package (libusb 1.0.23) that is out of date

I just updated my Manjaro system and saw the Kernel 5.12 has reached it’s EOL. So when I tried to install the Kernel with sudo mhwd-kernel --install linux513 I get following message

The following packages are out of date, please update your system first: libusb

The problem is, that “libusb” in current version has a bug and I need this library for using my XBox gamepad wirelessly. The developers of libusb knows this issue and are working on it, but it can still take a while until next release. So I downgraded it and set a rule for pacman to ignore it.

But this prevents me from updating the Kernel now. Here my initial bug report for xow and here the real issue coming from libusb. What should I do now? The current libusb version is broken, so shouldn’t Manjaro not force me to upgrade it? I am using this setup since many months now.

Have you tried just using your usual package manager to install linux513 (and any other linux513-* packages) after updating all other packages?

No, but shouldn’t I install the Kernel with mhwd instead? When try to install pamac install linux513, it seems to just install fine (I did not confirm installation process for now and chose [n]). But why would mhwd require the libusb version and pamac would not? Is there any problem ignoring this?

Since you need to hold upgrade of certain packages, you can also try using an LTS kernel like 5.10, unless you need a newer kernel for hardware compatibility.

1 Like

I get the same message with sudo mhwd-kernel --install linux510 . (Sorry to the moderators. If this was inappropiate to post here, maybe my posts could be transferred to a new thread/post.)

Unignore the libusb package required to be able to upgrade and see if the XBox gamepad is working (Bug might be fixed in the meantime) on both 5.10 and 5.13

If not, downgrade to the previous package after the upgrade.


1 Like

Why is the newer libusb version required by mhwd? Is there any software that uses the newer version? I don’t want unignore it and install it, just to see if I can downgrade with the newer Kernel. If the newer Kernel requires it, then I can’t downgrade. So something is fishy here.

The bug is not fixed in the meantime, as it is present since last year (we are in July now) and the developer of libusb said it will probably take some more time. It has nothing to do with the Kernel, so I don’t know why the Kernel requires the newer version of it.

I am on Manjaro since January and could do any system upgrades, and installed and updated the Kernel multiple times since then without a problem. Just the newest Manjaro version requires this newer libusb version. But there is not reason for. Can I set an ignore for the library like I did for pacman/pamac?

Well, finally I followed your recommendation and did exactly that (unignore-upgrade-ignore). Now I could change the Kernel, but I need to do this every time when doing mhwd-kernel stuff? To me this sounds like a bug in mhwd, because it should not require the newer libusb version. Or at least let me ignore it with mhwd too (just like pacman and pamac does).

But thanks for the shruggin emoji as a reaction…

The :man_shrugging: was there because you as the SysAdmin of your system decided to hold back / downgrade libusb, so you shouldn’t be surprised to have to jump through hoops upgrade-downgrade again to update on a rolling release model.

So no, not a bug in mhwd, but a feature and a consequence of the decision you took.

The real solution is to file a bug with the developers of the XBox gamepad as they’re probably on a fixed release model…

Therefore, I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

There is or was a bug in mhwd. Before I did this thing here, I got no question to ignore the package at output from sudo mhwd-kernel --install linux513

The following packages are out of date, please update your system first: libusb
Do you want to continue anyway? [y/N]

I did not got the “do you want continue”, but now I get it. So there was the bug then when I opened this question! Therefore it was required at that time. Currently I don’t know what the solution was here, to make mhwd functional again.

All I wanted to do is ignoring the package when installing or changing Kernel.

The real solution is to file a bug with the developers of the XBox gamepad as they’re probably on a fixed release model…

I have filed it and he explained it, that there is a bug in the current libusb and it is known. The developer since last year tries to solve this. That is why we need to ignore it when using xow driver.

Just out of curiousity, why aren’t you using the latest libusb-git where this issue is fixed?

I wasn’t aware of this. Where can I read about this issue being fixed? I quickly searched it, but couldn’t find.

It’s near the end of the libusb link you posted. I switched as soon as I read that last week.

Interesting. I have this on my radar now, but won’t switch yet. I use the AUR as my last resort, if I cannot get it done with standard repository. But it is good to know that it seems to be fixed. But why they don’t publish a new minor version with the fix in place? This way we could get the fix automatically with official repository. Therefore I am a little bit cautious and keep using the older version for now. Whenever I need, I will replace it with the -git version from source then. So thank you for this, as I didn’t notice it (using it since several months).

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.