LibreWolf browser not building

I tried to build the browser i chose the arch version and when i build it says “ERROR: megbar.patch was not found in the build directory and is not a URL.” So I went and installed the general linux option and got the same error. What is megabar.patch and where can I get it and also where do i put it?

Maybe you should use librewolf-bin instead. It seems like building librewolf itself has been having issues, as you can see from the comments on the AUR page.

What is “the arch version”? Did you mean AUR?

I used this one LibreWolf / Browser / Arch · GitLab

Have you tried to build the AUR version?

pamac build librewolf or if you want to bin version so that you don’t have to compile, pamac build librewolf-bin

For the normal librewolf build it almost worked but at the end it said one or more files did not pass the validity check! and the item that failed to check was unity-menubar.patch

Which seems to be the general issues per the comments on the page. You’ll probably have to just use the bin version, fix the PKGBUILD yourself, or wait until it’s fixed.

so i tried the bin version and got “ERROR: One or more PGP signatures could not be verified!” and this time the one that failed was librewold-85.0.1-1-x86_64.pkg.tar.zst

Did you read the comments on the AUR page…? You should always read the comments before installing from AUR.

well i got the bin version built but i’m new and what do I do with this there isnt any program listed when i look it up in the search

well thanks i got it by messing around and reading the comments on the aur page and thank you so much for the help

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.