LibreOfficeWriter Keyboard Malfunction

During use of Libre Office Writer on many occasions, there are keyboard issues. At one point, the keyboard began typing repeated the same key ‘h’ and continued filling other text boxes, such as when attempting to use the terminal to kill the program. (the mouse worked and was able to click into the Manjaro’s menu but the text box within was affected.) A reboot proved that the keyboard issue was not mechanical. After changing a setting in Manjaro for how text is typed in- someplace in the settings, Libra OfficeWriter after a certain point of text entry, stutters. Doing a save helps with the first occurrence but there after, after perhaps another page of text is typed, the keyboard stops working. The mouse still works but the keyboard remains non-working and unavailable to the system or any other application–such as the Logout, Login- type password feature. Rebooting resolves the issue. The issue is not present in a different Debian based OS on another partition. The system run on an HP Pavilion laptop, g-series with (EDIT: STRIKE 8 Gig. ) 4 Gig of RAM and a SWAP partition of 16 Gig.

sudo inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 5.16.14-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.16-x86_64
    root=UUID=46588cb5-04db-479e-b013-ff344795af33 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
    v: 4.16.1 dm: LightDM v: 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Hewlett-Packard product: HP Pavilion g7 Notebook PC
    v: 058F100014204610000620100 serial: <filter> Chassis: type: 10 serial: N/A
  Mobo: Hewlett-Packard model: 166A v: 08.38 serial: <filter> BIOS: Insyde
    v: F.63 date: 03/22/2012
  RAM: total: 3.63 GiB used: 1.91 GiB (52.5%)
  Array-1: capacity: 8 GiB slots: 2 EC: None max-module-size: 4 GiB
    note: est.
  Device-1: Bottom - Slot 1 size: No Module Installed
  Device-2: Bottom - Slot 2 size: 4 GiB speed: 1067 MT/s type: DDR3
    detail: synchronous bus-width: 64 bits total: 64 bits manufacturer: Samsung
    part-no: M471B5273DH0-CH9 serial: <filter>
  Info: model: Intel Core i3 M 380 bits: 64 type: MT MCP arch: Westmere
    family: 6 model-id: 0x25 (37) stepping: 5 microcode: 0x7
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 933 min/max: 933/2533 base/boost: 2533/2533 scaling:
    driver: acpi-cpufreq governor: schedutil volts: 0.0 V ext-clock: 1066 MHz
    cores: 1: 933 2: 933 3: 933 4: 933 bogomips: 20225
  Flags: acpi aperfmperf apic arat arch_perfmon bts clflush cmov
    constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts est flush_l1d fpu
    fxsr ht ibpb ibrs lahf_lm lm mca mce mmx monitor msr mtrr nonstop_tsc nopl
    nx pae pat pbe pcid pdcm pebs pge pni popcnt pse pse36 pti rdtscp rep_good
    sep ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tsc vme
    xtopology xtpr
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds
    status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Core Processor Integrated Graphics vendor: Hewlett-Packard
    driver: i915 v: kernel ports: active: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1
    bus-ID: 00:02.0 chip-ID: 8086:0046 class-ID: 0300
  Device-2: Chicony HP Webcam-101 type: USB driver: uvcvideo bus-ID: 2-1.5:3
    chip-ID: 04f2:b293 class-ID: 0e02 serial: <filter>
  Display: server: X.Org v: compositor: xfwm v: 4.16.1 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0.0
    screens: 1
  Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.65x9.37")
    s-diag: 485mm (19.11")
  Monitor-1: LVDS-1 model: LG Display 0x027a built: 2009 res: 1600x900
    hz: 60 dpi: 106 gamma: 1.2 size: 382x215mm (15.04x8.46") diag: 438mm (17.3")
    ratio: 16:9 modes: 1600x900
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel 5 Series/3400 Series High Definition Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:3b56 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.14-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.48 running: yes
  Device-1: Realtek RTL8188CE 802.11b/g/n WiFi Adapter vendor: Hewlett-Packard
    driver: rtl8192ce v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 4000
    bus-ID: 02:00.0 chip-ID: 10ec:8176 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8136 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 465.76 GiB used: 23.64 GiB (5.1%)
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD5000BPKX-22HPJT0 family: Black Mobile size: 465.76 GiB block-size:
    physical: 4096 B logical: 512 B sata: 3.0 speed: 3.0 Gb/s type: HDD
    rpm: 7200 serial: <filter> rev: 1A01 temp: 41 C scheme: MBR
  SMART: yes state: enabled health: PASSED on: 4y 318d 14h cycles: 94
  Optical-1: /dev/sr0 vendor: hp model: DVD RW AD-7711H rev: 1.81
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 302.09 GiB size: 296.28 GiB (98.08%)
    used: 23.64 GiB (8.0%) fs: ext4 block-size: 4096 B dev: /dev/sda3
    maj-min: 8:3 label: N/A uuid: 46588cb5-04db-479e-b013-ff344795af33
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 15.23 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: a5ade7db-8e54-4739-ba69-55a274ec42ce
  ID-1: /dev/sda2 maj-min: 8:2 size: 148.44 GiB fs: reiserfs label: N/A
    uuid: 18ea01c6-7a08-4414-b83f-fb54f90e58d3
  Hub-1: 1-0:1 info: Full speed or root hub ports: 3 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0020 class-ID: 0900
  Device-1: 1-1.1:3 info: Pixart Imaging Optical Mouse type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s
    power: 100mA chip-ID: 093a:2510 class-ID: 0301
  Hub-3: 2-0:1 info: Full speed or root hub ports: 3 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0020 class-ID: 0900
  Device-1: 2-1.5:3 info: Chicony HP Webcam-101 type: Video driver: uvcvideo
    interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 04f2:b293
    class-ID: 0e02 serial: <filter>
  System Temperatures: cpu: 56.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 184 Uptime: 53m wakeups: 1 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1495 lib: 367
  flatpak: 0 Shell: Bash (sudo) v: 5.1.16 running-in: xfce4-terminal
  inxi: 3.3.14

Yesterday while writing to the forum (and during a chat on another webpage based customer support) using Chromium, the keyboard stopped typing 5-6x and required reboot. So my bad: Libre happened to be where I’d typed the most- I can get about 2 pages typed b4 kb quits. The error seemed character limited but later the keyboard stuttered entering a search term. There was no text output.
Mouse clicking my way to shutdown, meant to close an open terminal but opened a new terminal by mistake. The new terminal loaded slower and a bit of flicker to it So I typed a key and the KB functioned! On Return to the browser, the KB worked, too. But not long after it stopped again. My new terminal “trick” did not work and I had to shutdown. Just “Restart” (but not POWER OFF COMPLETE Shutdown) does not work always. “Logout” “Login” does not work.

I thought maybe a timed malicious code- or cron job but didn’t know how to see crontabs in Manjaro.

I thot there was something with an hourly amror (I don’t recall the spelling) running, that I saw (i forget where). Unless I have top running I can’t get to it after the malfunction. I’ve tried different kernels. This was all I could come up with to see if any job was occurring:

systemctl status cronie
● cronie.service - Periodic Command Scheduler
     Loaded: loaded (/usr/lib/systemd/system/cronie.service; enabled; vendor pr>
     Active: active (running) since Thu 2022-04-07 11:07:37 EDT; 55min ago
   Main PID: 450 (crond)
      Tasks: 1 (limit: 4441)
     Memory: 580.0K
        CPU: 34ms
     CGroup: /system.slice/cronie.service
             └─450 /usr/bin/crond -n

Apr 07 11:07:37 nobody systemd[1]: Started Periodic Command Scheduler.
Apr 07 11:07:37 nobody crond[450]: (CRON) STARTUP (1.5.7)
Apr 07 11:07:37 nobody crond[450]: (CRON) INFO (Syslog will be used instead of >
Apr 07 11:07:37 nobody crond[450]: (CRON) INFO (RANDOM_DELAY will be scaled wit>
Apr 07 11:07:37 nobody crond[450]: (CRON) INFO (running with inotify support)
Apr 07 12:01:01 nobody CROND[6961]: (root) CMD (run-parts /etc/cron.hourly)
Apr 07 12:01:01 nobody CROND[6960]: (root) CMDEND (run-parts /etc/cron.hourly)
lines 1-17/17 (END)

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

@andrea85, thanks for the reminder and apologize for not posting data.

With regards to the problem, after determining the keyboard failed in other programs when typing, I started looking around for what was running and then eliminated one service that was running hourly, apparmor and another not in use, cups. The keyboad has not failed since. I’m not sure what turned on those services- t’wasn’t me, but maybe due to installed pkg. Thanks for your helpful suggestion- I’m going to mark this as solved for now.

There maybe another service or something else completely that causes the keyboard to stop output. Until I shutdown after changing service settings, there were no more keyboard issues. After full shutdown and start, they began again after typing a couple pages. Reviewing enabled services, and last commands, showed that I only stopped snapdapparmor service, not disabled it like I’d done to the others. So once again it was running after the boot.

The other difference was this time a usb-serial cable was still plugged in, when the keyboard failed. (But, it wasn’t plugged in during the original errors.) So I’d run some commands not long before, ie) lsusb, usb-devices…

(I’ve been not able to get the ttyUSB serial to communicate with a plotter. It had run effortlessly with a plot cut package and manjaro after my user was added to the uucp group and chmod to 777 of the ttyUSB0 port. Everything stopped after the update to the system and inkscape a couple weeks ago. Then the keyboard stops. Could my having changed these settings screwed up the keyboard???)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.