Libreoffice lag when typing

I’m posting here just in case someone knows the cure. It’s not a Manjaro problem. Happens on every linux os I’ve ever tried.

For work I create writer documents (reports) with lots of pictures in them. They are not massive in terms of file size - normally about 400kb per picture. when I’m writing these documents I get terrible lag when typing. The text appearing on screen ends up way behind what’s going on with my keyboard. It seems to begin as soon as I start inserting the images.

Over months and months I’ve tried everything I can find on the libreoffice help forum (and elsewhere) and nothing I’ve found yet has worked. I’ve turned off the java runtime, disabled open cl and tried it enabled too, disabled anti-aliasing, messed about with cache settings in the advanced section of options, and some other things I can’t bring to mind right now.

Happens with libreoffice fresh and still. I did note that the problem almost disappeared with libreoffice 6.47 but that is no longer available in the Manjaro or AUR repos as far as I can see. I was on libreoffice still but as soon as Manjaro upgraded me to libreoffice-still 7 it got bad again.

Happens on my laptop and my desktop (both powerful computers with SSD drives).

I would still be very interested in a fix for this, but for the moment I found a workaround and I’m posting it here in case it’s helpful for anyone else that has the same problem.

Libreoffice 6.4.7 from this page fixed the problem. No lag when typing or scrolling.