Libreoffice help is running wine (start.exe and explorer.exe)


My installation of libreoffice (-still 7.3.7-1) appears to be trying to run Internet Explorer (explorer.exe) via start.exe and wine whenever I press a HELP button. I understand it’s trying to load the help web pages but why would it ever be using wine or explorer.exe on a Linux system (instead of my default browser (vivaldi))? Does anyone have any idea what’s wrong and how I can fix it?

FWIW, I’m pretty sure I used to get a dialog when I accessed help. Was that changed? In any case, I’m fine with the web help but it should be using my default browser.



How did you install LibreOffice?

If you have downloaded an EXE installer from their website, then you’re running the Windows version of LibreOffice through Wine. In that case, this is expected behaviour.

If not, then maybe some environment variable is corrupt I guess, not really sure what is going on.

I installed it the normal way via pacman . The package is “extra/libreoffice-still” version 7.3.7-1.

Then there is a chance that xdg-open config might have been overwritten. Try running

$ xdg-mime query default text/html

and see what is the output that it gives you.

Thanks for mentioning that (I was literally looking for the command when your reply arrived :slight_smile: )

In any case, looks normal:

$ xdg-mime query default text/html

… and /usr/share/applications/vivaldi-stable.desktop looks normal.

Here’s a little more detail. I press a HELP button and then I see the wine icon on the task bar. System Monitor (KDE) shows a bunch of wine-related processes which include start.exe and explorer.exe (as reported). I just noticed now that there’s an xdg-open process that is listed (even though I searched on ‘wine’?) that appears to be related. Here are the relevant entries:

ray      1804154  0.0  0.0   8040  4096 ?        S    11:08   0:00 /bin/sh /usr/bin/xdg-open file:///tmp/lu1795970djq2e1.tmp/NewHelp1.html
ray      1801257  0.0  0.4 2679080 34144 ?       Rs   11:06   0:00 C:\windows\system32\start.exe /ProgIDOpen htmlfile /tmp/lu1795970djq2e1.tmp/NewHelp1.html
ray      1801254  0.0  0.3 2658352 30524 ?       S    11:06   0:00 start.exe /exec start /ProgIDOpen htmlfile

NewHelp1.html does indeed contain the help page I was expecting.

If I run that xdg-open command at the shell I get the same three lines of output repeating until I kill all the related processes:

$ xdg-open file:///tmp/lu1795970djq2e1.tmp/NewHelp1.html KApplicationTrader: mimeType "x-scheme-handler/file" not found KApplicationTrader: mimeType "x-scheme-handler/file" not found
0100:fixme:exec:SHELL_execute flags ignored: 0x00000100

Let’s try to isolate if xdg-open does the same behaviour when you manually run the app. Try copying that HTML file and running it manually through xdg-open.

$ xdg-mime query filetype file:///home/username/file.html
$ xdg-mime query filetype ~/file.html

If there is different filetype for both of them, that might help us debug the issue further.

$ xdg-open ~/file.html

My guess is for some reason both the outputs are differing.

Try running with debug mode.

XDG_UTILS_DEBUG_LEVEL=3 xdg-open file:///tmp/lu1795970djq2e1.tmp/NewHelp1.html

That should give us a hint if there is a different backend is in use.

You are correct:

$ cd /home/ray
$ touch foo.html
$ xdg-mime query filetype file:///home/ray/foo.html
xdg-mime: file 'file:///home/ray/foo.html' does not exist
$ xdg-mime query filetype ~/foo.html

I assume this is related to the ‘mimeType “x-scheme-handler/file” not found’ error I got earlier. But I don’t know how to fix that. Where/how is “x-scheme-handler/file” defined? How can there be only one handler for ‘file:’?

Adding XDG_UTILS_DEBUG_LEVEL=3 added one line to the repeating output that I posted earlier:

$ XDG_UTILS_DEBUG_LEVEL=3 xdg-open file:///home/ray/foo.html
Selected DE kde KApplicationTrader: mimeType "x-scheme-handler/file" not found KApplicationTrader: mimeType "x-scheme-handler/file" not found

What is “DE”? (Desktop Environment?)

Alright, there is some progress. When I tried the same command, I’m getting the mime-type as ‘text/html’ and not as ‘application/x-extension-html’. So the issue is somewhere related to the xdg-mime command which is used internally by xdg-open.

Try running xdg-mime query default application/x-extension-html and see the output. It should throw in Wine if I’m not wrong.


1 Like

You nailed it:

$ xdg-mime query default application/x-extension-html

So, in “~/.config/mimeapps.list” I have “text/html=vivaldi-stable.desktop”. I do not have anything for “application/x-extension-html”. Not sure which system-level mime file to check in…

Wow, that’s pretty annoying. I can’t even remember the last time I used wine!

Thanks, I’ll give that a try…

Okay, that seems to work. Thanks very much for everyone’s help!

Strange how the forum merged my replies to different people…

To reply to a specific post, click Reply there instead of the red button in the bottom right.

See how this post shows I’m replying to you? :wink:

To tag someone so they know you’re talking to them, use an asperand and start typing they’re username, it will autocomplete for you: @codemonkey

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.