Libreoffice Hangs When Saving

I switched to Manjaro XFCE over a year ago and LibreOffice-Fresh has always worked flawlessly for me. After the latest update I have been experiencing the application hanging when I try to save a document. I only use LibreOffice Draw since I need access to its drawing features. Sometimes it just hangs for a few minutes, completes the save, then allows me to return to editing. Sometimes it stays frozen requiring me to force quit the application (along with the resulting loss of work in the current document). Manjaro does not hang; this only affects LibreOffice Draw.

I experienced this a couple of years ago when I used to use Xubuntu and the solution then was to disable hardware acceleration and OpenCL which I now do by default whenever I install LO.

I was wondering if anyone else has been experiencing this since the last update. I have tried a number of things with no luck. At it is now, LO is so unreliable that I am thinking about removing it permanently.

Unfortunately, none of these seem to make a difference:

  • I have tried deleting my LO profile so a new one is generated
  • I have tried replacing LO Fresh with LO Still
  • I have tried different kernels (I normally use LTS kernel 5.10)
  • I have tried starting LO in Safe Mode with various options disabled or enabled

Can anyone suggest something I haven’t tried yet? Thank you in advance for any helpful advice.

UPDATE (16-SEPT-2021): no improvement after today’s Manjaro update.
UPDATE (17-SEPT-2021): tried installing the snap versions, including the edge release. LO continues to hang for random amounts of time before returning control to me.

No issues here, but these might be worth a try as they can easily be reversed:

Under Advanced Uncheck Use Java runtime environment (it is only needed for Base IIRC)

In Advanced -Expert Configuration Search for OpenGL and disable OpenGL

I’m not saying that it’s likely, but it could be a sign of hardware problems. What are you saving too? A local HDD/SDD, an SD card, Google Drive, an SMB share, etc? Try using another app to save a file to the same location - do you get the same problem?

I often have an SMB connection mounted to my NAS box, but if if I’ve powered off the NAS, sometimes I will get hanging from certain apps. This usually happens when the app tries to enumerate all available drives and mounts, such as a Save File dialog. Is it possible something like that is happening to you?

I’m just saving locally. I have come to the conclusion that the problem is a unique combination of mesa drivers + Libreoffice. Turning on hardware acceleration actually reduced the hangs.

I’ve always had a love/hate relationship with LO. I used to report bugs but I got tired of Windows users telling me the bug was a feature request. LO is powerful and I love Draw but it is also very buggy for me.

Thanks for your input.

Thanks for the suggestion. I always have Java Runtime unticked.
I’ve just done the latest stable update with LO 7.2 and a new mesa so I have my fingers crossed that resolves it.

UPDATE: 26-SEPT-2021

  • tried tweaking the memory settings under expert configuration with no improvement
  • tried enabling hardware acceleration, also with no effect

Saves continue to randomly hang Draw. Sometimes I can save several times in a row and it completes the action instantly. Then for no apparent reason the next one will lock up the application for 5+ minutes.

This only happens with LO Draw so clearly there is some interaction between the application and the graphics subsystem on my laptop.

UPDATE: 02-OCT-2021

Still experiencing the hang. It turns out the 6th Generation Intel i3 processors have a known bug that caused all sorts of grief for users in the past. Obviously, I am not going to buy a new pc just because of that.

The fix for this hardware bug was to disable OpenGL. I thought I’d done that by disabling hardware acceleration but it turns out the setting was moved into the expert configuration. Unfortunately, disabling the setting makes no difference.

Another fix was disabling antialiasing but this too had no effect.

The combination of Manjaro system updates with version 7.x of LibreOffice means that on my hardware the office suite is almost unusable. I’m not sure there is much else to try since it is impossible to roll back to the versions of Manjaro and LibreOffice that were stable. I would file a bug report with the Document Foundation but experience has told me that it is a waste of time. All their volunteers just chime in with “it doesn’t happen for me” or worse, “it’s a feature”. Time for a different office suite.

UPDATE: 03-OCT-2021

Today I tried app images for older versions of LibreOffice – versions 7.1, 7.0, and 6.47

All of these cause LibreOffice Draw to hang when saving too. If I have the patience to wait 5 or 10 minutes the save might complete but sometimes it doesn’t.

Since this issue seemingly affects all versions of LibreOffice it cannot be LibreOffice per se. I suspect it is a regression in the video subsystem. I’m not an expert on Mesa or Intel drivers so it isn’t something I can fix. I’ve tried multiple kernels with no success but unfortunately Manjaro doesn’t make it possible to revert to older versions of Mesa for testing.

I’m not going to close this thread myself because the issue isn’t resolved. It’s just the perfect storm of my Intel i3 sixth generation chipset + regressions in mesa or whatever. Regardless, LibreOffice is affected and has been for the last few Manjaro stable updates. It is not my hardware failing.

UPDATE: 10-OCT-2021

I switched to Scribus and no problems with hangs.

I decided to try an even older version of LibreOffice so I grabbed an AppImage for version 6.0x. This one predates the new ribbon interfaces that were introduced.

So far no hangs at all in Draw. Doing the same amount of testing in all versions after 6.5x would be causing a hang so fingers crossed.

I reported the issue as a potential mesa regression but after some help from one of the guys there we were not able to generate an mesa detected issues.

Then I decided to report it as a possible bug in LibreOffice. But I wasn’t even able to register an account because a registration bug wouldn’t let me complete the process. That really doesn’t inspire any faith in the Document Foundation or LibreOffice. Useless.

UPDATE: 14-DEC-2021
More Manjaro updates and everything working fine except Libreoffice. The file save bug is still present in 7.2.3 and 7.2.4 through the official repos. I’ve run out of how many attempts I have made to get Draw to save without hanging but it remains hopeless. I almost wish it was possible to buy Microsoft Office for Linux because LO is such a buggy mess it is often unusable with some versions.

Also just tried the latest kernels with no luck.

I’ve finally discovered what the problem is. It is associated with GTK3 rather than Libreoffice, the linux kernel, or the graphics drivers.

Changing the theme from GTK3 to QT5, then logging out and back in fixes the problem. Saving is once again instantaneous the way it used to be under GTK2.



This also explains why multiple versions of Libreoffice are affected. The last usable version without changing to QT5 for me was

It might also explain why there are so many weird bugs in xfce, particularly associated with thunar and the clipboard plugin.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.