Libreoffice doesn't start


Libreoffice doesn’t want to start anymore. I think it might be related to recent upgrade (Manjaro 23.1 Vulcan released or maybe [Stable Update] 2023-12-15 - Kernels, Blender, Thunderbird, Xorg-Server, Xwayland, Warzone2100).

When I run libreoffice, I get a splash screen, but nothing more.
Running from terminal gives error:

terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'

This is true for libreoffice-fresh and libreoffice-still.

Any cues how I might investigate further?

Kinder regards - david

Hi @davidbe,

I searched the error, and came across this page.

Where the last answer states:

Yesterday I face the same problem and then I installed the gtk2, as solution suggested by this post but the problem persist then I installed gtk3 and it was resolved. Maybe the newer libreoffice use gtk3 as hard dependancy not gtk2. I’m posting this if someone else encountered this problem in future he might be able to resolve it by installing gtk3.

So it seems to be because gtk wasn’t installed. and I did check, even though I’m using KDE, I do have gtk2, 3, and 4 installes:

$ pamac search --installed gtk
gtk4  1:4.12.4-1                                                                                                                                                                                                                                        extra
GObject-based multi-platform GUI toolkit
gtk3  1:3.24.38-1                                                                                                                                                                                                                                       extra
GObject-based multi-platform GUI toolkit
gtk2  2.24.33-3                                                                                                                                                                                                                                         extra
GObject-based multi-platform GUI toolkit (legacy)

So you could trey installing one, or all of those:

  • For gtk2:

    pamac install gtk2
  • For gtk3:

    pamac install gtk3
  • For gtk4:

    pamac install gtk4

And see if that helps. Hope it does!


According to this page a reinstall helped. So you could try that:

  • First remove it:

    pamac remove libreoffice-{still fresh}
  • Then make sure there are no remnants left of it that could interfere:

    sudo rm -f /etc/libreoffice

    And your home directory:

    rm -f ~/.config/libreoffice
  • Then reinstall it again:

    pamac install libreoffice-fresh

Really, really, really hope this helps!

1 Like

I dont know why any system would be missing gtk3 these days.
(every one at least comes with a browser or something that needs it I think)

That said … I might wonder about setting the libreoffice VCL.


SAL_USE_VCLPLUGIN=gtk3_kde5 libreoffice
SAL_USE_VCLPLUGIN=kf5 libreoffice
SAL_USE_VCLPLUGIN=kf6 libreoffice
SAL_USE_VCLPLUGIN=qt5 libreoffice
SAL_USE_VCLPLUGIN=qt6 libreoffice
SAL_USE_VCLPLUGIN=gtk3 libreoffice
SAL_USE_VCLPLUGIN=gtk4 libreoffice

(I dont know what desktop is in use or anything really … but any of those might produce better results)

@Mirdarthos , I found the same page and tried the reinstallation & removing of configuration files, but it didn’t change a thing. :frowning: I also switched to “still” in stead of “fresh”.

@cscs , I tried every combination, but none worked :frowning:

I just saw I posted the error message a bit too minimal, it is more elaborate (but didn’t give me any clue):

terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'

Fatal exception: Signal 6

I’ve been using Manjaro on this laptop already a few years without any hassle. Strange that this happens suddenly…

Strange things do suddenly happen without rhyme or reason on updates, especially kernel upgrades. The best thing to do, rather than spend hours of frustration trying to solve the issue is to remove libreoffice, then re-install.

You’ll first need to know which version of libreoffice you have - eg my version is the ‘still’ version, but there’s also a ‘fresh’ version. So to find out which one you have, run

pacman -Ss libreoffice | grep installed

Then remove as follows:

pamac remove -o libreofficeversion

and re-install:

pamac install libreofficeversion

That should do it.

It didn’t do the trick. I’m clueless.

I’m trying to find some time to reinstall this distro. It has gathered already too much cruft…

I dont know why it would. Weird suggestion.

If you have something in your HOME affecting things it would not be touched by uninstall/reinstall.

As to system files … no … things dont ‘just happen’.


Is the system up to date?

sudo pacman -Syu

Are there weird foreign packages?

pacman -Qm

Unmanaged pacnew files?

pacdiff -o

Also … does it happen with a new user?