LibreOffice Calc - clicking on Toolbar Extension and then Borders Button does not work

Issue in LibreOffice - Calc Application: - When the Calc Application has Standard Tool Bar set (View > User Interface > Standard Tool Bar), i.e., with 2 ICON rows also with the symbol “>>” for extension at the end of each row.

In the 2nd Row - When I press the symbol “>>” , I get the pop up as usual but when I press the Borders Icons - nothing happens and this is my issue.

All the icons that come on the new pop up does not work except the “Conditional” Icon.


  1. I have selected a section of rows before hand (i.e., before click on >> and click on the Borders Icon ) for the LibreOffice to draw borders
  2. First row with Tool Bar extension icon “>>” does not have any issue.
  3. LibreOffice is installed from Manjaro Repo
$ sudo pacman -Ss libreoffice                                                                                         
extra/libcdr 0.1.7-7 [installed]
    CorelDraw file format importer library for LibreOffice
extra/libreoffice-fresh 7.6.4-2 [installed]
    LibreOffice branch which contains new features and program enhancements

Calc Error

Tested in Other Linux Distributions :
I have installed the same LibreOffice version from the Repos in Other distributions with XFCE and Gnome as DE and I don’t have any issues.

Software Version:
Version: (X86_64) / LibreOffice Community
Build ID: 60(Build:1)
CPU threads: 4; OS: Linux 6.6; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Click on the right side Properties panel and click on Cell Appearance, then cell borders can be modified as desired.

Any suggestions to fix this issue would be great.
Did any one come across the same/similar issue ?


Yes, I did have something similar. I did try another Theme setting and change the background color. Back to Auto.

You’re my want to close LibreOffice move the config folder, open LibreOffice again, see if the issues are gone.

If so, delete the .bak file and start over with small settings steps are move .bak the file back, then try to pinpoint the error in the setting down.

pkill soffice
;mv ~/.config/libreoffice ~/.config/libreoffice.bak

Hi @terashy88 ,
Deleting the config, did not fix the issue, tried couple of times, no issues but recently I started getting the following error.

but then fixed the script.xlb error with help > restart in safe mode > reset to factory settings

Mostly, the new update 24.2 should fix the actual issue.

Thank you!