Libquicktime and java8-openjfx not upgrading

libquicktime 1.2.4-25 and java8-openjfx not upgrading. I tried to read the errors, but they don’t make any sense to me.

libquicktime:

java8-openjfx:
nevermind… here we are a week later, i was trying it again to pastebin the error and it works now! Thanks to whoever fixed this!

inxi -F                                                          ✔ 
System:
  Host: karen-main-game Kernel: 5.14.21-2-MANJARO arch: x86_64 bits: 64
    Desktop: GNOME v: 41.4 Distro: Manjaro Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME X570-P v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 4021
    date: 08/09/2021
CPU:
  Info: 8-core model: AMD Ryzen 7 5800X bits: 64 type: MT MCP cache:
    L2: 4 MiB
  Speed (MHz): avg: 3799 min/max: 2200/4850 cores: 1: 3800 2: 3800 3: 3799
    4: 3800 5: 3800 6: 3800 7: 3799 8: 3799 9: 3800 10: 3800 11: 3800 12: 3800
    13: 3800 14: 3800 15: 3800 16: 3800
Graphics:
  Device-1: AMD Vega 10 XL/XT [Radeon RX 56/64] driver: amdgpu v: kernel
  Display: wayland server: X.org v: 1.21.1.3 with: Xwayland v: 22.1.0
    compositor: gnome-shell driver: gpu: amdgpu resolution: 1: 1920x1080~60Hz
    2: 1920x1080~60Hz
  OpenGL: renderer: AMD Radeon RX Vega (VEGA10 DRM 3.42.0 5.14.21-2-MANJARO
    LLVM 13.0.1)
    v: 4.6 Mesa 21.3.7
Audio:
  Device-1: AMD Vega 10 HDMI Audio [Radeon 56/64] driver: snd_hda_intel
  Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.14.21-2-MANJARO running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: xx
  IF-ID-1: docker0 state: down mac: xx
Drives:
  Local Storage: total: 13.64 TiB used: 4.06 TiB (29.8%)
  ID-1: /dev/nvme0n1 vendor: Crucial model: CT1000P1SSD8 size: 931.51 GiB
  ID-2: /dev/sda vendor: Western Digital model: WD4001FAEX-00MJRA0
    size: 3.64 TiB
  ID-3: /dev/sdb vendor: Seagate model: ST10000DM005-3AW101 size: 9.1 TiB
Partition:
  ID-1: / size: 915.53 GiB used: 595.8 GiB (65.1%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 46.2 C mobo: N/A gpu: amdgpu temp: 39.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 990
Info:
  Processes: 473 Uptime: 6d 5h 3m Memory: 125.71 GiB used: 16.31 GiB (13.0%)
  Shell: Zsh inxi: 3.3.14

It appears that the source code is not compatible with ffmpeg5. The PKGBUILD on the AUR should be updated (and potentially others changes are also needed). Others have noticed it too, see the comments: AUR (en) - libquicktime

It looks like you have put java8-openjfx on the ignore list:

Warning: java8-openjfx: ignoring package upgrade (8.u202-3 => 8.u202-4)

but I may be mistaken - I don’t know what the output looks like when some package is in the ignore list - I have never done that.

libquicktime is marked as “orphan” and there are comments about this on the AUR page:

dvzrv commented on 2022-03-14 11:03 (UTC)

Yes, this package needs to be fixed to work with ffmpeg4.4 or ffmpeg 5. Either way, libquicktime’s upstream is dead. Feel free to adopt this package and fix it.

Consider what you need it for
or what other package needs it
and perhaps replace with something else from the regular repo?

For using ffmpeg4.4 instead of ffmpeg change the it in depends=() and add

export PKG_CONFIG_PATH='/usr/lib/ffmpeg4.4/pkgconfig'

to tell to makepkg to use ffmpeg4.4

Like I did for aqualung https://aur.archlinux.org/cgit/aur.git/commit/?h=aqualung&id=05f976cf58a78dad68dd626c264554fdf7cb90ca

@Lolix forgive my ignorance, but i haven’t a clue where to put that

export PKG_CONFIG_PATH='/usr/lib/ffmpeg4.4/pkgconfig'

in the build file(s) - there’s a few that are called “ffmpeg”. I have no idea what I’m looking at. I have not looked at text like this since when QB45 was new and actively being used :joy: Can you hold my hand (tell me exactly how to make it build?)

# Maintainer: David Runge <dvzrv@archlinux.org>
# Contributor: Federico Cinelli <cinelli@aur.archlinux.org>
# Contributor: Mateusz Herych   <heniekk@gmail.com>

pkgname=libquicktime
_commit='27295919b3a1036ba8bc06cec414dcc501f72d89'
pkgver=1.2.4
pkgrel=26
pkgdesc="A library for reading and writing quicktime files"
arch=(x86_64)
license=(LGPL2.1)
url="http://libquicktime.sourceforge.net/"
depends=(glib2 glibc zlib)
# NOTE: not compatible with ffmpeg >= 5, so switch to ffmpeg4.4 or remove
makedepends=(alsa-lib doxygen faac faad2 ffmpeg git gtk2 lame libdv libglvnd
libjpeg-turbo libvorbis libx11 libxaw libxext libxt libxv schroedinger sndio
x264)
optdepends=('alsa-lib: for lqtplay'
            'faac: for lqt_faac plugin'
            'ffmpeg: for lqt_ffmpeg plugin'
            'gtk2: for libquicktime_config'
            'lame: for lqt_lame plugin'
            'libdv: for lqt_dv plugin'
            'libglvnd: for lqtplay'
            'libjpeg-turbo: for lqt_mjpeg plugin'
            'libpng: for lqt_png plugin'
            'libvorbis: for lqt_lame and lqt_vorbis plugin'
            'libx11: for lqtplay'
            'libxaw: for lqtplay'
            'libxext: for lqtplay'
            'libxt: for lqtplay'
            'libxv: for lqtplay'
            'schroedinger: for lqt_schroedinger plugin'
            'sndio: for lqtplay'
            'x264: for lqt_x264 plugin')
provides=(libquicktime.so)
options=(!lto)
source=(
  "https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz"
  "${pkgname}-1.2.4-CVE-2016-2399.patch"
  "${pkgname}-1.2.4-CVE-2017-9122_et_al.patch"
  "${pkgname}-1.2.4-faad2.patch"
  "${pkgname}-1.2.4-ffmpeg2.patch"
  "${pkgname}-1.2.4-ffmpeg29.patch"
  "${pkgname}-1.2.4-ffmpeg4.patch"
  "${pkgname}-1.2.4-ffmpeg-codecs.patch"
  "${pkgname}-1.2.4-libavutil.patch"
)
sha512sums=('6ab6cd62ae2361bb3ad73725e9e8baa2b03361bc23e9e34b24f90c0e2bec4337de950ed7f30a6a1d2e67ab33e8f0c43538369fd07e417f54b84583a3c331f8dd'
            '759fee13bc96db036063efcd8288c0e467ce811b597cf6c0ceed1c8927593963174f4f3324512db0e773e936a4b9fe5c8d8fc9e0f00b2ce59110661175986f9c'
            '93639d3fe12eefddd1b457be702ec0a4a64a73c44fce6b3134e50bb9a4e7e5f25d256d3ace6ec5e774f2db4c0d68725f3e35e901f7d932a4be9cba566eab528e'
            '3e751330ebbc4026363efd45b21c60c313ea169a57a5cdfa46125e126aab34c2dea3629ce92e7b0b5f14693db4f11723177fd28611e2e979cc8fcd506077509e'
            '32ddf394aad4ed80e89ec72a534e0466268ab0061b991815e905b78eae55a7d935117b0915faf6f7f51bd7e2d9fbaa4b0e07bfcef1ef1e2f4a7e2061c489122d'
            '2a7e06c03b0f64f02b923c1a0e7121f4e1ea735f19a6df8ce8daf18177ead132d1ae921c64f3770042db3bbf29f15a7fcceece835d475e052c4c3bb7139c9e2e'
            '1b11a82d694654976a5f79cd8feb27eec3810e09a66dc58ca576eaf1f96e4948abd4dae7955a7da6cf99ae6ffef9e183b39090d96cc6b5fe216b4c4f4faff7a8'
            '20c535444de1f3e9a68c35ee4eb409f150e6340fd43dda4544791454f42c031b24c08f651e0351f5a22dcb59459ac372aa70d82a1d20482b2d997589e19087fd'
            '691110dc18f6646e2e17f40c6a42911a6b8eaa8cea20b5595f20d218d51da11d11923a3001b7ad7c3ad6bd0d90e712b95ccee5526fa1bec176cd27813e4a775e')
b2sums=('6c50965be5d19fb4c57ea6b36f2581ebd575d78a34f2df7029ce2c6ee560e8135a953a2e85d91d189e2c01b97c99804d0eab602866b88a5f07c36351174680f0'
        '2794d13a0afa8a948f8f1335d7ee0a3d75691bbb9c619716707f533f52e8a8826c4a883b25db2ad8fb6544ce8b7c0fa883158b110c10b896e124b6ade9d18945'
        '8d5be1d1a297d89da1256035042a9760227815b8e73cb994b04b3ac4a2d7b83f79625bb62dc89266ac2f3eebd4cb033c8eb66388aca6097f4dbcc86d919dbd72'
        '175a32d051c438d59f428fb5a5d082e267f5503d9ff5ecded8302b74278f0bd1d0c5680161c1dd99089a116f9617fb37cdc697115979c5901c88e201ab221039'
        '1db6a761fa94a32741a05919d12d0211964647a61ffd32ba8619530ec089c980999aa1ded534c2652eb3baf15558bcb9842a23634eeef043a6ed3eb3f8e794ff'
        '8a1e7b5df65f5297f59aa17c4a52706413c1ffd88d8645de7359ec26f7059101ab81ac135cf7ef707a8acbeb709e1a6dae03d6a7e7f70c7e88185ebb271acbe4'
        'bd1299c24b738b3752e4d8d50ed1b2fa2f208c83e577876118d115fca22293e102614ae0cdc168060115f7145d951d290bccf21154fda4aabf55329d310b6aca'
        'e770000ea0c39f77bc36e7e5252e281b9f9d06a136c655cd702332cc8581f128263e172e41eab3b7ce2543da7065d8efc28c048588e577db5ee6ec4bfeb1019b'
        '0a29c9a3d1eae31731b76536a22aa23a4888b8ac55c3176c60a152330fce37e8031a4269fa28026133c7061cd769b1428bf24fe59fed574e39d52ea00b6e00a0')

prepare() {
  cd "$pkgname-$pkgver"
  # boatload of CVEs: http://cve.mitre.org/cgi-bin/cvekey.cgi?keyword=libquicktime
  patch -Np1 -i "../${pkgname}-1.2.4-CVE-2016-2399.patch"
  patch -Np1 -i "../${pkgname}-1.2.4-CVE-2017-9122_et_al.patch"
  # checks for faad2 are broken in configure.ac
  patch -Np1 -i "../${pkgname}-1.2.4-faad2.patch"
  # ffmpeg compatibility is very ancient
  patch -Np1 -i "../${pkgname}-1.2.4-ffmpeg2.patch"
  patch -Np1 -i "../${pkgname}-1.2.4-ffmpeg29.patch"
  patch -Np1 -i "../${pkgname}-1.2.4-ffmpeg4.patch"
  patch -Np1 -i "../${pkgname}-1.2.4-libavutil.patch"
  patch -Np1 -i "../${pkgname}-1.2.4-ffmpeg-codecs.patch"

  autoreconf -fiv
}

build() {
  cd $pkgname-$pkgver
  ./configure \
    --prefix=/usr \
    --enable-gpl \
    --with-faac \
    --with-ffmpeg \
    --with-libdv \
    --with-x264 \
    --without-doxygen

  # prevent excessive overlinking due to libtool
  sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
  make
}

package() {
  depends+=(libfaad.so)

  cd $pkgname-$pkgver
  make DESTDIR="$pkgdir" install
  install -vDm 644 {AUTHORS,ChangeLog,README,TODO} -t "${pkgdir}/usr/share/doc/${pkgname}"
}

I’ve adopted the pkgbuild and made the fix https://aur.archlinux.org/cgit/aur.git/commit/?h=libquicktime&id=f7f53abc244613fffe657fb77990eb700506c486

Somewhere before configuration or build starts

The ones in depends/makedepends/optdepends (not --with-ffmpeg \ in build() )


libquicktime-git builded without changes instead

1 Like

I updated today to my surprise it worked, and found this post! Thank you!

Also, thank you for explaining where to put something like this. I’ll refer back to this post in the future to try and learn how to edit the package and maybe one day adopt a package. I just don’t know how to do this stuff yet. I only started building packages and roms with success in the last few years, but only following instructions and if it doesn’t work out the box often stuck. One day maybe!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.