LenovoThinkpad E14 AMD Gen 2 FN Keys

To activate Lenovo function keys add the following line to /etc/crontab

@reboot root rtcwake -m mem -s 2

Reboot your system and function and special keys (volume, brightness, etc) should be working.
Note: It will probably work with other Lenovo models.

While I do not doubt you, I do wonder why this works, since the command only suspends the computer for 2 seconds…

From the man page:

$ manly  rtcwake -m mem -s 2

rtcwake - enter a system sleep state until specified wakeup time

-m, --mode mode
Go into the given standby state. Valid values for mode are:

-s, --seconds seconds
Set the wakeup time to seconds in the future from now.


$ tldr rtcwake

Enter a system sleep state until specified wakeup time relative to your BIOS clock.
More information: <https://manned.org/rtcwake>.
Show whether an alarm is set or not:
sudo rtcwake -m show -v
Suspend to RAM and wakeup after 10 seconds:
sudo rtcwake -m mem -s 10
Suspend to disk (higher power saving) and wakeup 15 minutes later:
sudo rtcwake -m disk --date +15min
Freeze the system (more efficient than suspend-to-RAM but version 3.9 or newer of the Linux kernel is required) and wakeup at a given date and time:
sudo rtcwake -m freeze --date YYYYMMDDhhmm
Disable a previously set alarm:
sudo rtcwake -m disable
Perform a dry run to wakeup the computer at a given time. (Press Ctrl + C to abort):
sudo rtcwake -m on --date hh:ss

Yes, you are right.
As you probably know, many Lenovo owners say that when they suspend their session the FN keys start working.
This does the same thing at boot with no need for the user to suspend the session to activate FN keys, when you login they are allready working normally.
There is an explanation somewhere on the net why this works

Nope. Didn’t know.

Still wondering why only works after a suspend…

Did it work for you?

Don’t have a laptop, never you mind an IBM peripheral…

Oh, ok.
I thought you had a Lenovo laptop.

Nah, just wondering…yeah, weird, I know…