Lenovo touchpad recognized by the system,but doesn't work correct

Since i installed the newest 20.2.1 KDE version of Manjaro , im struggling with touchpad issues.Cursor stops,freezes for a few seconds and is generally very sluggish.It makes the touchpad unusable.Even when i try to hover over something, its treated as a press and i can’t literally move anywhere.So also touch sensitivity is very high and delayed.

MODEL: IdeaPad Gaming 3 15ARH05

Result of cat /proc/bus/input/devices
I: Bus=0018 Vendor=06cb Product=ce2d Version=0100
N: Name="MSFT0001:00 06CB:CE2D Touchpad"
P: Phys=i2c-MSFT0001:00
S: Sysfs=/devices/platform/AMDI0010:03/i2c-0/i2c-MSFT0001:00/0018:06CB:CE2D.0001/input/input19
U: Uniq=
H: Handlers=event16 mouse1
B: EV=1b
B: KEY=e520 10000 0 0 0 0
B: ABS=2e0800000000003
B: MSC=20

Changing the options in SYSTEM SETTINGS > INPUT DEVICES > TOUCHPAD doesn’t help

What i’ve tried:

  • System reinstall

  • Drivers as mtrack,libinput, synaptics(Settings are actually changing but cursor still with the same issue)

  • Different GUI and distribution (still the same issue)

  • Different kernel(kernel 4.19 and below doesn’t even work on my device)

Everything works correct on Windows 10 , or when i plug in an external mouse.

I ran out of ideas ,so i would be really grateful for any advice and let me know if i missed something.Thank you;)

Update to kernel 5.11 is a solution.

Manjaro Settings Manager > Kernel > Install Kernel 5.11

Don’t remove previous version, reboot pc and choose new kernel in grub

Here is my post with almost same issue