Lenovo ThinkPad T14s Low Microphone Volume


The volume of my built-in microphone on my ThinkPad T14s (Gen 1, AMD) is really low. I have tried boosting the audio using pulse audio but that did not work. I think it is a driver related issue since it works perfectly fine using Windows 10.

I am using Manjaro 21.1.2 GNOME, with kernel Linux 5.13.13-1-MANJARO.

  Kernel: 5.13.13-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
  root=UUID=6e12e4bb-bd01-4f80-9111-0639404f8c65 rw quiet splash apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: GNOME 40.4 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: LENOVO product: 20UHCTO1WW v: ThinkPad T14s Gen 1 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 20UHCTO1WW v: SDK0R32862 WIN serial: <filter> 
  UEFI: LENOVO v: R1CET66W(1.35 ) date: 07/30/2021 
  ID-1: BAT0 charge: 51.4 Wh (88.6%) condition: 58.0/57.0 Wh (101.8%) 
  volts: 12.7 min: 11.5 model: SMP 5B10W139 type: Li-poly serial: <filter> 
  status: Unknown cycles: 5 
  RAM: total: 30.59 GiB used: 5.95 GiB (19.4%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 8-Core model: AMD Ryzen 7 PRO 4750U with Radeon Graphics bits: 64 
  type: MT MCP arch: Zen 2 family: 17 (23) model-id: 60 (96) stepping: 1 
  microcode: 8600106 cache: L2: 4 MiB bogomips: 54316 
  Speed: 3042 MHz min/max: 1400/1700 MHz boost: enabled Core speeds (MHz): 
  1: 3042 2: 3240 3: 1409 4: 1399 5: 1442 6: 1399 7: 1513 8: 1717 9: 2825 
  10: 2621 11: 1991 12: 4055 13: 1562 14: 1836 15: 1427 16: 1444 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy 
  constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs irperf lahf_lm 
  lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx 
  nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter 
  pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni 
  popcnt pse pse36 rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sha_ni 
  skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor 
  svm svm_lock syscall tce topoext tsc tsc_scale umip v_spec_ctrl 
  v_vmsave_vmload vgif vmcb_clean vme vmmcall wbnoinvd wdt xgetbv1 xsave 
  xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel bus-ID: 06:00.0 
  chip-ID: 1002:1636 class-ID: 0300 
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo bus-ID: 2-2:2 
  chip-ID: 04f2:b6cb class-ID: fe01 serial: <filter> 
  Device-3: Jieli USB PHY 2.0 type: USB driver: snd-usb-audio,uvcvideo 
  bus-ID: 6-2.3:8 chip-ID: 1224:2a25 class-ID: 0102 
  Display: wayland server: X.org 1.20.13 compositor: gnome-shell driver: 
  loaded: amdgpu note: n/a (using device driver) - try sudo/root display-ID: 0 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: AMD RENOIR (DRM 3.41.0 5.13.13-1-MANJARO LLVM 12.0.1) 
  v: 4.6 Mesa 21.2.1 direct render: Yes 
  Device-1: AMD vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 06:00.1 
  chip-ID: 1002:1637 class-ID: 0403 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo 
  driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x bus-ID: 06:00.5 
  chip-ID: 1022:15e2 class-ID: 0480 
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus-ID: 06:00.6 chip-ID: 1022:15e3 class-ID: 0403 
  Device-4: Jieli USB PHY 2.0 type: USB driver: snd-usb-audio,uvcvideo 
  bus-ID: 6-2.3:8 chip-ID: 1224:2a25 class-ID: 0102 
  Sound Server-1: ALSA v: k5.13.13-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.34 running: yes 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8168 v: 8.049.02-NAPI modules: r8169 port: 3400 
  bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp2s0f0 state: down mac: <filter> 
  Device-2: Realtek vendor: Lenovo driver: rtw89_pci v: N/A modules: rtw89pci 
  port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:8852 class-ID: 0280 
  IF: wlp3s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 
  bus-ID: 6-4:4 chip-ID: 0bda:4852 class-ID: e001 serial: <filter> 
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 476.94 GiB used: 23.85 GiB (5.0%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Lenovo model: UMIS RPIRJ512VME2OWD 
  size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 type: SSD serial: <filter> rev: 1.8Q1908 temp: 42.9 C scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 360.44 GiB size: 353.72 GiB (98.13%) 
  used: 23.82 GiB (6.7%) fs: ext4 dev: /dev/nvme0n1p4 maj-min: 259:4 
  label: N/A uuid: 6e12e4bb-bd01-4f80-9111-0639404f8c65 
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) 
  used: 29.3 MiB (11.4%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  label: SYSTEM uuid: 3AB6-9A89 
  Alert: No swap data was found. 
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 116.23 GiB fs: ntfs label: Windows 
  uuid: 009CBC309CBC21D8 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 1 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 2-2:2 info: Chicony Integrated Camera type: Video driver: uvcvideo 
  interfaces: 5 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 04f2:b6cb 
  class-ID: fe01 serial: <filter> 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-5: 5-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-6: 6-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 6-1:2 info: Realtek BillBoard Device type: Billboard driver: N/A 
  interfaces: 1 rev: 2.0 speed: 12 Mb/s chip-ID: 0bda:2169 class-ID: 1100 
  serial: <filter> 
  Hub-7: 6-2:5 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
  power: 100mA chip-ID: 05e3:0608 class-ID: 0900 
  Device-1: 6-2.1:6 info: Logitech G203 LIGHTSYNC Gaming Mouse type: Mouse,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 300mA chip-ID: 046d:c092 class-ID: 0300 serial: <filter> 
  Device-2: 6-2.2:7 info: Logitech Keyboard K120 type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s 
  power: 90mA chip-ID: 046d:c31c class-ID: 0300 
  Device-3: 6-2.3:8 info: Jieli USB PHY 2.0 type: Video,Audio 
  driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s 
  power: 500mA chip-ID: 1224:2a25 class-ID: 0102 
  Device-4: 6-3:3 info: Synaptics Prometheus MIS Touch Fingerprint Reader 
  type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 06cb:00bd class-ID: ff00 serial: <filter> 
  Device-5: 6-4:4 info: Realtek Bluetooth Radio type: Bluetooth driver: btusb 
  interfaces: 2 rev: 1.0 speed: 12 Mb/s power: 500mA chip-ID: 0bda:4852 
  class-ID: e001 serial: <filter> 
  Hub-8: 7-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 59.0 C mobo: N/A gpu: amdgpu temp: 46.0 C 
  Fan Speeds (RPM): fan-1: 2800 
  Processes: 381 Uptime: 1h 15m wakeups: 1 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: 11.1.0 Packages: 1245 pacman: 1236 lib: 334 
  flatpak: 0 snap: 9 Shell: Zsh v: 5.8 running-in: gnome-terminal inxi: 3.3.06

What should I do to make this better?

Thank you in advance!

1 Like

I have the exact same notebook and I can confirm the low mic volume. Nevertheless, I had so far no complaints about it from my meeting partners. My mic volume setting is 100%.

I had complaints from my meeting partners, Zoom even filters out the microphone sound as background noise which makes it look as if I am muted.

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


P.S. If you want to notify me that you did provide this information, please :heart: this message and I’ll come back and have another look.
P.P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which exact CPU/GPU or Kernel, … you have without typing it every time

1 Like

That doesn’t mean anything: Vendors just configure the Microsoft driver settings optimally for their hardware whereas you’re probably stuck with the defaults for the hardware under Linux.

  1. You have both PipeWire and PulseAudio running so let’s start with disabling PipeWire to keep things simple:

    systemctl --user disable --now pipewire.socket && systemctl --user disable --now pipewire.service && systemctl --user mask pipewire.socket
  2. Execute:

  3. Press F4 to go to the capture settings

  4. Press F6 to select the default:0 and you should see something like this:


  5. Use the on your keyboard to select the capture modes you have one by one.

  6. Use on your keyboard to crank everything up to 50% if it’s lower than that and 90% if it’s already above 50%.

  7. Go back to 5 and take the next capture mode until done.

  8. Press Esc to leave alsamixer

  9. Whisper during the first zoom meeting to ensure you don’t blast everyone’s ears out!

  10. Use your normal microphone settings in Gnome / Zoom Microphone settings to bring the microphone down to an acceptable level for your meeting partners.


Thank you for the instructions, I disabled PipeWire with the given command.

I had the following windows in alsamixer:

These are all my displayed devices:

default 0:

default 1:

Performing the Mic boost does not really change anything in my experience. The capture level was already on 100%. The USB device is a crappy webcam Mic which I do not use for anything.

PulseAudio settings:

  1. Please execute:

  2. Answer Y

  3. post the link you’ve been given to the data you collected or post the full contents of the /tmp/asla-info.txt.RandomNumber file if you feel hesitant to upload your data there.

  4. I will then call in our resident Audio Über-Guru. :grin:


Thanks for the help, I really appreciate it!

Here is the link:


1 Like

Have I told you to try an LTS kernal already???

If not, please read this:

While I analyze your alsa output.


I did not try that yet, but that is something for the weekend since this is my main device to do my work

Okay, I tried out Kernel LTS and that did not solve the issue sadly…


Low mic. Boost doesn’t help. I’m out of my league.


Did you try this already?


The microphone may not be operational. A possible fix is to blacklist the snd_pci_acp3x module (to allow newer kernels to use snd_rn_pci_acp3x?) 

Not that it’s not working, but maybe it makes a difference… :man_shrugging: (I have a similar laptop; never tried the internal mic though)

1 Like

Yes I tried that again, does not seem to make any difference

1 Like

It seems that one of the last alsa updates made it a little better, but people still complain that I sound very quiet in calls