Lenovo screen flashes twice then suddenly mouse pointer appears with Lenovo logo and immediately manjaro will ask for password

Hi all. I am not acquainted with Computers much. I understand a bit of windows and lesser bit of linux. Consider me a newbie and see if my problem has any solution.

I am using Lenovo laptop that is given by company I work for. It has windows 10 with two main partitions that we see in “my pc”. So I installed Manjaro on the second.

Now, after each restart, the Lenovo Logo at BIOS screen will flash twice (usually it had been once) and then in a few seconds I can see A mouse pointer beneath it and in another few seconds Manjaro will come into picture asking for my password.

Second thing, I don’t see any boot menu which used to ask if I want to boot in windows or Manjaro.
I Tried to fix usual grub repair commands from Manjaro but no change. I also tried bootrec /fixboot in command prompt using a windows recovery drive but it will always end up with “access denied”.

I have tried lot many things through youtube including a suggested boot repair app something like “rescapp” but all failed.

Please guide me.
I can reset windows PC but it being a office laptop all admin settings will be lost and that will be a problem because I should not have tampered with the laptop when there is an IT team (of one person) To solve problems. (He was never useful so I had started doing things myself)

Please help.

Welcome to the forum! :slight_smile:

This is normal. The first time you see the Lenovo logo is when the UEFI is starting up and initializing the hardware. The second time you see it, it’s because Manjaro uses the UEFI logo as a boot splash theme. Then your mouse cursor will appear as the graphical display server is starting, and then you get to see the graphical login screen.

It’s all normal. :wink:

Edit the file /etc/default/grub and make sure that the following five lines are identical to this below…


Then, open up a terminal and issue the following command…

sudo update-grub

thank you brother for the reply.
I did as you asked but still don’t see windows option. Did I miss something?

I get the following options now-

  1. Manjaro Linux
  2. Advanced options for Manjaro Linux
  3. UEFI Firmware Settings

When was the last time you updated your system? There has been a change to GRUB two updates ago ─ a fix for the “boot hole” vulnerability ─ that requires an extra step.

Assuming that your system boots in UEFI mode and that your operating systems are installed on /dev/sda, you must first update the system and then reinstall GRUB to the EFI System Partition. :arrow_down:

sudo pacman-mirrors -f 5 && sudo pacman -Syyu
sudo grub-install --recheck --no-rs-codes --modules="part_gpt zstd" --removable /dev/sda
sudo update-grub

Also, make sure you’ve got os-prober installed, and that /etc/grub.d/30_os-prober has execute permission.

I had installed it a couple days back.

Package Manager had showed some 300 plus updates that I did but never updated via terminal.

I am following the above and its happening while I type.

But being new, please tell me how to get “os-probe” and how to give it execute permissions?

It’s a package ─ os-prober ─ from the normal repository that should normally be installed by default, but some people uninstall it and others remove the execute permission. If you have not uninstalled it or removed the execute permission, then it should still be functional.

It’s a shell script as an add-on to GRUB that scans your drive for other operating systems and then adds those to the GRUB boot menu.

I am still getting the following options on boot menu…

Manjaro Linux
Advanced options for Manjaro Linux
UEFI Firmware Settings

Did you run these two commands before you rebooted? :arrow_down:

sudo grub-install --recheck --no-rs-codes --modules="part_gpt part_msdos zstd" --removable /dev/sda
sudo update-grub

(Assuming your boot drive is /dev/sda.)

Yes Yes I did that.
But still I am not getting windows option.

What is the output of…

ls -l /boot/efi/EFI

This is what I get…

~ >>> ls -l /boot/efi/EFI
ls: cannot access ‘/boot/efi/EFI’: Permission denied
~ >>> sudo ls -l /boot/efi/EFI [2]
[sudo] password for vaibhav:
total 8
drwx------ 2 root root 4096 Aug 20 10:10 boot
drwx------ 2 root root 4096 Aug 20 10:10 Manjaro

Okay, and what’s the output of…

sudo ls -l /boot/efi/EFI/boot

~ >>> sudo ls -l /boot/efi/EFI/boot
[sudo] password for vaibhav:
total 268
-rwx------ 1 root root 274432 Aug 22 20:49 bootx64.efi

Okay, so that means that you don’t have a Windows boot loader in your EFI system partition anymore.

Now, this is not a Windows support forum, and I myself don’t use Microsoft Windows, but I’ve done some searching on the web on your behalf, and I think you may possibly find a solution to repair your Windows boot loader at the link below. :arrow_down:


If the above advice breaks your computer, then you get to keep all the pieces. :stuck_out_tongue:

1 Like

@vaitri2009 Hey

Were you able to figure out the fix for given problem, I am also facing the exact same issue :confused:

Just posting it out here, not the best solution but worked for me.
I had 2 drives, ssd and hdd. At first in hdd I installed windows 10, then I tried installing Manjaro in ssd and after that, it automatically loads manjaro.

Problem is that in /boot/efi/EFI there was no Microsoft folder, so I manually copied the files as:

  1. Open terminal from hard drive where windows is installed, go to path C:\Windows\Boot\EFI and copy it’s content to: /boot/efi/EFI/Microsoft/Boot/
  2. Once file is pasted, create one bootable pendrive of Windows 10, load it up and select Auto Repair option. This time windows will fix the boot system
  3. Now when you will restart, it will open up windows by default and if you want to select Manjaro, then you can change Boot priority for ssd first and hdd second. Bit of a manual work but atleast it’s working

Later on, if you will boot Manjaro and update it’s kernel and everything, then automatically in next restart of Manjaro it will detect WIndows 10.

This is kind of hack which I pulled it off. Not the best solution but anyone can try if you are in similar scenario like me