Lenovo Legion 5 Pro - unable to adjust brightness

I have recently acquired a Lenovo Legion 5 Pro notebook with AMD Ryzen and Nvidia 3050ti. After installing Manjaro I have an issue with adjusting brightness. I simply cannot adjust it. I know that this topic was already covered in several other threads. Since yesterday I have visited a lot of websites and didn’t find the solution.

I have followed tips from these websites:


These command doesn’t do anything

xbacklight -dec 10

Some outputs:

$ inxi -Fazy                                                                                                                                                                                                                                 
  Kernel: 5.15.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.15-x86_64
  root=UUID=cd5aafe9-277d-4a1a-ae56-b62ceb679dbc rw rootflags=subvol=@
  reboot=acpi quiet apparmor=1 security=apparmor udev.log_priority=3
  nvidia.NVreg_RegistryDwords=EnableBrightnessControl=1 acpi_osi=Linux
  amdgpu.backlight=0 acpi_backlight=vendor video.use_native_backlight=1
  Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
  Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82JS v: Legion 5 Pro 16ACH6
  serial: <superuser required> Chassis: type: 10 v: Legion 5 Pro 16ACH6
  serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN
  serial: <superuser required> UEFI: LENOVO v: HHCN20WW date: 10/01/2021
  ID-1: BAT0 charge: 30.5 Wh (37.1%) condition: 82.3/80.0 Wh (102.9%)
  volts: 15.7 min: 15.4 model: Sunwoda L20D4PC1 type: Li-poly serial: <filter>
  status: Charging cycles: 3
  Info: 6-Core model: AMD Ryzen 5 5600H with Radeon Graphics bits: 64
  type: MT MCP arch: Zen 3 family: 19 (25) model-id: 50 (80) stepping: 0
  microcode: A50000C cache: L1: 384 KiB L2: 3 MiB L3: 16 MiB
  flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  bogomips: 79080
  Speed: 2340 MHz min/max: 1200/3300 MHz boost: enabled Core speeds (MHz):
  1: 3393 2: 2834 3: 2394 4: 2437 5: 3355 6: 3556 7: 3032 8: 2966 9: 2732
  10: 3102 11: 3076 12: 2517
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW,
  STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA107BM [GeForce RTX 3050 Ti Mobile] vendor: Lenovo
  driver: nvidia v: 495.44 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
  chip-ID: 10de:25e0 class-ID: 0300
  Display: x11 server: X.Org compositor: kwin_x11 driver:
  loaded: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1600 s-dpi: 191 s-size: 340x221mm (13.4x8.7")
  s-diag: 406mm (16")
  Monitor-1: DP-4 res: 2560x1600 hz: 60 dpi: 188 size: 345x215mm (13.6x8.5")
  diag: 407mm (16")
  OpenGL: renderer: NVIDIA GeForce RTX 3050 Ti Laptop GPU/PCIe/SSE2
  v: 4.6.0 NVIDIA 495.44 direct render: Yes
  Device-1: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  chip-ID: 10de:2291 class-ID: 0403
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo
  driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x
  bus-ID: 06:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel
  v: kernel bus-ID: 06:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.2-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Lenovo driver: r8169 v: kernel port: 2000 bus-ID: 03:00.0
  chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Realtek vendor: Lenovo driver: rtw89_pci v: N/A modules: rtw89pci
  port: 1000 bus-ID: 04:00.0 chip-ID: 10ec:8852 class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
  bus-ID: 3-4:2 chip-ID: 0bda:4852 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
  Local Storage: total: 1.38 TiB used: 16.48 GiB (1.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:4 vendor: Samsung model: MZALQ512HBLU-00BL2
  size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
  lanes: 4 type: SSD serial: <filter> rev: 5L2QFXM7 temp: 34.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Samsung
  model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
  logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
  rev: 2B2QEXM7 temp: 33.9 C scheme: GPT
  ID-1: / raw-size: 128 GiB size: 128 GiB (100.00%) used: 16.48 GiB (12.9%)
  fs: btrfs dev: /dev/nvme1n1p1 maj-min: 259:1
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 568 KiB (0.2%) fs: vfat dev: /dev/nvme1n1p2 maj-min: 259:2
  ID-3: /home raw-size: 128 GiB size: 128 GiB (100.00%)
  used: 16.48 GiB (12.9%) fs: btrfs dev: /dev/nvme1n1p1 maj-min: 259:1
  ID-4: /var/log raw-size: 128 GiB size: 128 GiB (100.00%)
  used: 16.48 GiB (12.9%) fs: btrfs dev: /dev/nvme1n1p1 maj-min: 259:1
  Alert: No swap data was found.
  Message: No sensor data found. Is lm-sensors configured?
  Processes: 340 Uptime: 4m wakeups: 1 Memory: 15.54 GiB
  used: 2.17 GiB (14.0%) Init: systemd v: 249 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1287 lib: 335 flatpak: 0
  Shell: Zsh v: 5.8 default: Bash v: 5.1.8 running-in: yakuake inxi: 3.3.09
$ mhwd --listinstalled                                                                                                                                                                                                                       
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.11.04               false            PCI

Warning: No installed USB configs!

$ ls /sys/class/backlight/                                                                                                                                                                                                                   
ideapad  nvidia_0

$ cat /usr/share/X11/xorg.conf.d/10-amdgpu-nvidia-drm-outputclass.conf                                                                                                                                                                
Section "ServerLayout"
    Identifier "layout"
    Option "AllowNVIDIAGPUScreens"

Section "OutputClass"
    Identifier "AMDgpu"
    MatchDriver "amdgpu"
    Driver "amdgpu"

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    ModulePath "/usr/lib/nvidia/xorg"
    ModulePath "/usr/lib/xorg/modules"
    Option "RegistryDwords" "EnableBrightnessControl=1"

Hello and welcome to Manjaro

Am… Have you tired with xorg-xbacklight package ?? If no install it and try.
This is the arch wiki page, Backlight Arch Wiki, skim though it. Maybe it will help :man_shrugging:

As I mentioned xbacklight doesn’t work for me.

So far it’s correct but you still need to update the grub configurations:

  1. sudo nano /etc/default/grub
  2. Add “video.use_native_backlight=1” to GRUB_CMDLINE_LINUX_DEFAULT, for example GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash …OTHER_CURRENT_ENTRIES_HERE… video.use_native_backlight=1”
  3. sudo update-grub
  4. Reboot

Hey I have exact same problem with the same machine. Did you find a solution to the problem? @JiaZhang 's solution didn’t work for me.

Hi @owais , you should create a new topic, then provide your system information and what you have done so far.

Had this problem with my Lenovo Legion 5 with Intel igpu and Nvidia 3050 ti as well, no matter what solutions I tried. Upgrading to kernel 5.16 fixed it for me.