Lenovo Legion 5 amd ryzen nvidia - issue with using a second monitor


I’m new to Manjaro and a beginner in Linux - I bought recently a new Lenovo Legion 5 laptop and installed Manjaro (I had the same problems also with Ubuntu and Mint).

I’m having an issue with using a second monitor, depending on what kind of driver I have (I tried different combinations):

  • nvidia proprietary ones - it doesn’t boot if the second monitor is plugged in, if I unplug it before I start the laptop and then connect it, it’s working I can see the second screen then

  • open source drivers - boots if the the second monitor is plugged in on startup, but if I start without the monitor being connected it doesn’t start - hangs on a black screen

I also have an issue with not being able to use the touch-pad or change the screen brightness (but these I can survive).

I checked some posts in the forum, troubleshooting guides, but most of the solutions look like they’re quite tailor-made to the setup of the laptop.

Would anyone be able to help? Pasted some of the details below, not sure what can be useful to debug.
I’d be very grateful if I could get it to work properly.


  • amd ryzen 5 4600H with Radeon Graphics

current drivers:
I tried several combinations: only video-nvidia / only video-linux/ video-nvidia and video-linux together

uname -r

cat /etc/lsb-release:heavy_check_mark:

Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Address sizes: 48 bits physical, 48 bits virtual
Byte Order: Little Endian
CPU(s): 12
On-line CPU(s) list: 0-11
Vendor ID: AuthenticAMD
Model name: AMD Ryzen 5 4600H with Radeon Graphics
CPU family: 23
Model: 96
Thread(s) per core: 2
Core(s) per socket: 6
Socket(s): 1
Stepping: 1
Frequency boost: enabled
CPU max MHz: 3000,0000
CPU min MHz: 1400,0000
BogoMIPS: 5990.96
Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mc
a cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall n
x mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_go
od nopl nonstop_tsc cpuid extd_apicid aperfmperf pni pc
lmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2 movbe popc
nt aes xsave avx f16c rdrand lahf_lm cmp_legacy svm ext
apic cr8_legacy abm sse4a misalignsse 3dnowprefetch osv
w ibs skinit wdt tce topoext perfctr_core perfctr_nb bp
ext perfctr_llc mwaitx cpb cat_l3 cdp_l3 hw_pstate ssbd
mba ibrs ibpb stibp vmmcall fsgsbase bmi1 avx2 smep bm
i2 cqm rdt_a rdseed adx smap clflushopt clwb sha_ni xsa
veopt xsavec xgetbv1 xsaves cqm_llc cqm_occup_llc cqm_m
bm_total cqm_mbm_local clzero irperf xsaveerptr rdpru w
bnoinvd arat npt lbrv svm_lock nrip_save tsc_scale vmcb
_clean flushbyasid decodeassists pausefilter pfthreshol
d avic v_vmsave_vmload vgif v_spec_ctrl umip rdpid over
flow_recov succor smca
Virtualization features:
Virtualization: AMD-V
Caches (sum of all):
L1d: 192 KiB (6 instances)
L1i: 192 KiB (6 instances)
L2: 3 MiB (6 instances)
L3: 8 MiB (2 instances)
NUMA node(s): 1
NUMA node0 CPU(s): 0-11
Itlb multihit: Not affected
L1tf: Not affected
Mds: Not affected
Meltdown: Not affected
Spec store bypass: Mitigation; Speculative Store Bypass disabled via prctl
and seccomp
Spectre v1: Mitigation; usercopy/swapgs barriers and _user pointer
Spectre v2: Mitigation; Full AMD retpoline, IBPB conditional, IBRS

FW, STIBP conditional, RSB filling
Srbds: Not affected
Tsx async abort: Not affected

inxi -Fazy (part of the output)
Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64
root=UUID=75c0ad30-6577-450a-a563-c452135f3e61 rw quiet splash apparmor=1
security=apparmor udev.log_priority=3
Desktop: GNOME 40.5 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1
Distro: Manjaro Linux base: Arch Linux
Type: Laptop System: LENOVO product: 82B5 v: Lenovo Legion 5 15ARH05
serial: Chassis: type: 10 v: Lenovo Legion 5 15ARH05
Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: UEFI: LENOVO
v: EUCN28WW date: 10/20/2020
Info: 6-Core model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64
type: MT MCP arch: Zen 2 family: 17 (23) model-id: 60 (96) stepping: 1
microcode: 8600103 cache: L2: 3 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 71891
Speed: 1397 MHz min/max: 1400/3000 MHz boost: enabled Core speeds (MHz):
1: 1397 2: 2520 3: 1397 4: 1397 5: 1397 6: 1397 7: 1397 8: 1397 9: 1397
10: 1397 11: 1397 12: 1397
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Lenovo
driver: nouveau v: kernel bus-ID: 01:00.0 chip-ID: 10de:1f95 class-ID: 0300
Device-2: Syntek Integrated Camera type: USB driver: uvcvideo bus-ID: 1-3:3
chip-ID: 174f:244c class-ID: 0e02 serial:
Display: wayland server: X.org 1.20.13 compositor: gnome-shell driver:
loaded: modesetting alternate: fbdev,vesa display-ID: 0
resolution: <missing: xdpyinfo>
OpenGL: renderer: NV167 v: 4.3 Mesa 21.2.3 direct render: Yes

I tried also installing different kernels, but I didn’t help:
5.10.70-1, 5.12.19-1, 5.13.19-2, 5.14.10-1, 5.15.rc3.210926.g5816b3e-1

Managed to solve it: in the boot menu that I entered after pressing F2 on startup, there was a boot option set to legacy → I changed to uefi and after this the second screen is working, touchpad works and I can change the screen brightness :slight_smile: