Lenovo Laptop stuck on boot menu after setting UEFI to pure UEFI mode

I recently decided to stop dual booting and deleted my Windows 10 partitions, including the system reserved partition. I then realised that it was no longer possible to boot my laptop from USB. I wanted to reinstall windows or Manjaro in a way that I could use my machine properly again, but nothing worked. It kept just sending me to the “working” Manjaro login. In an attempt to force it to boot from a windows install medium, I set the UEFI to pure UEFI, knowing that windows allows this mode while Manjaro doesn’t. This got be stuck on the Lenovo splash screen or the boot menu on boot. I can select the USB key on the menu as well as the manjaro bootloader, but neither of them start. Any Help?

Welcome to the forum! :slight_smile:

This is blatantly false. My own system here has no Microsoft Windows on it ─ nor any other distribution than Manjaro, for that matter ─ and it boots in strict UEFI-only mode.

What Manjaro does not support is Secure Boot, but you can switch off Secure Boot and still have the machine booting in pure UEFI mode.

That’s because you probably installed Manjaro in legacy BIOS mode. Many UEFI implementations will attempt to boot in legacy BIOS mode first if both UEFI mode and CSM (legacy BIOS mode) are enabled in the firmware settings.

The refusal of your system to boot from a USB stick may be due to Secure Boot being active.

Ok, sorry I was not aware Manjaro supported pure UEFI, but I still have no way of turning off secure boot (to my knowledge) since every way I have tried to access my BIOS has not worked…

Also how would I install Manjaro for UEFI and how would it be different? Would I have to reinstall?

Um, in your opening post, you wrote… :arrow_down:

So apparently you do know how to get into the UEFI firmware setup.

The installer image can boot in either mode and will detect whether your hardware is booting in UEFI mode or in CSM (legacy BIOS) mode. So you don’t have to do anything special with regard to that.

The boot process is very different. With a legacy BIOS boot, there are two options…

  • Either you have an MS-DOS MBR-style partition table, in which case the legacy version of the GRUB boot loader will be installed in the MBR of your fixed drive; or…

  • You have a GPT (GUID partition table), in which case you need a special and unformatted partition of type bios-grub, about 2 MiB in size, and with the boot flag set in the partition table. GRUB will then install its core.img in that free space, because without it, it will overwrite partition boundaries and damage the first partition.

Now, with a UEFI-native boot, you have to use a GPT, but instead of the unformatted bios-grub partition, you now need a 512 MiB EFI system partition formatted as vfat (i.e. FAT32), and also with the boot flag set. In a native UEFI boot, the system will use a UEFI-native version of GRUB, which will install part of itself in this EFI system partition. The EFI system partition is read by the UEFI’s own boot manager, and is intended to contain the boot loaders of as many UEFI-native operating systems as you wish to install.

One of the main differences is also that with a native UEFI boot, the machine boots up in 64-bit mode, and this allows the kernel to connect more directly with the firmware and the hardware, given that the firmware and the operating system kernel are both running in the 64-bit long mode address space of the processor.

With a legacy BIOS boot, this is not the case, as the processor will be reset to the 8086-compatible 16-bit “real mode” before the GRUB boot loader becomes active, and then the boot process of the kernel itself is very different too. The compressed kernel image will then first copy information about the hardware that was exported via “real mode” into a protected area of the memory address space before it can switch to 64-bit long mode and decompress the runtime kernel.

UEFI is the successor to the legacy BIOS boot method, and is much more efficient. And as explained higher up in this post, it also more easily allows multiple operating systems to coexist peacefully on the same computer.

Unless you absolutely know what you’re doing, reinstalling will probably be the best option, yes.

1 Like

So apparently you do know how to get into the UEFI firmware setup.

That was before the system locked up. I could access UEFI firmware setup just fine before I changed that setting.

Do you know of a way I could attempt to access the UEFI now? I have already tried all the F keys at boot and all the F keys with Fn pressed, and I know of no other way of getting into the UEFI firmware setup. (Except the grub screen, which I cannot get to currently)

Well, only you know what you did and how you did it. I’d recommend consulting the machine’s manual. :man_shrugging:

All the manual for the machine tells me to do is press F2 when the first lenovo splash screen appears, which just gets me stuck on the splash screen. Any ideas?

You could try to remove the CMOS battery and then put it back after about five minutes. You will then of course have to set up all your UEFI settings again, but at least you’ll regain access to those settings.


Sorry if this sounds stupid, but this doesnt erase anything else right?

Also that means I take off the back plate, remove the battery, find a shiny round thing underneath which I take out and then replace it after 5 minutes. Is that remotely correct?

1 Like

Maybe this helps, please see:

1 Like

Not like my situation at all, sorry… I have no access whatsoever to the OS.

I’ve sent in a warranty request and hope to get it fixed by them. Thanks for the ideas!