Lenovo Ideapad 5 pro 16-ACH6 wifi not working

Hello everyone! I am new to Manjaro, it works very well on my Lenovo Ideapad 5 pro 16-ACH6. After full installation I can’t understand why wifi doesn’t work.
This is my output for inxi -Nazy:

  Device-1: Realtek vendor: Lenovo driver: N/A port: 2000 bus-ID: 03:00.0 
  chip-ID: 10ec:8852 class-ID: 0280 
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 
  bus-ID: 4-1.3:5 chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>

This is output for rfkill list:

0: ideapad_wlan: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: ideapad_bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no
2: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

As I understand this means that driver for wifi is installed and works well. Why wifi isn’t working?

1 Like

This is one of the exceptions where you need to install a driver in Linux.

  1. Activate the AUR

  2. Execute:

    pamac build rtw89-dkms-git


1 Like

:+1: Welcome to Manjaro! :+1:

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

P.P.S. @tux-86 I’ve edited your post to be much more clear to a brand new user:

  • They don’t know what the AUR is
  • They don’t know how to install packages
  • They’ll think they need to install drivers like in Windows, whereas on Linux, 99% of all drivers are in the kernel…

Please press the orange pencil in the top right of your post and press raw to see what I changed exactly!

:bowing_man: :pray:

P.P.P.S. Although I’m a moderator on this site, this is not an official warning: just helping you to become a more productive member of this forum.

1 Like

This works! Thank you very much! I am really appreciate your help!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.