Lenovo ideapad 5 14 ARE05 touchpad--no driver? KDE sees nonexistant mouse

I am installing KDE on the lenovo ideapad 5 14ARE05. (Flex)
The trackpad is unresponsive. Using the KDE system settings, it appears that the trackpad is being identified as the mouse, but as far as I can tell there is no trackpad driver at all.There is a similar problem that to addressed with this laptop in Windows, which tells you to go into the mouse settings, where you can find a separate tab for the trackpad. KDE simply states no trackpad is found.
The Windows solution states that if that trackpad tab is not available, that a BIOS update might be needed.

I have tried a bunch of fixes that were designed for the problem where the touchpad is being seen as the touchscreen, but they ended up just shutting down my touchscreen. I tried adding the xorg synaptics driver, just in case, although I believe my touchpad is supposed to be elan.

here is my xinput output:

⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Wacom HID 5218 Finger                     id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Integrated Camera: Integrated C           id=10   [slave  keyboard (3)]
    ↳ Ideapad extra buttons                     id=11   [slave  keyboard (3)]
    ↳ Wacom HID 5218 Pen                        id=12   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=14   [slave  keyboard (3)]

Is there a way to add an Elan driver? Should I suck it up and try a BIOS update? I dont want to brick a new laptop.

Here is my inxi info

$ inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 5.10.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=d089146d-67a1-41e4-b6de-24993ceb24a1 ro quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Convertible System: LENOVO product: 81X2 v: IdeaPad Flex 5 14ARE05 
  serial: <filter> Chassis: type: 31 v: IdeaPad Flex 5 14ARE05 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40700 WIN serial: <filter> 
  UEFI: LENOVO v: EECN29WW date: 10/15/2020 
  ID-1: BAT0 charge: 52.6 Wh condition: 52.6/52.6 Wh (100%) volts: 13.0/11.5 
  model: Sunwoda L19D3PD6 type: Li-poly serial: <filter> status: Full 
  cycles: 4 
  RAM: total: 15.07 GiB used: 2.44 GiB (16.2%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 6-Core model: AMD Ryzen 5 4500U with Radeon Graphics bits: 64 
  type: MCP arch: Zen 2 family: 17 (23) model-id: 60 (96) stepping: 1 
  microcode: 8600104 L2 cache: 3 MiB bogomips: 28453 
  Speed: 1397 MHz min/max: 1400/2375 MHz boost: enabled Core speeds (MHz): 
  1: 1397 2: 1397 3: 1397 4: 1397 5: 1397 6: 1397 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy 
  constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs irperf lahf_lm 
  lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx 
  nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter 
  pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni 
  popcnt pse pse36 rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sev 
  sev_es sha_ni skinit smap smca sme smep ssbd sse sse2 sse4_1 sse4_2 sse4a 
  ssse3 stibp succor svm svm_lock syscall tce topoext tsc tsc_scale umip 
  v_vmsave_vmload vgif vmcb_clean vme vmmcall wbnoinvd wdt xgetbv1 xsave 
  xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel bus ID: 04:00.0 
  chip ID: 1002:1636 class ID: 0300 
  Device-2: Acer Integrated Camera type: USB driver: uvcvideo bus ID: 1-4:2 
  chip ID: 5986:212a class ID: 0e02 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 158 size: 309x173mm (12.2x6.8") 
  diag: 354mm (13.9") 
  OpenGL: renderer: AMD RENOIR (DRM 3.40.0 5.10.15-1-MANJARO LLVM 11.0.1) 
  v: 4.6 Mesa 20.3.4 direct render: Yes 
  Device-1: AMD driver: snd_hda_intel v: kernel bus ID: 04:00.1 
  chip ID: 1002:1637 class ID: 0403 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo 
  driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus ID: 04:00.5 
  chip ID: 1022:15e2 class ID: 0480 
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 04:00.6 chip ID: 1022:15e3 class ID: 0403 
  Sound Server: ALSA v: k5.10.15-1-MANJARO 
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Lenovo driver: rtw_8822ce v: N/A modules: rtw88_8822ce port: 2000 
  bus ID: 02:00.0 chip ID: 10ec:c822 class ID: 0280 
  IF: wlp2s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
  IP v4: <filter> scope: global 
  IP v6: <filter> scope: global 
  IP v6: <filter> virtual: stable-privacy scope: link 
  WAN IP: <filter> 
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 
  bus ID: 3-4:3 chip ID: 0bda:c123 class ID: e001 serial: <filter> 
  Message: Required tool hciconfig not installed. Check --recommends 
  Message: No RAID data was found. 
  Local Storage: total: 238.47 GiB used: 10.47 GiB (4.4%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Lenovo model: UMIS RPJTJ256MEE1OWX 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 rotation: SSD serial: <filter> rev: 2.0C0628 temp: 32.9 C 
  scheme: GPT 
  Message: No Optical or Floppy data was found. 
  ID-1: / raw size: 221.59 GiB size: 217.11 GiB (97.98%) 
  used: 10.47 GiB (4.8%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  label: N/A uuid: d089146d-67a1-41e4-b6de-24993ceb24a1 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A 
  uuid: 400C-D673 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 16.58 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p3 maj-min: 259:3 label: N/A 
  uuid: ba325d12-6626-426e-85d3-46f3332e774e 
  Message: No Unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Device-1: 1-4:2 info: Acer Integrated Camera type: Video driver: uvcvideo 
  interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 5986:212a class ID: 0e02 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 class ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Device-1: 3-3:2 info: Synaptics type: <vendor specific> driver: N/A 
  interfaces: 1 rev: 2.0 speed: 12 Mb/s chip ID: 06cb:00be class ID: ff00 
  serial: <filter> 
  Device-2: 3-4:3 info: Realtek Bluetooth Radio type: Bluetooth driver: btusb 
  interfaces: 2 rev: 1.0 speed: 12 Mb/s chip ID: 0bda:c123 class ID: e001 
  serial: <filter> 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 class ID: 0900 
  System Temperatures: cpu: 52.4 C mobo: 38.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 229 Uptime: 49m wakeups: 6 Init: systemd v: 247 Compilers: 
  gcc: 10.2.0 Packages: pacman: 1293 lib: 408 flatpak: 0 Shell: Bash v: 5.1.0 
  running in: konsole inxi: 3.3.01 ```

Try Kernel 5.11 - it has support for more touchscreens/touchpads

Thank you, but sadly that had no effect.

More information–It seems that the trackpad is definitely being treated as a mouse–
I tried to connect my wireless logitech mouse (using solaar) and the solaar app works fine and recognizes the mouse, but I get no cursor or any other interaction. However, going through the kde system settings, I can see that under trackpad, I have information about my logitech mouse as n ignored device. It also lists the lenovo thinkpad usb keyboard with trackpad is ignored.

I’m using an Ideapad 5 14 (14ARE05), but not the Flex - apparently Lenovo uses the same identifier for several models (whyever it would do that).

My laptop is using an MSFT touchpad, which used to have issues until semi-recently, but if I remember right, there also used to be problems with the Ideapad 5 15 models, which come with an Elan touchpad as well.
There was a solution, if I’m not mistaken, so maybe that’s a starting point for you?

See e.g. here:

Thank you, I’ve tried those fixes without luck. I am thinking maybe I have the MSFT touchpad instead of the elan-- its hard to tell when the hardware isnt being recognized. For some reason the lenovo website spec sheets dont list the touchpad specifics. Can you tell me what fixed your problems? Also, did you use uefi or standard bios when you loaded? Thanks!

I actually did nothing, the issues were eventually fixed in one of the 5.9 kernels.
Prior to that about every other boot, the touchpad would not be recognized. When it was, it worked fine, however. Just no guarantee it would com up after booting.

There briefly was a similar issue again with one of the 5.10 kernels (the one directly after the last stable update), but that seems fixed again with the next kernel update which dropped soon after.

My laptop is using UEFI, although I don’t really think it matters here.

Thanks for the input. I’m going to try reinstalling using the UEFI option for giggles. I hope you have a good day!

I bought my new Lenovo Flex 4 with the Ryzen 7 4700 APU just a couple of weeks ago. I installed the newest version of Manjaro KDE, but I still have the stock Windows 10 installed. I have also had sthe same touchpad issues described here. I will chronicle my experiences below as it’s possible it could be useful to someone else.
When I first installed Manjaro, the touchpad wouldn’t work. I switched to one of the recommended kernels, but it still didn’t make the touchpad work. So, whenever I booted up my computer I would use a wireless mouse. After a couple of days, my touchpad starting working again! How strange.
But then I logged into Windows, I did an update, and when I booted into Manjaro the next time, the touchpad stopped working. Very annoying.
I started using my wireless keyboard mouse again. I started working through some other bugs and issues, like my backlight issue, and the “Failed to start pkgfile database update” on bootup problem I had. Just today, I booted up Manjaro, and ope, my touchpad starting working again.
I wonder if the issue isn’t so much the fact that the touchpad driver isn’t there, it’s just being misidentified as a mouse rather than a touchpad, and by inserting an actual mouse- it disturbs some program classifications and makes the computer recognize the touchpad as the touchpad and the mouse as the mouse. Perhaps that’s the issue. But then I’m not a programmer and all I can do is speculate. But my situation could give a clue as to the particular nature of this bug.
(Also, as a sidenote, often a left-click will register as a right-click. This is a problem I have even in Windows. The touchpad could use some refinement in either case, it’s not entirely Manjaro’s fault.)

1 Like

I am still trying to get the touchpad to work. Due to various calamities, I haven’t been able to work on this fore several months. Weirdly, the first time I booted up, I had a working touchpad, first time ever. Sadly, after updating, I have been unable to replicate. I saw that the Arch wiki had a solution, which I attempted, but did nothing.

I also see this suggestion– but it is not Manjaro specific. Can someone tell me how to modify this to be appropriate to Manjaro?

I had this same issue. The problem is with the kernel. The kernel hasn’t detected the touch pad. Firstly edit the kernel boot parameters. This is what i did to solve it - EDIT: It is recommended to take a backup using cp /etc/default/grub /etc/default/grub.bak

  1. sudo nano /etc/default/grub
  2. Edit GRUB_CMDLINE_LINUX_DEFAULT to GRUB_CMDLINE_LINUX_DEFAULT="quiet i8042.nopnp=1 pci=nocrs"
  3. Now save and exit.
  4. Run sudo update-grub

The next steps will be to patch the kernel

  1. Now run git clone https://github.com/pavlepiramida/elan_i2c_dkms.git
  2. After that install make and dkms, so run sudo apt install make dkms
  3. Now run cd elan_i2c_dkms
  4. After that run sudo dkms install .
  5. Finally, run reboot

Hi, by any chance, Have you figiured out how to fix the touchpad issue? I recently bought the Flex 5, everything runs perfectly except the touchpad. Thank you in advance, if you could provide your solution here.

Sadly, I have not. It does not seem to be a problem specific to Manjaro, either. I have had the mouse appear as it should exactly once, and I have not been able to recreate that situation. I am hoping for an upcoming kernel to address the problem.

If you happen to find a solution I would be equally grateful if you could post it. Sorry I am not of more help!

Thanks for your reply, and I also tried to install Ubuntu 20.04, said 5.9 kernel is compatible with touch pad, but from my end, it does not work either. Anyway I will keep looking for alternatives. Than you

Hi, I tested almost every solutions found online, all failed. It seems that the problem varies with touchpad manufacturers. So I went to Costco where I bought this laptop, I honestly told them, there are no problems within the preinstalled Windows system, however, my initial purpose in buying this machine was to install a Linux system, but the touchpad of this machine unluckily is not fully compatible with the Linux. I also told them, The same parts of the Lenovo computers may come from different manufacturers and some work well with Linux, some not, so I asked them if they could trade me another one if I were lucky enough, may it be perfecto. They agreed and wish me luck. Guess what, when I came home and check the touchpad device, it shows a different type, even if there is no obvious manufacturer displayed, but it is absolutely different from the previous one (MSFT, I think). Then I installed the Manjaro KDE, no more tunes, and no need to upgrade to other kernels, just runs perfectly, other distros did the same. So lucky !!! Anyway, hopefully, you would fix the problem asap.

I fixed my unresponsive touchpad issue in Manjaro. I’ll exhaustively explain how I solved the issue so a professional of some kind could read this and find a way to fix the problem for other people. I didn’t try to change anything about the software this time. Instead I changed the hardware. I went online, bought another touchpad, and installed it. It’s the same touchpad model as before, I just bought it directly from the manufacturer (CNY) who also supplied the same part to Lenovo. I didn’t want to do it, as the process was invasive, but I felt very frustrated by the issues I was having with it so I took the risk.
I have the 14 inch AMD 4700U version of this laptop. I bought it in February, and my touchpad is the “MSOFT” model.
I had to go into the BIOS, disable the battery, and take it out. Three out of four screws on the touchpad were easily accessible after taking out the battery, but one screw (just one!) required that I remove all the motherboard screws so I could lift the motherboard up and remove the final screw to install my new touchpad. After looking at the internals, and the differences between the old and new touchpad - I concluded that I might have been able to fix the problem in a less invasive way, but I already bought a replacement part, so dammit, I was going to use it.
I noticed three things which might be of use to other people with the same problem:

  1. The ribbon that connected the touchpad to the motherboard wasn’t inserted properly. The fins were supposed to be completely inserted into the plastic clamp, but instead just the tip was in. It’s possible the problem I was having was caused by the ribbon simply not being connected properly.
  2. The touchpad model was exactly the same as the previous one. Every manufacturing code was precisely the same, except for one. The old touchpad had a generic looking ribbon connecter, while the new touchpad had a purple-colored ribbon connector that was manufactured in Hamburg, Germany. I’m guessing the ribbon made in Hamburg was of a higher quality. It’s a separate part from the touchpad itself, so I think Lenovo decided to cheap out on this part. It’s possible other people might be able to solve their issue by replacing this ribbon with a better one.
  3. The new touchpad I had was manufactured in early January, while the previous one (if I remember correctly) was manufactured in the middle of last year. It’s possible they engineered out the problem by now, although there was no indication on any code that a revision was made.

My touchpad had a few issues even in Windows. It would glitch sometimes, or the cursor would disappear, meaning that not even Windows would detect it. The new touchpad feels more responsive. If you’re having the same issue, you could likely get the touchpad fixed under warranty. I could have as well, but then again I’m also very stupid. The issue was noticeable but not that bad in Windows, so I figured that Lenovo might have refused to do anything about it while I was out of a laptop for a month waiting for them to figure out what they wanted to do.

I mentioned the hardware a lot here, so how could a change in hardware fix the problem when the difference between Linux and Windows is software? I’m guessing the problem was actually primarily hardware- but Windows was programmed to manage erratic or faulty inputs to compensate for crappy hardware. Linux hardware does tend to be a bit more high-end. Sometimes the touchpad would work in Linux, it was just very unreliable and unpredictable- which is how a hardware issue would behave, as a small vibration could cause the connector to connect just right or just wrong. If you don’t mind removing the back panel and the battery, it’s possible you could solve the issue yourself if all you did was either replace the ribbon connector or reinsert it. Replacing the entire touchpad would be a pain, but you might not need to go that far. If you do intend to fiddle with the hardware at all, I’d recommend buying a repair kit and a few extra screws for this model before you start. I tried all the software related fixes to no avail (with the exception of compiling my own kernel), and this worked for me. Try all the less invasive options first, and move to the more invasive options. Unfortunately, I had to go all the way and change out everything. (Also, if you’re going to take the back panel off, you might as well buy and install an Intel AX200 Wifi/Bluetooth Card, it’s a lot faster and more reliable than the crappy stock Realtek- only about 20 bucks, totally worth it. Some people have reported issues with the stock Realtek card with Linux.)

1 Like

I am so grateful to you for taking the time to post this, and with such detail. I had put mine aside, but before that I had noticed that my touchpad worked only if the computer had been off for a really long time (Like more than a week) and that it only worked for that session. During one of those times I saved some logs and I also have the MSOFT model. I think I will try to get it fixed under warranty, although right now I’m in the middle of replacing an 11-year old motherboard in my desktop, and my brain can barely handle one thing at a time. I will follow up to let folks know whether I am successful with the warranty bid, and if not, how I fared following your method. (You call it stupid, I’d say you were pretty inspired!) Thanks again.

I was worried that Lenovo would only accept a warranty claim if the issues pertained to Windows rather than Linux, because if they only tested the issue in Windows they might not be able to reproduce the issue. But if you don’t mind being without this laptop for a while, then go for it- if Lenovo messes with it first, they might just throw their hands up and replace the entire touchpad. The only reason I was comfortable taking apart my computer was because my mom has a medical electronics degree, and I could always ask her for help with anything electronics related in case I messed anything up. If the problem with your laptop is Lenovo’s assembly issues or their crappy ribbon connector, they might not be able to fix anything. If that’s the case, I can send you a link to the parts I bought. Got them all off of Amazon.

Hi I wanted to update to confirm rtj503’s experience-- Thanks to their generous post and advice, I have my laptop fully functional at last. Thank you rtj503! I found your comments and links extremely helpful! I would just add, to anyone in a similar situation and willing to risk an attempt, you really may want to have extra screws at the ready. Two of the screws holding the touchpad were cross-threaded, and I ended up having to get special bits for removing stripped screws and extra screws to replace them.

If you don’t have at least a hobbyist’s experience with computer innards (that’s all I’ve got), it would probably be worth returning for a new one, But I am happy that it wasn’t a Manjaro, or even a Linux problem. And VERY grateful to the Manjaro community!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.