Lenovo IdeaPad 330 WiFi issues

Hey all! My Lenovo IdeaPad 330 is having wifi problems. Connecting works fine and after connecting it works without issues for a random amount of time, after which transfer just stops. The connection stays active, and the wifi tray app blinks between a few hundreds of bytes per second and nothing at all. Reconnecting or turning wifi off and on resets the situation. May be completely unrelated, but the tray app also freezes for a few seconds whenever I try to do something in this state.
I remember seeing a bunch of issues around the web related to this Aetheros chip the laptop is using, they mostly talked about changing back to older firmware version, I tried that, didn’t solve my issue.
Below is the system info:

System:    Kernel: 5.14.10-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
           Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
           Distro: Manjaro Linux base: Arch Linux
Machine:   Type: Laptop System: LENOVO product: 81DE v: Lenovo ideapad 330-15IKB serial: <filter>
           Chassis: type: 10 v: Lenovo ideapad 330-15IKB serial: <filter>
           Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <filter> UEFI: LENOVO v: 8TCN58WW
           date: 06/18/2020
Battery:   ID-1: BAT0 charge: 24.1 Wh (94.5%) condition: 25.5/35.0 Wh (73.0%) volts: 8.4 min: 7.6
           model: LGC L16L2PB3 type: Li-poly serial: <filter> status: Charging
Memory:    RAM: total: 7.68 GiB used: 3.66 GiB (47.6%)
           RAM Report: permissions: Unable to run dmidecode. Root privileges required.
CPU:       Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Kaby Lake
           note: check rev: A cache: L2: 6 MiB bogomips: 28808
           Speed: 800 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 1633
           5: 1106 6: 2801 7: 3299 8: 2262
           Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art avx avx2
           bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de
           ds_cpl dtes64 dtherm dts ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
           fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid
           invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc
           nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti
           pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2
           ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi
           vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel bus-ID: 00:02.0
           chip-ID: 8086:5917 class-ID: 0300
           Device-2: IMC Networks EasyCamera type: USB driver: uvcvideo bus-ID: 1-8:8
           chip-ID: 13d3:5a02 class-ID: 0e02 serial: <filter>
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting
           alternate: fbdev,vesa resolution: 1: 1600x900~60Hz 2: 1600x900~60Hz s-dpi: 96
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.2.3
           direct render: Yes
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel
           v: kernel bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
           Device-2: Razer USA Kraken 7.1 Chroma type: USB
           driver: razerkraken,snd-usb-audio,usbhid bus-ID: 1-3:4 chip-ID: 1532:0504
           class-ID: 0300
           Sound Server-1: ALSA v: k5.14.10-1-MANJARO running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo
           driver: r8168 v: 8.049.02-NAPI port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8168
           class-ID: 0200
           IF: enp1s0 state: down mac: <filter>
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lenovo
           driver: ath10k_pci v: kernel bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280
           IF: wlp2s0 state: up mac: <filter>
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter>
           IP v6: <filter> type: dynamic noprefixroute scope: global
           IP v6: <filter> type: noprefixroute scope: link
           IF-ID-1: virbr0 state: down mac: <filter>
           IP v4: <filter> scope: global broadcast: <filter>
           WAN IP: <filter>
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-7:7
           chip-ID: 0cf3:e500 class-ID: e001
           Report: rfkill ID: hci0 rfk-id: 7 state: down bt-service: enabled,running rfk-block:
           hardware: no software: yes address: see --recommends
Logical:   Message: No logical block device data found.
RAID:      Message: No RAID data found.
Drives:    Local Storage: total: 238.47 GiB used: 174.47 GiB (73.2%)
           ID-1: /dev/sda vendor: SK Hynix model: HFS256G3BTND-N210A size: 238.47 GiB
           speed: 6.0 Gb/s type: SSD serial: <filter> rev: 1P10 scheme: GPT
           Message: No optical or floppy data found.
Partition: ID-1: / size: 233.43 GiB used: 174.47 GiB (74.7%) fs: ext4 dev: /dev/sda2 label: N/A
           uuid: 0ef36afe-dcb4-4314-aac3-d8defcace511
           ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat dev: /dev/sda1
           label: N/A uuid: 4726-5F2C
Swap:      ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile
Unmounted: Message: No unmounted partitions found.
USB:       Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 speed: 480 Mb/s
           chip-ID: 1d6b:0002 class-ID: 0900
           Device-1: 1-1:2 info: [Maxxter] USB GAMING MOUSE type: Mouse,Keyboard
           driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s power: 100mA
           chip-ID: 18f8:1286 class-ID: 0301
           Hub-2: 1-2:3 info: Genesys Logic Hub ports: 4 rev: 2.1 speed: 480 Mb/s power: 100mA
           chip-ID: 05e3:0610 class-ID: 0900
           Device-1: 1-2.2:5 info: HUION 420 type: Mouse,HID driver: uclogic,usbhid interfaces: 3
           rev: 1.1 speed: 12 Mb/s power: 100mA chip-ID: 256c:006e class-ID: 0300
           Device-2: 1-2.4:9 info: Razer USA BlackWidow Ultimate 2013 type: Keyboard,Mouse
           driver: razerkbd,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s power: 100mA
           chip-ID: 1532:011a class-ID: 0300
           Device-3: 1-3:4 info: Razer USA Kraken 7.1 Chroma type: Audio,HID
           driver: razerkraken,snd-usb-audio,usbhid interfaces: 4 rev: 2.0 speed: 12 Mb/s
           power: 200mA chip-ID: 1532:0504 class-ID: 0300
           Device-4: 1-7:7 info: Qualcomm Atheros type: Bluetooth driver: btusb interfaces: 2
           rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 0cf3:e500 class-ID: e001
           Device-5: 1-8:8 info: IMC Networks EasyCamera type: Video driver: uvcvideo
           interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 13d3:5a02 class-ID: 0e02
           serial: <filter>
           Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s
           chip-ID: 1d6b:0003 class-ID: 0900
           Hub-4: 2-2:2 info: Genesys Logic hub ports: 4 rev: 3.0 speed: 5 Gb/s
           chip-ID: 05e3:0616 class-ID: 0900
Sensors:   System Temperatures: cpu: 37.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 267 Uptime: 1h 59m wakeups: 13 Init: systemd v: 249 Compilers: gcc: 11.1.0
           clang: 12.0.1 Packages: 1661 pacman: 1641 flatpak: 13 snap: 7 Shell: Bash v: 5.1.8
           running-in: konsole inxi: 3.3.08

I have the same adapter on my other laptop. I used to have weird issues, but haven’t in a long time.

Maybe try setting the regulatory domain:


I’ve set it to the appropriate country. We’ll see if this does anything. Problem is I can’t exactly test this, so I guess I’ll just have to wait. But I’ll keep this in mind, thanks.

Nope, sadly it’s definitely still broken.

Try a different 5 GHz channel on your router. I seem to remember having issues with higher freqencies.

Tried that one too, and although lower ones seemed to make it a tad bit more stable, it didn’t solve it.