Left control key issues in Cinnamon after update

Hi there,

after the last updates (08/2022) I have issues with my left control key. Copy via CTRL+C etc. works, but some applications (e.g. games) do not recognize the left control key at all. The right one is working.

xev gives me:

FocusOut event, serial 39, synthetic NO, window 0x5200001,
    mode NotifyUngrab, detail NotifyPointer

FocusIn event, serial 39, synthetic NO, window 0x5200001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 39, synthetic NO, window 0x0,
    keys:  204 0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0  

Instead of the usual KeyPress event I have these FocusIN/OUT events, so it seems like some other application grabs the control key first. But I have checked it double: there is no custom keyboard binding for ctrl and nothing unusual running in the background.

Since it works in gnome and budgie but not in cinnamon, it must be strongly bounded to cinnamon DE. I have created a fresh user with empty config - same issue. Kernel doesn’t seem to make any difference either. Changed to another keyboard hardware – same issue. If I bind swap capslock and control in the advanced settings: same issue, but now at the “capslock” button.

I have started an manjaro cinnamon usb-live stick from earlier this year – there it worked! So i tried to export the keymap and import it to my regular system: doesn’t work.

And so at this point I’m out of ideas. I really love Manjaro cinnamon for many years now – but being unable to use the left ctrl button in games is really annoying. I would really appreciate any hints and ideas from you.

Well, your analysis that something is grabbing the key is indeed what I suspect to be the case, and this something must then be one of the processes you’ve got running in the background.

The fact that you can swap the Ctrl key with Caps Lock and that it then happens to the Caps Lock key instead confirms that the key works and that whatever’s grabbing it is not actually reading the raw scan code from the keyboard — which is what the kernel does — but that it instead intercepts the specific assignment of whatever your desktop environment considers to be the left Ctrl key.

Perhaps the culprit is a process that you started earlier and closed but that somehow refuses to actually terminate properly — a game, maybe? — or maybe it’s one of the things running in your system tray. :thinking:

As I understand xlsclients gives me a list with possible processes grabbing the keys. Output is


I tried to kill every single one of them (of course some will terminate my whole session/terminal) and still the issue remains. Even after a clean reboot, with no custom autostart processes. :thinking:

Is there any way I can investigate further?

Well, I’m not a Cinnamon user, so I don’t recognize all of the processes you’ve listed here, but could it be that the key is defined in the keyboard settings as a compose key for typing compound characters, or perhaps as a trigger for switching between keyboard input levels? :thinking:

No chance. I investigated via xdotool key XF86LogGrabInfo and could not find anything.

One thing actually worked: downgrading cinnamon, cinnamon-session, cinnamon-desktop, cinnamon-settings-daemon, cinnamon-menus. Not the best solution. I have no idea what else I could do.

I have the same issue. After upgrading to cinnamon-5.4.10, my left CTRL-key showed the described behaviour. This breaks some shortcuts and causes dropdowns to close when pressing e.g. CTRL+V for inserting due to the focus loss of the window. This happens on both my work laptop and private PC with different sets of programs installed and directly after login without any extra programs running.

Downgrading just cinnamon-5.4.10 to cinnamon-5.4.9 resolved the issue.
I opened an issue with cinnamon: [BUG] Left Control key removes focus from active window, then refocuses it · Issue #11079 · linuxmint/cinnamon · GitHub


Same bug for me as well.

Same for me. I opened a Cinnamon issue on this. Basically I noticed on all my systems ( two desktops, two laptops, three virtuals ) this behavior.

On my home desktop I have an old HDD that was my install before moving to SSD some time back. I use it for config file changes or whatnot instead of my main install and possibly borking something.

It was on Cinnamon 5.4.3 and it worked fine. I updated it and left Ctrl was broken. I also have KDE on that install and it still works fine, and worked before the update as well.

I tested with kernels 5.15, 5.10, and 5.4

can you guys try the 5.4.10-3 package I just pushed to all branches?


Looks like 5.4.10-3 has fixed it. It’s working on my work and home desktops and a virtual. I do appreciate it. I use left Ctrl quite a lot! More than I realized until it was not working. :stuck_out_tongue: Thank ya for pushing that out

Thanks so much for the fixed package!

For the interested: The problem was that the left ctrl key was grabbed by cinnamon for the “locate mouse pointer” option even if this option was not enabled (Mouse and Touchpad → Mouse → Show position of pointer). This upstream commit fixed that: locatePointer: Only grab the keybinding if the feature is enabled. · linuxmint/cinnamon@aab79cc · GitHub


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.