LED Microphone Mute issues with different Kernel versions

On my LENOVO T14s (AMD) Gen 1. the LED (F4) indicating the Microphone Mutehas been working properla. With some update it did not light any longer and somebody adviced me that this may be based on the Kernel. With the actual UPdate 09.08.2021) I noticed this difference:

  • OLD: Kernel Version: 5.10.53-1-MANJARO (64-bit) → LED permanently OFF
  • NEW: Kernel Version: 5.10.56-1-MANJARO (64-bit) → LED permanantly ON

The microphone itself including muting / UNmuting is working properly, it’s only an issue with the LED.

I can’t any longer reply to this:
But this is to confirm, that the Microphone Mute LED works fine since Kernel 5.15.38-1-MANJARO (linux515)
Thanks to everybody, who has been working on this!

Have you tried any other kernels yet? 5.4 and 5.14 would be high on my list…


Thank you @Fabby,

Have you tried any other kernels yet? 5.4 and 5.14

Not yet and as I’m using Manjaro since very few months, I’ve no idea, how to to this; actually I’m searching a tutorial

If you’re new, go to your launcher and type or look for kernel. That should brighten your day!


Thanks again @Fabby,
started kernel earleir, this shows the installed versions, allows to remove some. But I don’t see an option to choose a different one. I’m thinking about the boot options

Have a look over at the wiki and if you get stuck there, let us know which exact item you’re stuck at.



Thank you @Fabby,

mhwd-kernel --listinstalled
Currently running: 5.10.56-1-MANJARO (linux510)
The following kernels are installed in your system:
   * linux510
   * linux54

During boot, I went to options and chose the 5.4 version. Then startup is delayed by start-jobs for three USB-devices, that are not mounted actually as they are used for Backups only. Back to Kernel 5.10, there is no issue like that.

Did you forget to test 5.14 Stable?


Thank you @Fabby, no, this …

… was on purpose: On my system 5.14 is experimental (ref. screenshot) and I feel not experienced enough, to try that.

Any idea about the issue with 5.10? The USB-drives are defined in /etc/fstab:

UUID=7f13008d-50e6-4eec-9503-efd757892494  /media/myBook8_A ext4   auto,nofail,rw,async,users    0 0
UUID=1e05302f-ee5e-4a82-9c45-fa05d2146162  /media/myBook8_B ext4   auto,nofail,rw,async,users    0 0
UUID=4bb7051f-0059-4b3d-918e-8d5a97c56a0e  /media/HDD2go    ext4   auto,nofail,rw,async,users   0 0

Probiere mahl 5.13!
In that case, try 5.13 first then…


Not without both:

  1. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.
  2. a sudo lsblk


Thanks, here we go …

$ inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 5.10.56-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=3fb81935-3c2a-4b83-ae67-7b8f75e23839 rw text apparmor=1 
  security=apparmor resume=UUID=338139c5-0361-42c0-9573-dbd00f711a01 
  udev.log_priority=3 noplymouth acpi_backlight=none 
  Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: LENOVO product: 20UH001QGE v: ThinkPad T14s Gen 1 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 20UH001QGE serial: <filter> UEFI: LENOVO 
  v: R1CET60W(1.29 ) date: 11/30/2020 
  ID-1: BAT0 charge: 45.9 Wh (87.1%) condition: 52.7/57.0 Wh (92.4%) 
  volts: 12.9 min: 11.5 model: SMP 5B10W139 type: Li-poly serial: <filter> 
  status: Charging cycles: 205 
  RAM: total: 30.65 GiB used: 2.88 GiB (9.4%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 8-Core model: AMD Ryzen 7 PRO 4750U with Radeon Graphics bits: 64 
  type: MT MCP arch: Zen 2 family: 17 (23) model-id: 60 (96) stepping: 1 
  microcode: 8600106 cache: L2: 4 MiB bogomips: 54324 
  Speed: 2101 MHz min/max: 1400/1700 MHz boost: enabled Core speeds (MHz): 
  1: 2101 2: 1931 3: 1662 4: 1910 5: 1487 6: 1459 7: 1469 8: 1450 9: 1746 
  10: 1664 11: 1617 12: 1618 13: 1598 14: 1692 15: 1397 16: 1532 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy 
  constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs irperf lahf_lm 
  lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx 
  nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter 
  pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni 
  popcnt pse pse36 rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sha_ni 
  skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor 
  svm svm_lock syscall tce topoext tsc tsc_scale umip v_vmsave_vmload vgif 
  vmcb_clean vme vmmcall wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel bus-ID: 06:00.0 
  chip-ID: 1002:1636 class-ID: 0300 
  Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo 
  bus-ID: 2-2:2 chip-ID: 13d3:5405 class-ID: fe01 serial: <filter> 
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa 
  display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 158 size: 309x173mm (12.2x6.8") 
  diag: 354mm (13.9") 
  OpenGL: renderer: AMD RENOIR (DRM 3.40.0 5.10.56-1-MANJARO LLVM 12.0.1) 
  v: 4.6 Mesa 21.1.6 direct render: Yes 
  Device-1: AMD vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 06:00.1 
  chip-ID: 1002:1637 class-ID: 0403 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo 
  driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x bus-ID: 06:00.5 
  chip-ID: 1022:15e2 class-ID: 0480 
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus-ID: 06:00.6 chip-ID: 1022:15e3 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.56-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.33 running: no 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8169 v: kernel port: 2400 bus-ID: 02:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp2s0f0 state: down mac: <filter> 
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 2000 
  bus-ID: 03:00.0 chip-ID: 8086:2723 class-ID: 0280 
  IF: wlp3s0 state: up mac: <filter> 
  IP v4: <filter> type: noprefixroute scope: global broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 6-4:3 
  chip-ID: 8087:0029 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 2.05 TiB used: 987.11 GiB (47.1%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung 
  model: SSD 970 EVO Plus 2TB size: 1.82 TiB block-size: physical: 512 B 
  logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> 
  rev: 2B2QEXM7 temp: 48.9 C scheme: GPT 
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: SanDisk model: USB 3.2Gen1 
  size: 232.88 GiB block-size: physical: 512 B logical: 512 B type: N/A 
  serial: <filter> rev: 1.00 scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 32 GiB size: 31.25 GiB (97.65%) used: 27.28 GiB (87.3%) 
  fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:3 label: Manjaro 
  uuid: 3fb81935-3c2a-4b83-ae67-7b8f75e23839 
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) 
  used: 17.5 MiB (3.4%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  label: UEFI-ESP uuid: F8E8-132F 
  ID-3: /home raw-size: 32 GiB size: 31.25 GiB (97.65%) used: 9.69 GiB (31.0%) 
  fs: ext4 dev: /dev/nvme0n1p4 maj-min: 259:4 label: home 
  uuid: 36be0edf-49c4-4ee0-96a3-4da6bc64a86c 
  ID-4: /home/<filter>/VirtualBoxVMs raw-size: 300 GiB 
  size: 294.29 GiB (98.10%) used: 122.5 GiB (41.6%) fs: ext4 
  dev: /dev/nvme0n1p5 maj-min: 259:5 label: Virtual 
  uuid: c29b5da5-b959-4989-87ed-6db493b9c3a0 
  ID-5: /mnt/Daten raw-size: 1.21 TiB size: 1.19 TiB (98.35%) 
  used: 786.51 GiB (64.8%) fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:7 
  label: Daten uuid: 249b9b5a-332c-4176-8a2e-9cef91138ce6 
  ID-6: /run/media/myname/ventoy raw-size: 228.84 GiB 
  size: 228.84 GiB (100.00%) used: 41.12 GiB (18.0%) fs: exfat dev: /dev/sda1 
  maj-min: 8:1 label: ventoy uuid: 896D-52F3 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 64 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p2 maj-min: 259:2 label: Swap 
  uuid: 338139c5-0361-42c0-9573-dbd00f711a01 
  ID-1: /dev/nvme0n1p6 maj-min: 259:6 size: 200 GiB fs: ext4 label: TimeShift 
  uuid: ee73659c-5cf3-46d2-a7c8-29db485d1b85 
  ID-2: /dev/sda2 maj-min: 8:2 size: 32 MiB fs: vfat label: VTOYEFI 
  uuid: 909C-8E10 
  ID-3: /dev/sda3 maj-min: 8:3 size: 4 GiB fs: ext4 label: TestDaten 
  uuid: 5f88b7c6-5417-4f7f-884b-40a5f588b9b0 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 1 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 2-2:2 info: IMC Networks Integrated Camera type: Video 
  driver: uvcvideo interfaces: 5 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 13d3:5405 class-ID: fe01 serial: <filter> 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 4-3:2 info: Alcor Micro AU9540 Smartcard Reader type: Smart Card 
  driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 50mA 
  chip-ID: 058f:9540 class-ID: 0b00 
  Hub-5: 5-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-6: 6-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 6-3:2 info: Synaptics Prometheus MIS Touch Fingerprint Reader 
  type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 06cb:00bd class-ID: ff00 serial: <filter> 
  Device-2: 6-4:3 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb 
  interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0029 
  class-ID: e001 
  Hub-7: 7-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Device-1: 7-2:2 info: SanDisk Ultra type: Mass Storage driver: usb-storage 
  interfaces: 1 rev: 3.2 speed: 5 Gb/s power: 896mA chip-ID: 0781:5581 
  class-ID: 0806 serial: <filter> 
  System Temperatures: cpu: 65.9 C mobo: 0.0 C gpu: amdgpu temp: 46.0 C 
  Fan Speeds (RPM): cpu: 2800 
  Processes: 343 Uptime: 30m wakeups: 1 Init: systemd v: 248 tool: systemctl 
  Compilers: gcc: 11.1.0 Packages: pacman: 1506 lib: 395 Shell: Bash v: 5.1.8 
  running-in: konsole inxi: 3.3.06

and the second part:

$ sudo lsblk
sda           8:0    1 232,9G  0 disk 
├─sda1        8:1    1 228,8G  0 part /run/media/myname/ventoy
├─sda2        8:2    1    32M  0 part 
└─sda3        8:3    1     4G  0 part 
nvme0n1     259:0    0   1,8T  0 disk 
├─nvme0n1p1 259:1    0   512M  0 part /boot/efi
├─nvme0n1p2 259:2    0    64G  0 part [SWAP]
├─nvme0n1p3 259:3    0    32G  0 part /
├─nvme0n1p4 259:4    0    32G  0 part /home
├─nvme0n1p5 259:5    0   300G  0 part /home/myname/VirtualBoxVMs
├─nvme0n1p6 259:6    0   200G  0 part 
└─nvme0n1p7 259:7    0   1,2T  0 part /mnt/Daten

Try 5.13 first and if that doesn’t solve the problem, try 5.14 RC3.

Note: Don’t delete 5.10; just add 5.13 and 5.14 and try them out by going to the advanced options of grub and see if the problem goes away automagically
If it doesn’t, remove them again…


This system has a setting in ALSA for the LED - ‘Mute-LED Mode’
I would expect it to take the first available option by default (On) unless it is set to a specific option by user

This command should change the LED setting to show when sound is muted

amixer --card=2 sset 'Mute-LED Mode' 'Follow Master'

The terminal response should confirm the new setting:

HW probe of Lenovo ThinkPad T14s Gen 1 … #67d6c15711: amixer

Simple mixer control 'Mute-LED Mode',0
  Capabilities: enum
  Items: 'On' 'Off' 'Follow Master'
  Item0: 'On'

But this on Lenovo forum suggests there may be a bug in firmware
P14s/T14s AMD, MIC mute LED stopped working.-English Community

1 Like

Done this, the response is a bit different:

$ amixer --card=2 sset 'Mute-LED Mode' 'Follow Master'
Simple mixer control 'Mute-LED Mode',0
  Capabilities: enum
  Items: 'On' 'Off' 'Follow Master'
  Item0: 'Follow Master'

The LED behaviour is as before:

  • Kernel Version: 5.10.53-1-MANJARO (64-bit) → LED permanently OFF
  • Kernel Version: 5.10.56-1-MANJARO (64-bit) → LED permanantly ON
  • Kernel Version: 5.10.59-1-MANJARO (64-bit) → LED permanantly ON

Done that, no changes for the LED:

  • Kernel Version: 5.10.53-1-MANJARO (64-bit) → LED permanently OFF
  • Kernel Version: 5.10.56-1-MANJARO (64-bit) → LED permanantly ON
  • Kernel Version: 5.10.59-1-MANJARO (64-bit) → LED permanantly ON
  • Kernel Version: 5.13.11-1-MANJARO (64-bit) → LED permanantly ON

I do not dare to use version 5.14 as it is experimental …

I have edited my previous post because the URL to the hardware probe was for an T14s model with an Intel CPU not a AMD Ryzen
I could not find a match for your model number and must have copied the URL from the wrong tab

But I have noticed many of the other T14s models have 4 options for the LED

Simple mixer control 'Mic Mute-LED Mode',0
  Capabilities: enum
  Items: 'On' 'Off' 'Follow Capture' 'Follow Mute'
  Item0: 'Follow Mute'

I suspect your ALSA option ‘Follow Master’ would only indicate if audio playback is muted

try this command to see if LED changes when audio playback is muted [off] or unmuted [on]

amixer -c2 'Master' toggle
1 Like

Sorry, this provides an error:

$ amixer -c2 'Master' toggle
amixer: Unknown command 'Master'...

I missed the key part of the command :man_facepalming:

amixer -c2 sset 'Master' toggle

If the LED is not following the control on the card it might be following the default PulseAudio level control

amixer sset 'Master' toggle
1 Like

Thank you @nikgnomic
$ amixer -c2 sset 'Master' toggle
toggles the F1-LED, indicating the speaker’s muting. The F1-LED is working correct for each process to mute / unmute the speakers (F1, System control, etc.)

1 Like

Try these commands one at a time to see if there are any errors

amixer -c2 sset 'Mic Mute-LED Mode' 'Follow Capture'
amixer -c2 sset 'Capture' nocap
amixer -c2 sset 'Capture' cap

If the Mic Mute LED was working for you on kernel v5.4 you should roll back to that kernel

1 Like