League Of Legends lutris stopped launching

Hi guys!

So… I always played league of legends a lot on mine linux manjaro and I never had a lot of problems, I always managed to play and the game always opened correctly…

However, last week, the game has simply stopped opening, that is a very strange thing, and since then I have been trying to get it to work.

How it’s happening here: Click play -> black rectangle -> lol logo appears -> 2 minutes later the logo disappear and all the processes closes -> button appearing “play” again.

I’ve been testing different things, and i think the problem can be with the Riot Client, because whenever I close this process the game opens, but without the chat or asking me to leave the game and open it again.

I don’t know if i installed some packages that it’s causing conflicts or troubles with lol, but it’s a very strange thing. Does someone here knows if lol stopped to work in every linuxes?

Today i made sudo pacman -Syyu and updated everything, i tried to install some packages like lib32-gst-plugins-base-libs, lib32-gtk3, lib32-libxslt, lib32-opencl-icd-loader, lib32-v4l-utils, lib32-libcurl-gnutls

I’m here guys, to ask you all a help to know what is the problem and how to fix him, please :frowning:

This is the logs when i try to run league of legends with lutris:

Running /home/pedroegg/.local/share/lutris/runners/wine/lutris-lol-5.5-2-x86_64/bin/wine /home/pedroegg/Games/league-of-legends/drive_c/Riot Games/League of Legends/LeagueClient.exe
Initial process has started with pid 10352
Game is considered started.
esync: up and running.
000000.001|   OKAY| Running from cwd 'C:\Riot Games\League of Legends'.
000000.001| ALWAYS| Application Version:10.19.336.497 - CL:3360497 - Build Date:Sep 15 2020 - Build Time:20:14:07
000000.002|   OKAY| Initial working directory: "C:\Riot Games\League of Legends"
000000.002|   OKAY| Current process: "C:\Riot Games\League of Legends\LeagueClient.exe"
000000.002|   OKAY| Command line arguments:
000000.004|   OKAY| Enabling Data API Dradis collection with endpoint: https://ekg.riotgames.com/messages
000000.009| ALWAYS| The following message is prepared to be sent to dradis:
Event Name: riot__rclient__event
common.os_platform: Windows
common.application_name: LeagueClient
common.application_version: 10.19.336.497
common.cef_version: 74.1.19+gb62bacf+chromium-74.0.3729.157
common.installation_id: p673Zg==
common.locale: pt_BR
common.os_version_major: 10
common.machine_id: Mxxm7pIjf0aqb19r6X8aEg==
common.os_edition: Ultimate N, x86
common.os_version_minor: 
common.region: BR
common.session_id: 5b6c6176-8a48-bd49-81ea-31e4bffbede7
event_name: startup
crash_reporter: crashpad
000000.009| ALWAYS| Queued Dradis event to be sent.
000000.010| ALWAYS| Direct Launch enabled for league_of_legends.live in environment 'live' for app path 'C:\Riot Games\League of Legends\LeagueClient.exe' and install dir 'C:\Riot Games\League of Legends'
000000.011| ALWAYS| Found associated Riot Client install (C:/Riot Games/Riot Client/RiotClientServices.exe)
000000.029|   OKAY| Launched Riot Client with process 59
000000.029| ALWAYS| Riot Client started. Exiting with the expectation of being restarted (ExitForDirectLaunch).
000006.330|   OKAY| EventCollector: 0 events remaining after thread join
000006.330|   OKAY| Shut down EventCollector in 1313 milliseconds
Initial process has exited.
Game is considered exited.
All monitored processes have exited.
Exit with returncode 0

You all can ask me to test different things or ways to open the game :slight_smile:

Huh.
It seems to do this and the expected exit, but not restart?
(no idea if it should be doing that … but it says expectation…)

Where is your Riot client from? Is it an AUR package?

If it is … you probably need to rebuild it.

I use yay as my AUR helper … so a full update would be

sudo pacman -Syyu && yay -Sua --devel

(--devel is included for things like git packages)

If you dont use an AUR helper … and in fact in most basic installs … you can probably just do

pamac update -a

(the -a should include AUR)

1 Like

Yes, i don’t know what is this, but if i check the processes, the Riot Client it’s already open, and if i kill him, the logo appears very quickly, lol open but with no connection to chat or the game asks me to restart.

My League of legends it’s from lutris, all the downloaded things. I didn’t downloaded nothing from AUR to play league of legends.

And thanks! I can try run these commands and try to run the game again

Maybe we do a full mirror sort first.

sudo pacman-mirrors -f && pamac update -a

I would say as first check (or rather just a double-check) we run that.

If no change … I might start hitting the lutris/LoL/Wine boards for specifics …

1 Like

I already run pacman -Syyu today before, so i tried to just run the yay -Sua --devel, but just these options appeared:

12  aur/burpsuite                  2020.5.1-1 -> 2020.9.1-1
11  aur/electron4                  4.2.12-4   -> 4.2.12-6
10  aur/exif                       0.6.21-1   -> 0.6.22-1
 9  aur/libnvidia-container        1.1.1-1    -> 1.3.0-1
 8  aur/libnvidia-container-tools  1.1.1-1    -> 1.3.0-1
 7  aur/nvidia-container-toolkit   1.1.1-2    -> 1.3.0-1
 6  aur/openrazer-daemon           2.7.0-1    -> 2.8.0-1
 5  aur/openrazer-driver-dkms      2.7.0-1    -> 2.8.0-1
 4  aur/openrazer-meta             2.7.0-1    -> 2.8.0-1
 3  aur/python-openrazer           2.7.0-1    -> 2.8.0-1
 2  aur/razergenie                 0.8.1-1    -> 0.9.0-1
 1  aur/xdg-su                     1.2.3-1    -> 1.2.3-2

I don’t think that i need to update these packages, do you think? If yes i will do

Yes but I cannot be sure your mirrors were good, thus the above commands :wink:

I would say you should update those.
(after you make sure you are fully up to date after checking mirrors)
Especially since there seem to be some about drivers and more.

1 Like

Okay. I will do that. But… What should pamac -a do? Here just printed the same of pamac --help haha

oops. forgot the ‘update’

sudo pacman-mirrors -f && pamac update -a

:sweat_smile:

1 Like

Looks like i found a solution! Thank you very much!

Why i can’t post links here?

Link (Put the reddit main url together with that below):

r/leagueoflinux/comments/j07yrg/starting_the_client_script/

I’m doing more tests and i will mark these answer as solution if it’s everything okay.

I’ve done not all updates you asked me (but i was doing), my linux crashed due to high usage of memory i think(terminal + a lot of tabs firefox + spotify + lutris + several softwares) haha, but i will check if the solution it’s really that link

For now, it’s okay! The game finally opened and with chat and other things! Now i will try to play and test other things

Thanks :slight_smile:

Ah. So the client is broken. heh. Well. good on that other user for posting the fix :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.