LCD display wont wake up

I am new to Manjaro system, I came from Windows world. Manjaro runs fine, but I found one problem I need to solve.

The thing is, that when I turn pc as first and my screen as second, there is no image displayed on screen (its an LCD tv, so sometimes I forget to use remote to turn it on :smiley: ).
When I turn TV as first, PC as second, everything works okay.

Maybe its not clear, so I describe typical situation when it happens:
I come home, turn on PC on with button and go make cofee. When I come back, I realize I didn´t turn on the screen :smiley: but when I turn it on, it stays black and nothing happens and I have to use reset button. After reset everything is okay, screen displays, linux runs.
When I turn TV on and turn on PC after it, it runs okay. On Windows it worked fine even screen was turned on many minutes later.
Screen is connected via HDMI.
Can someone help please?

I can confirm that. I’ve got a regular monitor attached to my PC and if I forget to switch it on in the first place I have to reset the PC. The monitor is connected through DisplayPorts both in a graphic card and the monitor.
It didn’t use to be like that in the past but I can’t tell when it started.

1 Like

Now I tested it with Windows 11 (good thing is that GRUB remebers and boots automatically last OS which was used :slight_smile: )
I did it precisely same way.
First restarted from Manjaro to Win11, then turned PC fully off and TV screen too.After it i waited few minutes and turned PC on with button (but didn´t turn on TV with remote). Went make coffee :smiley: and when I returned, turned on TV with remote and what do you think? Desktop of Win11 welcome me again. So definitely it is some Manjaro or GPU driver thing.

I tried to connect via ssh (i didn’t enable it) and it told me Connection refused, next I tried ping and it answered properly, so under that black screen I assume system is running normally. Can someone help please???

yesterday I turned on monitor first and after it turn on pc and it works flawlessly. but I need it to work when monitor is not turned on.

only thing i can say about this is that instead of needing to reset the pc, try unplugging the displayport cable and re-plugging. It might make the monitor detected.

okay, but this is not permanent solution.I wont replug cable every time I forget to turn on the monitor, its kinda silly, don’t you think?

yes, it was only suggestion to maybe prevent need to push reset.

You have not given much details, not even what gfx card you use. But no matter with that, trying different kernel versions is probably first thing to try pinpoint possible location of issue.

6.1 is LTS and best if it works. 6.2 is latest and might fix if 6.1 won’t. And of course you can test/use much older LTS kernels all the way back to 4.19. If nothing else works, maybe even try 6.3RC

radeon rx 590 with amdgpu drivers :slight_smile: kernel 6.1.23-1, as I said before - when I turn monitor first, it is okay. When I boot windows 11 and turn on monitor later, it works too. On other PC with Win 8.1 it works too. I come home everyday and first thing is to turn pc on, make coffe and monitor I turn on later with remote. So it is important to get it work like this :smiley: its an everyday routine :smiley:

ok, it should be well supported, try switching to the different kernels i talked about.

okay, I didn’t do this never before, could it cause any problems to my system?

anything is possible, but there should not be any issue. From the boot menu you can still select the currently working version if the new ones you test fail to boot.

EDIT: I tried kernel 6.2, problem persists. Even reconnecting HDMI cable didn’t help.

so, go down the path. Maybe first try 6.3, then 5.15 5.10 5.4 4.19

Notice that if you want to boot the older versions than the highest one installed at the moment, you need to explicitly select it during boot from the boot menu. Otherwise it will continue booting with newest installed kernel version.

good notice, now I installed 6.0.5 realtime and still running on 6.3.

tested 6.3, 6.2, 6.0.5, 5.15.106 and problem still persists.

Same here, but has been so for over a year since when I had a ‘new’ display and used DP to connect. Not considered an issue by me though.

for me it is issue. I have tv instead of monitor, so I have to turn it on by remote everytime. And everytime I forget :smiley: on windows it was never a problem, when I turned on tv later than pc, desktop appeared everytime.

well you still have 3 kernels to test, after that troubleshooting gets harder.

I still think that is some issue of gpu driver.maybe some setting? is any way to configure amdgpu via terminal?