Layout Switcher has problem after Manjaro 20.1.1 upadate

Gnome and Tiling layout are not shown in Manjaro Gnome

Thank you for reporting!

Fixing tonight. Which branch is this?

1 Like

@MDIntisar are you using stable? As stated as on the forum?

1 Like

It is stable.

Yes, this is the stable branch.

The fixed version should already be in git, but it seems I uploaded an old commit by accident. Or maybe I didn’t commit the changes to git… :thinking:

1 Like

The problem is solved.

2 Likes

Applying Tiling does not seem to do anything. Any docs on how it works?

1 Like

It should install the material-shell extension if it is not installed, enable it and disable incompatible extensions. My guess is that the installation part does not happen. Can you run gnome-layout-switcher from terminal, enable tiling and post the output here? Thank you for reporting the problem!

2 Likes

The installation part doesn’t happen in my experience. I had to manually install the extension from the https://extensions.gnome.org. Then it worked.

When I installed the extension from the manjaro repository, tile layout didn’t work from the switcher.

xxxx@magaryss-20041 Linux 5.8.11-1-MANJARO x86_64 20.1.1 Mikah
~ >>> gnome-layout-switcher
current layout: manjaro
active layout: material_shell
disabled dash-to-dock@micxgx.gmail.com
disabled appindicatorsupport@rgcjonas.gmail.com
enabled material-shell@papyelgringo
Layout applied

I already installed the material-shell and its dependencies, but even so the theme is not applied correctly

after installing it (material-shell), I used Alt + F2 and using the “r” command, the material-shell was included in the extensions. Now it works normally. Remembering that I had to install the material-shell manually

Material shell has been added to the dependencies of Manjaro-gnome-assets

2 Likes