Launching apps from taskbar - colors off, can't see icons... permissions issue

When I launch this app for instance from the command line, and others as root:


The colors are correct. However if I run


Not only can I not set ‘theme’ colors, but the app is all white on white background, and I can’t see any icons, or menu choices.
This is a problem first because I don’t want to have to get to a prompt, sudo and enter password every time I run the app, but I can’t launch the program off the taskbar (as sudo won’t work this way)
The same appears to be going on with this Manjaro forum, when I launch the hyperlink to the site from the Manjaro taskbar, all the icons (edit, emoticon, share link) are white-on-white, and invisible.

Program launched off Manjaro taskbar - where is everything?

Program launched off command line as root:

Its weird that its a permissions issue, but in any case I don’t see any background/foreground font color settings in the shortcut taskbar for Manjaro.
Anyone have any ideas?

You’re not supposed to run any common applications as root. The root account is not to be used in vain. It is too easy to mess up your system that way if you don’t know what you’re doing, and even for your system to get compromised.

The issue is obviously one related to the theme you’re using, but you’ve neglected to mention what desktop environment you’re running.

There is no such thing. Some desktop environments and window managers may have a task bar, others may have a task bar widget placed on a panel, or they may have a dock, but there is no such thing as the Manjaro task bar, because Manjaro does not have a default desktop environment.

The three official editions are Manjaro GNOME, Manjaro Plasma and Manjaro XFCE, and then there are the various community editions, such as Manjaro MATE, Manjaro Cinnamon, Manjaro Budgie, Manjaro Deepin, Manjaro LXDE, Manjaro LXQt, and so on. And all of them are different from one another.

Returning to the issue of the application, considering that you’re unable to change the theme in it, you are obviously running one of the GTK-based environments ─ i.e. GNOME, Budgie, Cinnamon, MATE, XFCE or LXDE ─ while deepin-draw is a Qt-based application. Qt and GTK don’t work well together, so you’ll need to install qt5ct from the repository and use that to set the theme for Qt-based applications.

sudo pacman -Syu qt5ct

If the above command also updates your system, then let it finish completely. Do not power off the machine or hit the reset button.

I think I may have the qt4ct repository (qt4 4.8.7.-33) already installed.
Will it cause a conflict, or can they both be installed at the same time?
And yes its Cinnamon, and I’ve already reinstalled from Gnome. Not starting over again lol.

Looks possible.

The app you need is qt5ct, currently at version 1.1-1.

Qt4 and Qt5 can coexist, yes, but Qt4 is no longer supported. Please note that the Ubuntu post you are linking to is from 2013, when Qt5 was still new.

Ran that command and it said it was already up to date, ran only for a few seconds.
Now what? Everything still is white-on-white, unless apps are run as root. Which of course I don’t want to do.

qt5ct is a configuration utility for Qt-based applications, which your deepin-draw is. So you have to use qt5ct to select a suitable theme and/or color scheme, and then this will apply to all Qt applications.

you have to use qt5ct to select a suitable theme and/or color scheme, and then this will apply to all Qt applications.>

I have no idea how to do this. There is a ‘QT5 Settings’ option in the menu, but nothing changed there has any effect on the apps. They still show white-on-white, no matter what they are set to.
There is this error message:

I also get this error message when app was run from the command line, that does NOT come up when the same app is run as root from the command line:

$ deepin-draw %u

(deepin-draw:4142): dbind-WARNING **: 08:25:55.102: Couldn’t register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

what a pain

Yes, most of the paint applications have invisible toolbar icons, no matter what I do. They are all white-on-white, no matter what preference setting is picked.
The QT5 settings application, has no effect.
What’s more, when I open the QT5 Settings app, the window is too large to view the “Apply” button, which is now off the bottom of the screen.
But… conveniently… there is no MAXIMIZE option in the window, only minimize, and close.
If I minimize, and right click–> MAXIMIZE, it has no effect.

Who would program these apps to do this? Its seems like unnecessary punishment.

Understood this is an Ubuntu article, but beggars can’t be choosers. At least it discusses one of the paint applications that has all defunct icons.
The person claims you must install the ‘breeze’ theme. Which I have.
Then specifically says, “qt5ct must NOT be installed”
I guess I can try uninstalling it again, but that would get me back to where I started.
Has nobody seen this happen before?

Here’s the QT5 configuration tool, now that I set the variable in environment, as it asked.
The window size has blown up permanently, so there is no access to the “Apply” button at bottom of window. And yet it can’t be maximized, as that option is missing, and can’t be drag resized either to show the bottom of the window.
Looks like all options to proceed have been blocked.
Why would they make a configuration tool, but then make it impossible to apply settings?

Try holding down the Alt key and dragging the window upward in order to reach Apply. Then you can do the same for dragging it down far enough to reach the window close button.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.