Latte Dock not launching after update

Using Latte Dock, and after updating my system earlier today it doesn’t launch. It won’t open/show up after using a terminal to launch it, using things like latte-dock --replace, -d and --c don’t do anything. Also firefox is kinda laggy. Is there a way for me to roll back the update, or to get it to work. Any ideas?

Plasma: 5.23.5, KDE frameworks version: 5.90.0, QT version: 5.15.2, Kernal Version: 5.15.16-1-MANJARO 64 bit, Graphics platform: X11

Not possible on manjaro or any other rolling-release distribution.

What is the terminal output when you run these commands?

I don’t get a terminal output after running the commands, it is just blank. Same with running it. I checked system monitor in gnome to see if plasma had an issue, and it is running just not displaying. Stopping and restarting the process does nothing

Edit: bad timing to make this post it is late so will have to leave actual diagnosis until tomorrow after school, but I will stay updated on the thread and try what I can

Did you checked on setting>startup and shutdown>Autostart ??

Everything seems normal. Latte is under autostart as it was before. Everything seems the same. The kvantum theme I used before gave the error “QT.svg: /.config/Kvantum/Layan-solid/Layan-solid.svg:6534:6: Could not resolve property: #radial
Gradient1988”, so I changed it to a different one and it doesn’t do that anymore.

OK, the issue has been fixed. I removed files in ~/.config/latte related to the layout, restarted, and it apeared with a blank layout. I think it was how I had added a new dock recently, but I didn’t think that was the issue. Perhaps it was, idk.