Latte-Dock no transparency or zoom effect on kwin_x11

Hello Manjaro Community!

My latte-dock has a weird way to respond to me.
When accessing the settings, the first screen I see is this:


Image1

When clicking on the top left corner Where “latte” is barely seen, it suddenly transforms to this:


Image2

And suddenly all options to customize my dock vanished. Any changes done in the second options menu do not apply.

Also when running kwin_x11 the dock has greyed-out options at transparency and background settings.


Image3

Only when simultaneously running picom or xcompmgr, they get “unlocked”.
But Picom and xcompmgr force transparency on my applications-menu and that’s why I don’t want to run them.


Image4

$ inxi -Gxx | grep compositor
       Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: intel resolution: 1: 1366x768~60Hz 2: 1920x1080~60Hz

Please don’t do such mixes … I think it was told to you already in the previous topic, in some other words.
Make sure you set the rendering backend for Compositor to OpenGL 3.1 (your iGPU must be capable of that - otherwise will not work) and that the Translucency effect is enabled. Try with different Plasma Style and Widget Style too.

I was having the same issue until I came across this post and found out after double checking my compositor, my compositor crashed and was no longer enabled at startup. I’d check if this is the issue for you, if “Enable compositer on startup” is still checked in your kde system settings