Latte Dock (git) doesn't show up even if i --replace it

Hi,
I recently uninstalled the normal latte dock version and tried out the git version. However, when I did so, I’d encounter many problems: I’ll try to explain as best as I can here and give you guys as much context as English isn’t my mother language.

Before installing the GIT version, I also came across a few bugs on the normal latte dock version which I didn’t really think much of. Things like dock/panel not switching, options not working etc.

Once I got to the GIT version (to use floating docks/ more settings etc) the dock wouldn’t show up. I thought it was because of the layouts I had previously installed on the normal version (layouts that consisted of floating docks). I managed to load the dock by simply using the --default-layout command and deleted the layouts that I had installed. However, even after rebooting my device, latte would still not work. Instead I’d get a message on the terminal that an instance of latte is already running. Forgot to mention that before anything, latte(?) would load a wide notification panel on the right of my screen and then close it but no docks would appear afterwards. Still happens to this day. Someone on reddit told me that it could be a buggy widget. However the problem did not end there. Even when I got to load the dock using only the default layout, I’d try to add any new widgets but the widget panel wouldn’t appear. Even If I wanted to customize the dock, once I clicked on the advanced options slider on the top right of the latte settings panel, the panel would simply crash along with the dock. I am out of ideas. I tried --replacing. I tried any possible commands. Even tried debugging but nothing worked to my favour. Apart from all of that, whenever I use any latte-dock related command I get this error:
Icon theme “Numix-Circle” not found.

Invalid Context= "Legacy" line for icon theme:  "/usr/share/icons/Adwaita/8x8/legacy/"
Invalid Context= "Legacy" line for icon theme:  "/usr/share/icons/Adwaita/16x16/legacy/"
Invalid Context= "UI" line for icon theme:  "/usr/share/icons/Adwaita/16x16/ui/"
Invalid Context= "Legacy" line for icon theme:  "/usr/share/icons/Adwaita/22x22/legacy/"
Invalid Context= "Legacy" line for icon theme:  "/usr/share/icons/Adwaita/24x24/legacy/"
Invalid Context= "UI" line for icon theme:  "/usr/share/icons/Adwaita/24x24/ui/"
Invalid Context= "Legacy" line for icon theme:  "/usr/share/icons/Adwaita/32x32/legacy/"
Invalid Context= "UI" line for icon theme:  "/usr/share/icons/Adwaita/32x32/ui/"
Invalid Context= "Legacy" line for icon theme:  "/usr/share/icons/Adwaita/48x48/legacy/"
Invalid Context= "UI" line for icon theme:  "/usr/share/icons/Adwaita/48x48/ui/"
Invalid Context= "Legacy" line for icon theme:  "/usr/share/icons/Adwaita/64x64/legacy/"
Invalid Context= "UI" line for icon theme:  "/usr/share/icons/Adwaita/64x64/ui/"
Invalid Context= "Legacy" line for icon theme:  "/usr/share/icons/Adwaita/96x96/legacy/"
Invalid Context= "UI" line for icon theme:  "/usr/share/icons/Adwaita/96x96/ui/"
Invalid Context= "Legacy" line for icon theme:  "/usr/share/icons/Adwaita/256x256/legacy/"
Invalid Context= "Legacy" line for icon theme:  "/usr/share/icons/Adwaita/512x512/legacy/"
Invalid Context= "Legacy" line for icon theme:  "/usr/share/icons/Adwaita/scalable/legacy/"
Invalid Context= "UI" line for icon theme:  "/usr/share/icons/Adwaita/scalable/ui/"

It’s possible cached templates still exist for the old version. Try either clearing your ~/.cache dir or launching the new install of latte with the -cc flag (just once)
latte-dock --cc

I think I cleaned some files yesterday after looking around I uninstalled latte and then I ran the command yay -Sc and then I reinstalled it. It loaded normally and those layouts I thought I had deleted were still there. Even so, after trying to use advanved settings It will crash. I will try out the command you told me to tho

UPDATE: The command didn’t work. I also cleared my cached. It launched normally but advanced settings would not load. Should I maybe try to install an older version of latte?

UPDATE: the error i get on the terminal says something about something called “Adwaita”. I noticed that this is a pack of icons I, for some reason, have in my system. It might be a default pack because I am also unable to delete it.