Latest updates fail due to a conflict

Hey just wanted to inform you guys that the latest batch of updates due to fail due to a conflict

could not satisfy dependencies:
- installing pacman (6.0.2-18) breaks dependency 'pacman-contrib' required by pacui
- if possible, remove pacui and retry

Hi @gameslayer9999,

There’s your answer. Just install it again afterwards.

… another variant:
looking up the dependencies of pacui - it does not seem to require pacman-contrib
so removing pacman-contrib would also appear to work

I saw that but it’s a workaround for the issue and I wanted to report the problem so it can be resolved without having to manually do that

Hmm I don’t even have pacman-contrib installed, wonder why it is saying that

Not really, as the announcement said:

1 Like

I’d have thought so - that is how I interpreted that.

If I try to install pacman-contribs I run into this issue

Resolving dependencies...
Checking inter-conflicts...
Failed to prepare transaction:
could not satisfy dependencies:
- unable to satisfy dependency 'pacman' required by pacman-contrib
- removing pacman breaks dependency '' required by libpamac
- removing pacman breaks dependency 'pacman>5' required by yay

Ahh right I see, but due to this other conflict it seems a bit of a messy issue at least with my case



But it was announced that there might be some manual intervention necessary…

Yeah seems like I had to remove pacui and bmenu and would remove packages that relied on it to resolve the issue at least so far, I am downloading the updates now

Yep working now! :smiley:

1 Like

If you had looked at the Stable Updates thread, then you would have seen that there was no need to remove anything. pacman-contrib is a spin-off from the pacman package, and thus the dependencies have changed. All you needed to do was… :point_down:

sudo pacman -Syu pacman-contrib

That would have updated your system and installed pacman-contrib all in one go.

While you’re at it, also tend to your .pacnew files, because there’s quite a few with this update. And you should merge them, not blindly copy them over, because then you won’t be able to log in anymore.


Same here when the red Update icon appeared and I ran it. Seems like this is a total system re-install, because when I did this as recommended:

sudo pacman -Syu pacman-contrib

It took a long time, and I’ve captured the Terminal log of it if anyone’s interested. Now I’m going to reboot and hope this PC’s still alive. Hope this gets fixed at some point so the GUI can handle it w/o the CLI method.

Anyway, thanks for the post and helpful replies. :slightly_smiling_face:

1 Like

Its a regular system update, the only extra being it pointing at that package (so update system while installing X). Not ‘whole system reinstall’ or anything all that different from any update.

1 Like

Thanks cscs. It took a long time, with many (most) of my apps reinstalling along with a lot of apparently system stuff. Anyway, I came back here mostly to thank everyone and report that the system seems to have rebooted normally, the red update Panel icon went away all by itself too. Me: happy. :slightly_smiling_face:

1 Like

Also just to add I hardly read the announcements on the forum that said I was just reporting the issue to help get it resolved and not cause this issue for future users upgrading as users will now have to manually intervene especially new users who might not know about this or the fix you have to manually do or I will have to do for some family members/clients

Thanks for the replies and the solution @Aragorn :wave: :smiley:

1 Like

pacman-contrib was not installed on my system but as recommended by the error message I removed
pacui and also its’ dependency bmenu which worked out for me then.

Noted. You’d have saved yourself the trouble if you did. As would everyone else who did.


Do I need to reinstall them though? I needed to remove pacui and updlockfiles

You’re asking us if you need some package? How should we know?