Latest update -> No nVidia -> How to install? I'm confused

I saw an update notification (31 Dec 2020). Updated to the latest release. Found no Nvidia driver (GeForce 930m) installed. Tried to install via Settings but out of luck. Now I’m confused how to install! Please help…

Solution: A newbie (like me) friendly Guide for nVidia-prime Drivers
In short, With new update of Manjaro there are no more packages with different version names like nvidia-455xx, nvidia-450xx etc. It is simply one package. So to anyone who was running hybrid-intel-nvidia graphics, after updating OS just uninstall nvidia-455xx-utils (in my case it was 455xx, replace with yours) and install nvidia-utils via Pamac. After that, install the driver via Manjaro Settings Manager or run sudo mhwd -a pci nonfree 0300. Probably you will need a restart. And finally issue solve… Thanks…

1 Like

Please read this post below… :arrow_down:

It was mentioned in the announcement for the 2020.12.30 update. :arrow_down:

1 Like

Solved… Thanks…


Thank you, that worked for me!

I’m on stable branch to avoid these probs :frowning:


what should be done with other nvidia-utils packages,like mentioned in this thread:

lib32-nvidia-utils 455.


If you’ve updated to latest Manjaro, probably unnecessary Nvidia drivers are uninstalled already. You have to install lib32-nvidia-utils and linux5x-nvidia (if not installed already).

You mentioned lib32-nvidia-utils, I think 455 is probably the version number. Yes, you need this package to be installed. And linux5x-nvidia-455xx this is the package name. Remove that and install linux5x-nvidia (current version will be 455.xx.xx-x like this).

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.