Latest update attempt: python package errors

Attempting current updates on my system throws these messages:

*Starting full system upgrade...*
  • :: Replace python-dbus with extra/dbus-python? [Y/n] *
  • :: Replace python-dbus-common with extra/dbus-python? [Y/n] *
  • :: Replace python2-twisted with extra/python-twisted? [Y/n] *
  • resolving dependencies…*
  • looking for conflicting packages…*
  • :: dbus-python and python2-dbus are in conflict. Remove python2-dbus? [y/N] *
  • error: unresolvable package conflicts detected*
  • error: failed to prepare transaction (conflicting dependencies)*
  • :: dbus-python and python2-dbus are in conflict*

Any ideas appreciated…

test with y

1 Like

having the same issue as @lagagnon when trying to run updates on Octopy.
after this python things, the update attempt ends with a
error: failed to prepare transaction (could not satisfy dependencies),
and it doesn’t matter wether I answered Y or N to all of the questions regarding python above.
any clue? is there any way to just skip this and move on forward with the rest?
thanks

Not sure if this is your problem as well: I sorted out my python problems when I realized the package “radiotray” was causing the problems. I removed radiotray and all worked fine. I probably could have reinstalled radiotray but never used it so it’s gone for good.