Latest update 2023-06-04 broke VRR support

Update went ok, system is still working. But after the update VRR is no longer working on my monitor in games. Usually the screen would flicker once when starting a game and VRR would be turned on. (and I could confirm that VRR was on in the monitors settings. But now it’s just locked on 120hz and VRR off.

I’m using Gnome with X11 and this statement in xorg.conf
Option “VariableRefresh” “true”

I have been running it like that, for getting VRR to work in games. And it has worked fine up until now.

I was thinking it was a Gnome issue, and it propably shiftet over to wayland but that was not the case. Still thinking it was gnome I ran my cinnamon desktop instead (Cinnamon only uses X11 and is using it’s own compositor (muffin). But VRR still does not work.

I’m wonderring what package update broke VRR and would just like to downgrade it. I also have a system backup but would like to try something else before i pull that trigger.

I would suspekt it to be an xorg or mesa update that is the problem.

Thise where the only xorg pakages updated:
xorg-setxkbmap 1.3.3-2 1.3.4-1
xorg-xcalc 1.1.1-1 1.1.2-1
xorg-xdpyinfo 1.3.3-4 1.3.4-1
xorg-xinput 1.6.3-3 1.6.4-1

And thise the only mesa pakages:
lib32-mesa-demos 8.5.0-1 9.0.0-1
lib32-mesa-utils 8.5.0-1 9.0.0-1

My specs:

Running stable Manjaro
AMD CPU Ryzen 5 1600AF
Driver: Mesa
Kernel: 6.3.5
Desktop Gnome and also have cinnamon.

Any solution or suggestion is highly appreciated.

You can return your system with Time Shift to previous version of Manjaro and have to update without file xdg-desktop-portal-gnome because the bug is there and all be fine. :slightly_smiling_face:

1 Like

Would it work if I just downgraded that specific pakage (xdg-desktop-portal-gnome). Just that my system backup is little over a week old.

you can switch to testing branch and try if the mesa update there fixes things. else you can also go to unstable and see if Gnome 44.2 updates fixes things. Switching Branches - Manjaro

1 Like

Maj be. I didn’t try this solution. But the update is from 04.06., i.e. before 2 days.

Here some info more about VRR and Gnome 44: GNOME releases version 44 []

Hey guys.

So i tried downgrading both xdg-desktop-portal-gnome and then later also xdg-desktop-portal to the previous version. This did not solve the problem however. So decided to just use timeshift and roll the system back. But as it so happens it just made a new backup today and deleted the older one that I needed. And I only keep one backup at a time as to not use up a lot of space. Doh

I still have the option to go to testing or unstable but I think I’m just gonna wait it out for a bit and see if the next couple of updates fixes it, before I try anything else. VRR is not really “mission critical” after all.

I want to thank you guys for your time and help.

So I have been looking into this problem a little more. I have now tried the testing branch which did not have any update at the time since the new mesa driver was already pushed to stable. So I also tried unstable branch. Alot of updates here… Still the problem is the same.

I can see many are having problems with this update in relation to xdg-desktop-portal packages. But I dont think that is the problem here.
Because i found this bug report on gnomes gitlab page that fits perfectly
regression: broken vsync and VRR for fullscreen windows in XOrg session (#2794) · Issues · GNOME / mutter · GitLab

They suggest it is related to GTK , which may explain why I’m seeing this bug on the cinnamon desktop also.
I’m not sure, maybe you guys can tell me? :slight_smile:

So how do I get around this? Should I downgrade Gnome to version 43? and how do I do this with all the dependencies?? does the downgrade program take dependencies into account?

I have learned one thing from all of this. Always make a manual backup of the system before a big update. :rofl:

Again all suggestions are highly appreciated.

There is nothing you can do currently to fix it. The mentioned MR in the bug report is only part of the solution, as it fixes tearing in full screen videos, but not the broken Vsync in full screen games.

To test if VRR is working you can install and run vrrtest from the AUR, in my case it still works even without the MR applied to mutter.

The only workaround for now is to use Wayland, which has no VRR support, until they fix the Xorg issues in GTK4, Mutter etc…