Latest system upgrade broke WiFi

I made a pacman -Syyu some weeks ago and after a reboot my Network Manager doesn’t get any wlan network (eth still working tho).

rfkill list gives:

0: tpacpi_bluetooth_sw: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

No WLAN listed…

lscpi -kvv gives me a WiFi controller but it seems it doesn’t use any driver compare to some others (I don’t know if it was like that before…):

00:14.3 Network controller: Intel Corporation Alder Lake-P PCH CNVi WiFi (rev 01)
	Subsystem: Intel Corporation Device 0090
	Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at 603d1cc000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel modules: iwlwifi
OS: Manjaro Linux x86_64 
Host: 21BVCTO1WW ThinkPad T16 Gen 1 
Kernel: 5.15.104-2-MANJARO 
Uptime: 31 mins 
Packages: 1470 (pacman) 
Shell: fish 3.6.1 
Resolution: 1920x1080, 1920x1080 
WM: i3 
Theme: Adwaita [GTK3] 
Icons: Adwaita [GTK3] 
Terminal: kitty 
CPU: 12th Gen Intel i7-1260P (16) @ 4.700GHz 
GPU: Intel Alder Lake-P 
Memory: 4178MiB / 31810MiB

Today I got a huge system upgrade (with linux-headers and may other packages but it still didn’t solve the problem…) so my system is up to date

Did you categorize the thread in AUR because you pulled the Wifi driver from there?

If so, have you tried rebuilding it?

Have you rebooted since the update?

I didn’t pull anything from the AUR, when I installed Manjaro around november last year, everything worked out of the box, no driver installation needed or whatsoever. It’s the first time I get a problem…
I categorized with AUR because I was thinking it was maybe related to an AUR package but not sure at all… Might be worth to remove the tag then?

I handled that.

Thanks for the tags. yes I have rebooted after this morning upgrade.

try with a different kernel, with the 6.1, and if it doesnt work, try with the 6.2 …
also fast startup disabled in windows if you are dual booting…

1 Like

Hi thank you for the tips, bumping kernel version to 6.1 works for me using the same wifi card.

Used the following command to bump kernel verison:

sudo mhwd-kernel -i linux61
1 Like

upgrading to 6.1 with @lavigne958 command

sudo mhwd-kernel -i linux61

fixed the wifi but now I get some drivers problems with displaylink (I’m using a D6000 dock) and I only have one screen detected (probably because of evdi version)…

So I downgraded back to 515 (5.15)

Not a viable solution for me…

However thanks for that!!