Latest Raspberry Pi image can not bei installed on 3/4

As the new images provide the new Kernel for Raspberry Pi 5. It’s will be installed on previous models as well. So I would suggest to split the images one for Raspberry Pi 3/4 and one for Raspberry Pi 5.

For workaround just use the previous image.

1 Like

I can not understand what you are trying to say with the title or the body of your post. The official Pi OS 64bit image boots 3b, 3b+, 3a+, 4b, 400, 5, cm3, cm3+, cm4, cm4s, and Zero 2 W.


It has 2 kernels kernel8.img and kernel_2712.img (pi5) and all of the .dtb,s for each board in the fat32 boot partition. Each device’s firmware at boot time should pick the correct .dtb, kernel and initramfs to boot with.

If you only use one device with the image you can always uninstall the kernel/kernel headers you will not use.

It does have a little bit different config.txt than before.

New config.txt

#Uncomment some or all of these to enable optional Hardware interfaces

#Run in 64bit mode

#Auto load correct initramfs files if found

#Run as fast as the firmware/board allows

#Disable compensation for displays with overscan

#Enable sound
#Uncomment if no sound thru hdmi

#Auto load overlays for detected cameras
#Auto load overlays for detected DSI displays

#Enable DRM VC4 V3D driver
#For pi4’s and above boards uncomment next line & Comment out above line

#Don’t have the firmware create an initial video= setting in cmdline.txt
#Use the kernel default instead

#Disable rainbow screen at boot

#RPi 5B/4B/400 ONLY
#For 4k content @ 60 Hz refresh rate, uncomment hdmi_enable_4kp60=1

If video breaks with hdmi_enable_4kp60=1 uncomment


#Enable host mode on the 2711 built-in XHCI USB controller
#This line should be remoed if the legacy DWC2 controller is required


I am talking about the Manjaro-ARM images.

23.02 → not working with Pi4/3
22.13 → works

If you use Manjaro arm installer you can see it install linux-rpi5 on this device which make the OS not bootable.

Right now you have to build using the unstable branch with manjaro-arm-tools buildarmimg until the new packages filter down through the branches. I have not tried the other installer (forget the name) to see what it does. I also will not try the 23.02 images as they are just too old. Right I only build fresh up to date images using the unstable branch.

manjaro-arm-installer is a different animal than manjaro-arm-tool’s buildarmimg I’m thinking that package needs updating. I do not maintain it. New DEV images (built on the unstable branch) are built here with buildarmimg every Monday with the latest updates for the week. Last I tried it worked ok.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.